Professional Web Applications Themes

asp problem in IIS5.1 - ASP Components

Hi All, I have windows XP with IIS 5.1. My IIS is working fine with HTML Pages.but it is not working with ASP pages. if i select a .html file as initial doent it is working fine. but if i select a .asp file as inistial doent it not working. I am getting the following error. page can not be displayed - if i enable display friendly http error messages. if i uncheck the "Display friendly http error messages" in internet explorer, i am getting the follwing error message. Server Application Error the server has encountered an error while loading ...

  1. #1

    Default asp problem in IIS5.1

    Hi All,

    I have windows XP with IIS 5.1. My IIS is working fine
    with HTML Pages.but it is not working with ASP pages. if i
    select a .html file as initial doent it is working
    fine. but if i select a .asp file as inistial doent it
    not working. I am getting the following error.

    page can not be displayed - if i enable display
    friendly http error messages.
    if i uncheck the "Display friendly http error messages" in
    internet explorer, i am getting the follwing error message.

    Server Application Error
    the server has encountered an error while loading an
    application during te pocessing of your request. please
    refer to the event log for more detail information. Please
    contact the server aministrator for assistance.

    in Event Viewer. if found following warning event.The

    Event ID:36
    Source:W3SVC

    server failed to load application '/LM/W3SVC/1/ROOT'. The
    error was 'Class not registered
    '.
    For additional information specific to this message please
    visit the Microsoft Online Support site located at:
    [url]http://www.microsoft.com/contentredirect.asp[/url].

    For more information, see Help and Support Center at
    [url]http://go.microsoft.com/fwlink/events.asp[/url].

    I checked in IIS for .asp association link (asp.dll) and
    it is there....

    I dont have any ideas to proceed funther... please help
    me...

    Thanks in Advance.,
    Vamsi.

    vamsi Guest

  2. #2

    Default Re: asp problem in IIS5.1

    have you searched support.microsoft.com yet? IIRC this is answered there
    very clearly. search on the error message





    ________________________________________
    Atrax. MVP, IIS
    [url]http://rtfm.atrax.co.uk/[/url]

    newsflash : Atrax.Richedit 1.1 in beta with Mozilla-compatibility.
    [url]http://rtfm.atrax.co.uk/infinitemonkeys/components/Atrax.RichEdit/[/url]

    *** Sent via Developersdex [url]http://www.developersdex.com[/url] ***
    Don't just participate in USENET...get rewarded for it!
    Atrax Guest

  3. #3

    Default asp problem in IIS5.1

    vamsi,
    whether ur pronlem is solved....becoz i too ot struck
    in this problem....so it u got the soluction forward to me
    thankQ in advace
    -das
    >-----Original Message-----
    >Hi All,
    >
    > I have windows XP with IIS 5.1. My IIS is working
    fine
    >with HTML Pages.but it is not working with ASP pages. if
    i
    >select a .html file as initial doent it is working
    >fine. but if i select a .asp file as inistial doent
    it
    >not working. I am getting the following error.
    >
    > page can not be displayed - if i enable display
    >friendly http error messages.
    >if i uncheck the "Display friendly http error messages"
    in
    >internet explorer, i am getting the follwing error
    message.
    >
    > Server Application Error
    > the server has encountered an error while loading an
    >application during te pocessing of your request. please
    >refer to the event log for more detail information.
    Please
    >contact the server aministrator for assistance.
    >
    >in Event Viewer. if found following warning event.The
    >
    >Event ID:36
    >Source:W3SVC
    >
    >server failed to load application '/LM/W3SVC/1/ROOT'.
    The
    >error was 'Class not registered
    >'.
    >For additional information specific to this message
    please
    >visit the Microsoft Online Support site located at:
    >[url]http://www.microsoft.com/contentredirect.asp[/url].
    >
    >For more information, see Help and Support Center at
    >[url]http://go.microsoft.com/fwlink/events.asp[/url].
    >
    >I checked in IIS for .asp association link (asp.dll) and
    >it is there....
    >
    >I dont have any ideas to proceed funther... please help
    >me...
    >
    >Thanks in Advance.,
    >Vamsi.
    >
    >.
    >
    a k bhagwan das Guest

  4. #4

    Default Re: asp problem in IIS5.1

    Hi Vamsi,

    I think I may have a solution for you. I experienced the same problem
    and fixed it this way:

    Go to Settings/Control Panel/Administrative Tools/Internet Services
    Manager

    Select your Local Server (your computer name) properties

    In the Internet Information Services tab, Edit the Master Properties

    Select the Directory Security tab and Edit Anonymous Access and
    authentication control.

    In the Authentication Methods window, make sure Integrated Windows
    Authentication is selected then select Edit

    In the Anonymous User Account window, either type in your logon
    (Computername\username then password) or select Browse

    In the Select user window, set the location to the name of your
    computer/server name. Type in your username and click Check Names. It
    should list your fully qualified username. Click OK.

    Type in your Windows logon password, click ok and it will prompt you for
    the password again.

    Click OK in the Authentication Methods window.

    Click OK out of Master Properties, then your Local Server properties.

    This worked for me. I hope it works for you.

    Lynn Clark







    *** Sent via Developersdex [url]http://www.developersdex.com[/url] ***
    Don't just participate in USENET...get rewarded for it!
    Lynn Clark Guest

  5. #5

    Default Re: asp problem in IIS5.1


    "vamsi" <vamsinmyahoo.co.in> wrote in message
    news:1d4a301c4235f$82ee5820$a401280aphx.gbl...
    > Hi All,
    >
    > I have windows XP with IIS 5.1. My IIS is working fine
    > with HTML Pages.but it is not working with ASP pages. if i
    > select a .html file as initial doent it is working
    > fine. but if i select a .asp file as inistial doent it
    > not working. I am getting the following error.
    >
    > page can not be displayed - if i enable display
    > friendly http error messages.
    > if i uncheck the "Display friendly http error messages" in
    > internet explorer, i am getting the follwing error message.
    >
    > Server Application Error
    > the server has encountered an error while loading an
    > application during te pocessing of your request. please
    > refer to the event log for more detail information. Please
    > contact the server aministrator for assistance.
    >
    > in Event Viewer. if found following warning event.The
    >
    > Event ID:36
    > Source:W3SVC
    >
    > server failed to load application '/LM/W3SVC/1/ROOT'. The
    > error was 'Class not registered
    > '.
    > For additional information specific to this message please
    > visit the Microsoft Online Support site located at:
    > [url]http://www.microsoft.com/contentredirect.asp[/url].
    >
    > For more information, see Help and Support Center at
    > [url]http://go.microsoft.com/fwlink/events.asp[/url].
    >
    > I checked in IIS for .asp association link (asp.dll) and
    > it is there....
    >
    > I dont have any ideas to proceed funther... please help
    > me...
    >
    > Thanks in Advance.,
    > Vamsi.
    >

    Surya Guest

Similar Threads

  1. IIS5.0 with ORACLE 9.2
    By sgadge@yahoo.com in forum ASP Database
    Replies: 0
    Last Post: April 13th, 10:21 AM
  2. IIS5/Oracle 8.1.7 Problem
    By Larry DiGiovanni in forum ASP Database
    Replies: 0
    Last Post: September 26th, 03:37 PM
  3. WIN2k+IIS5+PHP-CGI
    By Adam in forum PHP Development
    Replies: 1
    Last Post: August 22nd, 11:39 AM
  4. Problem moving from IIS5 to 4
    By Phil in forum ASP Database
    Replies: 2
    Last Post: August 17th, 07:33 PM
  5. Replies: 2
    Last Post: July 23rd, 03:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139