Professional Web Applications Themes

Automation Error 0x8007045A in calling dll - ASP Components

I have an ASP page (VS 6) which calls a VB COM dll which in turn calls a third party dll that is the offical API for this third party application. My dll code works just fine in the VB debugger but when it runs in its compiled state, the code hits an error when it tries to instantiate the API dll: Error 0x8007045A. Description: Automation error A dynamic link library (DLL) initialization routine failed. Both dlls are registered and I should emphasize that the error is NOT raised in the ASP page (which is usually where one has problems) ...

  1. #1

    Default Automation Error 0x8007045A in calling dll

    I have an ASP page (VS 6) which calls a VB COM dll which in turn calls a
    third party dll that is the offical API for this third party application. My
    dll code works just fine in the VB debugger but when it runs in its compiled
    state, the code hits an error when it tries to instantiate the API dll:

    Error 0x8007045A. Description: Automation error
    A dynamic link library (DLL) initialization routine failed.

    Both dlls are registered and I should emphasize that the error is NOT raised
    in the ASP page (which is usually where one has problems) but in the wrapper
    dll. I've scoured the web for more info on this error and see one or two
    people have suffered a similar problem when they have an ASP page calling a
    wrapper dll which in turn calls another dll. But I didn't see any solutions
    that worked. Thinking this might be some kind of permissions issue I tried
    giving the IUSER AND IWAM accounts administrator privileges but I still get
    the same error.

    I should add that I have no problem instantiating other dlls from ASP so
    there seems to be something weirdly different about this third party dll.
    However, if I build a VB executable which calls the API dll, it has no
    problem running in its compiled state. So there's something about the
    account under which ASP runs under which seems to be causing problems.

    Any ideas?

    Julian Brown Guest

  2. #2

    Default Re: Automation Error 0x8007045A in calling dll

    Have you been able to fix the problem you were having with the third party
    API dll. we are developing a web application that calls a vendor API
    using a VB6 wrapper. We are getting the "Automation error A dynamic link
    library (DLL) initialization routine failed". if you have had any success
    could you let me know what you did to fix the problem.

    LeeHowdeshell Guest

Similar Threads

  1. Acrobat Automation causes a COM error
    By Darryl_Blackwell@adobeforums.com in forum Adobe Acrobat SDK
    Replies: 1
    Last Post: August 31st, 03:53 PM
  2. Replies: 2
    Last Post: September 18th, 11:49 AM
  3. Automation Error '800a01b8'
    By Frank Drebin in forum ASP Components
    Replies: 1
    Last Post: August 19th, 10:43 PM
  4. Automation Error
    By Ken Snell in forum Microsoft Access
    Replies: 0
    Last Post: July 10th, 03:38 PM
  5. ASP.NET & Outlook automation error
    By matthew in forum ASP.NET General
    Replies: 0
    Last Post: July 7th, 01:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139