Professional Web Applications Themes

automount permissions problem - Debian

Here's my problem, maybe someone can help. I have a usb media reader than handles smartmedia, compact flash, etc. It works fine in the sense of being able to put media into it and mount the media, using the usb-storage module, and copy files off the media. The devices look like scsi disk drives, as expected with the use of usb-storage. It would be ideal to be able to use autofs to mount these drives, as I do for my dvd and cdrw drives, so I added the appropriate entries into auto.mount, the control file for my /mount automount directory. ...

  1. #1

    Default automount permissions problem

    Here's my problem, maybe someone can help. I have a usb media reader
    than handles smartmedia, compact flash, etc. It works fine in the sense
    of being able to put media into it and mount the media, using the
    usb-storage module, and copy files off the media. The devices look like
    scsi disk drives, as expected with the use of usb-storage.

    It would be ideal to be able to use autofs to mount these drives, as I
    do for my dvd and cdrw drives, so I added the appropriate entries into
    auto.mount, the control file for my /mount automount directory. It looks
    like this:

    # Automount map file
    # 6/4/02 nl
    #
    #format:
    # key [ -mount-options-separated-by-comma ] location
    dvd -fstype=iso9660,ro,nosuid,nodev,exec,user :/dev/dvd
    cdrw -fstype=iso9660,ro,nosuid,nodev,exec,user :/dev/cdrw
    floppy -fstype=vfat,nosuid,noauto,user,nodev,unhide :/dev/floppy
    cf -fstype=vfat,ro,nosuid,noauto,user :/dev/cf
    sm -fstype=vfat,ro,nosuid,noauto,user :/dev/sm

    /dev/cf and /dev/sm are symlinks to /dev/sda1 and /dev/sdb1.

    The media cards automount all right, but the protections on the
    directories created by autofs is rwxr--r--, which means I cannot cd into
    or list the files in subdirectories on the media unless I become root,
    which is not ideal. And that's the problem.

    I don't have this problem with automounted cd's or dvd's - the
    protection mask for those is rwxr-xr-x, so all works fine.

    Is there something I should have done in the auto.mount file? Is this
    something about the way the cf and sm cards work (they are formatted in
    a digital camera, so I don't really have any control over how various
    bits are set in the filesystem.

    Any thoughts/help appreciated.

    Thanks.
    nl



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Neal Lippman Guest

  2. #2

    Default Re: automount permissions problem

    On Sat, 2003-07-26 at 18:06, Shawn Lamson wrote:
    > On Sat, July 26 at 5:49 PM EDT
    > Neal Lippman <nllippman.org> wrote:
    >
    > >
    >
    > I don't use automount but to get proper permissions for my vfat fs's i
    > use this type or entry in fstab
    > /dev/hdb1 /mnt/win98 vfat defaults,gid=6,umask=002
    >
    > then as long as I am in group 6 ( disk on my box ) I have read access...
    > The key is the umask portion and equates to permissions of 775 or
    > rwxrwxr-x in case you aren't familiar with umask.
    >

    Ah...that makes sense. I will review mount options; I should be able to
    include any options mount accepts in the auto.mount file...hopefully
    this will work.

    nl


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Neal Lippman Guest

  3. #3

    Default Re: automount permissions problem

    Shawn Lamson wrote:
    > On Sun, July 27 at 12:51 AM EDT
    > Andreas Janssen <andreas.janssenbigfoot.com> wrote:
    >>I hope you know that being in the disk group as a user can be a severe
    >>security risk.It allows you direct read/write access to all your IDE
    >>and SCSI hard disk (for example with dd). If you are in group disk, the
    >>filesystem mechanisms that protect you from accidentially destroying
    >>your system can become useless.
    > Point taken - since this is my home box I do a lot of admin tasks under
    > my user id and am about as careful as I am with root. IIRC I did this
    > originally to allow myself to burn CD's and b/c I used my Windows HD's
    > as storage for music etc... and needed to access it frequently which is
    > not an admin function.
    This true, but

    You could use the cdrom group for writing CDs. Works perfectly with
    ide-scsi emulation as the /dev/scd* devices belong to the cdrom group.

    You do not need to be in the disk group to access the /filesystem/ on your
    windows partitions. As far as I know, you can use umask to allow write
    access to the filesystem for everyone without setting the gid. Or you
    could set the gid to the group your user is in, as you are the only human
    user on your system.

    best regards
    Andreas Janssen


    --
    Andreas Janssen
    [email]andreas.janssenbigfoot.com[/email]
    PGP-Key-ID: 0xDC801674
    Registered Linux User #267976


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Andreas Janssen Guest

Similar Threads

  1. Automount problem (structure below mount point)
    By Tim Day in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 15th, 11:05 AM
  2. automount and NIS issue
    By Binner in forum Linux Setup, Configuration & Administration
    Replies: 14
    Last Post: August 1st, 04:00 PM
  3. ted NFS & Automount hangs
    By Rubens S. Gomes in forum Sun Solaris
    Replies: 0
    Last Post: July 27th, 05:54 PM
  4. Automount
    By JZidar in forum Debian
    Replies: 5
    Last Post: July 4th, 05:20 PM
  5. automount on AIX 4.3.3
    By Steve Nottingham in forum AIX
    Replies: 0
    Last Post: June 26th, 10:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139