Professional Web Applications Themes

Basic Webpage runs slow on IE 7 - Macromedia Dynamic HTML

I'm trying to develop a prototype web page for my website. So far its nearly finished and runs fine on Firefox 2 and Opera 9, but falls to pieces on IE 6 and earlier and seems to make IE7 overload most pc's processors. Could someone give me some feedback on the code found at: http://www.csmayores.org.uk/csmark2 I've embedded the CSS code within the page's header so you can easily see it. This website is aimed at the elderly so all measurements are done using relative units (em) to allow browsers such as Firefox to resize the screen content proportional without loss ...

  1. #1

    Default Basic Webpage runs slow on IE 7

    I'm trying to develop a prototype web page for my website. So far its nearly
    finished and runs fine on Firefox 2 and Opera 9, but falls to pieces on IE 6
    and earlier and seems to make IE7 overload most pc's processors. Could someone
    give me some feedback on the code found at:
    http://www.csmayores.org.uk/csmark2
    I've embedded the CSS code within the page's header so you can easily see it.

    This website is aimed at the elderly so all measurements are done using
    relative units (em) to allow browsers such as Firefox to resize the screen
    content proportional without loss of integrity (So that the visually impaired
    can zoom in); could this be causing the problems?

    Thanks in advance

    Chopo

    Chopo^2 Guest

  2. #2

    Default Re: Basic Webpage runs slow on IE 7

    Your home page opens immediately on my IE7/WinXP system.

    None of the links are active, though.
    akribie Guest

  3. #3

    Default Re: Basic Webpage runs slow on IE 7

    The page opens relatively fast but do you not experience lagging as you scroll
    over the links, especially those on the Left hand side (The links are meant to
    be dead by the way as the page is just a prototype and the site hasn't been
    built). Maybe its just my system. I'll have to test it on more systems.

    Can anyone give me feedback on exactly what code needs changing for it to work
    on IE6?

    Thanks akribie BTW

    Chopo^2 Guest

  4. #4

    Default Re: Basic Webpage runs slow on IE 7

    It seems the source of the lagging on my system is the shadow on the background
    of the main text panel the ?mainPanelBG? div tag. The shadow is a png
    (Images/CSM_Shadow.png) with an alpha (transparency) channel. It is only 10px
    by 10px large, but I doubt its the image size that?s the problem but rather the
    fact that IE7 probably doesn?t do a very good job of tiling a transparent png
    background over another background. If it has to go, I?ll get rid of it, but it
    seems a shame, especially as all the ?proper? (ok I?m just kidding don?t slate
    me for microfobia) web browsers seem to cope fine with the webpage.

    To see the difference the lack of shadow makes try the following two versions
    of the website on IE7
    http://www.csmayores.org.uk/mark2_Shadow
    http://www.csmayores.org.uk/mark2_noShadow

    The problem is especially noticeable when scrolling up and down the webpage.

    I admit, some of the images need optimising, but I don't think this is
    contributing much to the problems I am experiencing as I have tested the page
    without the images. The one on the left margin is optimised as is the
    background (sort of, as I originally made it 2000 pixels long, this is just
    dumb and I am going to redesign the bottom and make it just 1000 pixels long.
    This should half the file size), the one that needs work on is the yoga session
    pic.

    Can anyone suggest any shadow workarounds for IE7 otherwise once I separate
    the CSS from the main webpage ill resort to using a different CSS doent
    without the shadow for IE.

    One solution I am working on is tiling the shadow on the Right hand side only
    along the y-axis. This seems to be working but it makes it more difficult to
    offset the shadow downwards as well as to the right; however this is a miner
    compromise.
    See it at:
    http://www.csmayores.org.uk/mark2_Shadow2

    Chopo

    Chopo^2 Guest

Similar Threads

  1. Flash player runs slow
    By cag175 in forum Macromedia Flash Player
    Replies: 2
    Last Post: October 14th, 02:57 PM
  2. projector runs very slow
    By yogeshhungama webforumsuser@macromedia.com in forum Macromedia Director 3D
    Replies: 0
    Last Post: October 10th, 09:41 AM
  3. #24580 [NEW]: sometimes script runs slow
    By longshot at home dot nl in forum PHP Development
    Replies: 0
    Last Post: July 10th, 09:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139