Professional Web Applications Themes

Bone driven animation issues - Macromedia Director 3D

Hello! Thought I'd start a topic regarding bone-related issues in Director, perhaps it would be beneficial not only to me but to anyone else having problems in that department. Issue #1 - does Director support bone stretching when exported out of 3D Studio Max? All of my tests show rotational and positional changes which work great, but any kind of stretching on bones does not export. Am I missing something, hopefully? It's essential for the face rig I'm working on (next issue) Issue #2 - I have a bone rig for facial animation. I am using dummy objects to move ...

  1. #1

    Default Bone driven animation issues

    Hello! Thought I'd start a topic regarding bone-related issues in Director,
    perhaps it would be beneficial not only to me but to anyone else having
    problems in that department.

    Issue #1 - does Director support bone stretching when exported out of
    3D Studio Max? All of my tests show rotational and positional changes which
    work great, but any kind of stretching on bones does not export. Am I missing
    something, hopefully? It's essential for the face rig I'm working on (next
    issue)

    Issue #2 - I have a bone rig for facial animation. I am using dummy objects
    to move bones. It's a pretty standard setup - the sample image is here:
    http://img.photobucket.com/albums/v203/anton980/3D%20Stuff/Face_Rig.jpg This
    poses a problem when I export the whole thing into Director, however. Either
    Director doesnt like the dummy objects and the animation doesnt get transfered,
    or the bones are not linked correctly to be used in Director. So I was
    wondering if anyone has had any experience setting up a similar rig and getting
    it to work in Director, or do I need to seek other methods to animate the face?

    Thanks for looking and thanks in advance for suggestions!

    Anton.

    anton980 Guest

  2. #2

    Default Re: Bone driven animation issues

    Issue #1 - all the SW3D exporters do not support bone stretching animations.
    Try to scale a bone of your own skeleton and see the result. :tounge;

    Issue #2 - if you're using dummy objects to move bones pay attention to the
    hierarchy!
    Also don't forget to group them all (including the mesh) before exporting.

    Nanomedia Guest

  3. #3

    Default Re: Bone driven animation issues

    [q]Originally posted by: Nanomedia

    Issue #2 - if you're using dummy objects to move bones pay attention to the
    hierarchy!
    Also don't forget to group them all (including the mesh) before exporting.[/q]

    Thank you very much for your response! Stretching bones would help me a lot
    for facial animations, but I guess I'll have to do without them.

    Regarding the dummy's place in the hierarchy - I cant just link a bone to a
    dummy, I need to go through position/look-at constraints and I had a feeling
    those wouldnt be carried over to Director, or does it matter? If I uploaded a
    file I'm working on, would you be able to see if you can get it to work with
    Director? Thanks!

    anton980 Guest

  4. #4

    Default Re: Bone driven animation issues

    If you're looking for bone stretching and facial animation, there're two
    methods:
    1) link few dummies to the bones chain (and you'll get a mixed keyFramePlayer
    / bonesPlayer animation).
    2) use bones only (you'll need more bones, but you don't need the
    keyFramePlayer).
    Augustin has a nice example (workaround) about "morphing":
    http://www.onwine.com.ar/demos/morphing.html

    cheers

    necromanthus Guest

Similar Threads

  1. 3D Bone Animation Exporter for Director MX
    By praesul in forum Macromedia Director 3D
    Replies: 5
    Last Post: January 11th, 11:43 PM
  2. Parent/Bone
    By otterman in forum Macromedia Director 3D
    Replies: 6
    Last Post: September 7th, 07:55 AM
  3. a bone to pick
    By JJBBDD in forum Coldfusion - Advanced Techniques
    Replies: 1
    Last Post: July 19th, 08:24 AM
  4. export only animation from Maya, RAM useage issues
    By jdoubles webforumsuser@macromedia.com in forum Macromedia Director 3D
    Replies: 1
    Last Post: November 26th, 03:47 PM
  5. Replies: 3
    Last Post: August 5th, 05:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139