Professional Web Applications Themes

Bones Problem - Macromedia Director 3D

Bones problem: I?ve been at this for a couple days with no success. I can?t get the bones animation to play in Director 11 or mx04. I have an elaborate model that has bones that doesn?t work in director so I went back to basics. I created a simple cylinder and then 2 connected bones. I animated the bones, attached them to the cylinder with the skin modifier (which is suppose to work in shockwave) and nothing. I then grouped the cylinder and bones together. I also made sure to name the bones with the root bone being the first ...

Sponsored Links
  1. #1

    Default Bones Problem

    Bones problem:
    I?ve been at this for a couple days with no success. I can?t get the bones
    animation to play in Director 11 or mx04.
    I have an elaborate model that has bones that doesn?t work in director so I
    went back to basics. I created a simple cylinder and then 2 connected bones. I
    animated the bones, attached them to the cylinder with the skin modifier (which
    is suppose to work in shockwave) and nothing. I then grouped the cylinder and
    bones together. I also made sure to name the bones with the root bone being the
    first thing in each name. The animation is working fine in max. When I trace
    the w3d properties in director it says the bones are there and the animation is
    playing. But no animation is visible in Director.
    Here are my files:
    Screen capture of the export settings:
    http://mdg.ext.msstate.edu/bones_help/export_settings.gif
    3d max file:
    http://mdg.ext.msstate.edu/bones_help/temp_bones.max
    Director 11 file:
    http://mdg.ext.msstate.edu/bones_help/temp_bones.dir
    W3d file:
    http://mdg.ext.msstate.edu/bones_help/temp_bones.W3D
    Director mx04 file just in case:
    http://mdg.ext.msstate.edu/bones_help/temp_bones_mx2004.dir

    Any help would be greatly appreciated



    Sponsored Links
    Khamul02 Guest

  2. #2

    Default Re: Bones Problem

    Your bones chain is uncomplete.
    Ungroup, create the 3rd bone, link the 3rd bone to the 2nd bone, group the mesh (cylinder) and the 3 bones and export the W3D file.
    That's all.

    cheers
    necromanthus Guest

  3. #3

    Default Re: Bones Problem

    AWSOME!! It would be nice if there was some doentation that says you need a
    minimum of 3 bones. Also, I noticed that if I animated the last bone in the
    chain nothing happened. It is alsmost like you need a dummy bone at the end of
    the link to get it to work. Many many thanks!!

    Khamul02 Guest

  4. #4

    Default Re: Bones Problem

    the last bone should recieve animation maybe its connected not to any vertices
    tyree_2 Guest

Similar Threads

  1. Lightwave 2 Shockwave Bones Problem
    By mbrown174 in forum Macromedia Director 3D
    Replies: 1
    Last Post: May 2nd, 01:58 PM
  2. Biped and Bones
    By greengnu in forum Macromedia Director 3D
    Replies: 1
    Last Post: April 8th, 03:13 PM
  3. Bones i 3d object
    By dyrwoolf in forum Macromedia Director 3D
    Replies: 3
    Last Post: January 18th, 08:02 AM
  4. bones get name
    By Boomy3D in forum Macromedia Director 3D
    Replies: 0
    Last Post: November 24th, 03:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139