Professional Web Applications Themes

Building FVWM 2.5.7 for Debian testing / Gnome 2 - Debian

On Mon, Jul 14, 2003 at 04:45:07PM -0400, Paul Smith wrote: > Hi all; > > I want to build the latest FVWM development version (2.5.7) for Debian > testing with support for Gnome 2. > > I've got the configure almost working with everything I want properly > configured, except that it can't find gnome-config so it can't enable > Gnome support. I've looked and the only place that seems to be defined > is in libgnome-devel. > > Well, I have the libgnome2-devel package installed, but there's no > gnome-config in there so the FVWM configuration doesn't recognize ...

  1. #1

    Default Re: Building FVWM 2.5.7 for Debian testing / Gnome 2

    On Mon, Jul 14, 2003 at 04:45:07PM -0400, Paul Smith wrote:
    > Hi all;
    >
    > I want to build the latest FVWM development version (2.5.7) for Debian
    > testing with support for Gnome 2.
    >
    > I've got the configure almost working with everything I want properly
    > configured, except that it can't find gnome-config so it can't enable
    > Gnome support. I've looked and the only place that seems to be defined
    > is in libgnome-devel.
    >
    > Well, I have the libgnome2-devel package installed, but there's no
    > gnome-config in there so the FVWM configuration doesn't recognize that
    > it's installed.
    >
    > I tried to install libgnome-devel but it complains:
    >
    > Sorry, but the following packages have unmet dependencies:
    > libgnome-dev: Depends: libdb3-dev but it is not going to be installed
    > E: Sorry, broken packages
    >
    > So... what next? Any ideas where can I find a gnome-config for Gnome 2?
    Try apt-get install libdb3-dev. It'll probably fail, but at least
    apt-get will tell you why and then you'll know why libdb3-dev 'is not
    going to be installed'.

    David


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    David Fokkema Guest

  2. #2

    Default Re: Building FVWM 2.5.7 for Debian testing / Gnome 2

    %% David Fokkema <dfokkemaileos.nl> writes:
    >> Well, I have the libgnome2-devel package installed, but there's no
    >> gnome-config in there so the FVWM configuration doesn't recognize
    >> that it's installed.
    >> So... what next? Any ideas where can I find a gnome-config for
    >> Gnome 2?
    df> Try apt-get install libdb3-dev. It'll probably fail, but at least
    df> apt-get will tell you why and then you'll know why libdb3-dev 'is
    df> not going to be installed'.

    Well, I installed libdb3-dev and now it will install libgnome-dev.

    But, that is the dev package for Gnome 1.4. I know, because APT wants
    to install a whole boatload of other 1.4.2 Gnome libraries when I ask
    for libgnome-dev.

    What I'm really wondering is, why isn't there a gnome-config in
    Gnome 2 anymore or, if there is, what package is it a part of?

    I guess I should ask this on the debian-gtk-gnome list.

    --
    -------------------------------------------------------------------------------
    Paul D. Smith <psmithnortelnetworks.com> HASMAT--HA Software Mthds & Tools
    "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
    -------------------------------------------------------------------------------
    These are my opinions---Nortel Networks takes no responsibility for them.


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Paul Smith Guest

  3. #3

    Default Re: Building FVWM 2.5.7 for Debian testing / Gnome 2

    On Tue, Jul 15, 2003 at 10:45:55AM -0400, Paul Smith wrote:
    > %% David Fokkema <dfokkemaileos.nl> writes:
    >
    > >> Well, I have the libgnome2-devel package installed, but there's no
    > >> gnome-config in there so the FVWM configuration doesn't recognize
    > >> that it's installed.
    >
    > >> So... what next? Any ideas where can I find a gnome-config for
    > >> Gnome 2?
    >
    > df> Try apt-get install libdb3-dev. It'll probably fail, but at least
    > df> apt-get will tell you why and then you'll know why libdb3-dev 'is
    > df> not going to be installed'.
    >
    > Well, I installed libdb3-dev and now it will install libgnome-dev.
    >
    > But, that is the dev package for Gnome 1.4. I know, because APT wants
    > to install a whole boatload of other 1.4.2 Gnome libraries when I ask
    > for libgnome-dev.
    >
    > What I'm really wondering is, why isn't there a gnome-config in
    > Gnome 2 anymore or, if there is, what package is it a part of?
    >
    > I guess I should ask this on the debian-gtk-gnome list.
    Yes, I guess that would be a good idea...

    David


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    David Fokkema Guest

  4. #4

    Default Re: Building FVWM 2.5.7 for Debian testing / Gnome 2

    On Tue, Jul 15, 2003 at 10:45:55AM -0400, Paul Smith wrote:
    > Well, I installed libdb3-dev and now it will install libgnome-dev.
    >
    > But, that is the dev package for Gnome 1.4. I know, because APT wants
    > to install a whole boatload of other 1.4.2 Gnome libraries when I ask
    > for libgnome-dev.
    >
    > What I'm really wondering is, why isn't there a gnome-config in
    > Gnome 2 anymore or, if there is, what package is it a part of?
    There is no gnome-config for GNOME 2 because GNOME 2 uses pkgconfig for
    everything instead of lots of individual *-config scripts. fvwm2 isn't
    really GNOME2-ready yet.

    --
    Michael Heironimus


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Michael Heironimus Guest

Similar Threads

  1. Setting up Debian: XServer problems and Gnome doesn't start
    By Andreas Janssen in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: September 7th, 02:38 PM
  2. Debian/Testing and security updates
    By Greg Folkert in forum Debian
    Replies: 3
    Last Post: July 26th, 06:10 AM
  3. Gnome Panel and Gnome 2 migration in sarge; user problems
    By Manuel Bilderbeek in forum Debian
    Replies: 1
    Last Post: July 22nd, 03:07 AM
  4. building,testing XML/LibXML/Common
    By James Dean in forum PERL Modules
    Replies: 2
    Last Post: July 6th, 02:49 AM
  5. Replies: 0
    Last Post: July 3rd, 08:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139