Professional Web Applications Themes

button prob - Macromedia Flash Sitedesign

hello, Well, I have run into a little problem whilst making my site. I have nave bat which, when the mouse goes over it comes up and reveals the buttons *the buttons being 3 pictures) Ive put a stop action at from 86 (the frame where i dont want the movie to continue to go) and i want the button, when pressed to go to frame 87, which is easy enu, noramly. My problem is i put an ; on release, folowed my a; gotoAndPlay(87) code, which i thought would make the movie start playing frame 87, but, instead it ...

  1. #1

    Default button prob

    hello,

    Well, I have run into a little problem whilst making my site. I have nave bat which, when the mouse goes over it comes up and reveals the buttons *the buttons being 3 pictures) Ive put a stop action at from 86 (the frame where i dont want the movie to continue to go) and i want the button, when pressed to go to frame 87, which is easy enu, noramly. My problem is i put an ; on release, folowed my a; gotoAndPlay(87) code, which i thought would make the movie start playing frame 87, but, instead it only puts the nav bar down. The fla. is below if you dont unerstand me. The button i want to make the movie go to fame 87 has an instance name "portfolio" and it is in the bar at the button of the screen named "navbar"

    If you could help me that would be swell.

    I couldnt uload the fla, the file is too big (even ziped)

    Ohwel, hope you understand me

    Thanks alot.


    GilesW webforumsuser@macromedia.com Guest

  2. #2

    Default Re: button prob

    please???

    I think Ive worked out the problem, but its the solution which is giving me a hard time.

    The button seems to be playing the navbar's movie clip's timeline, not the main one, so i tryed button in "Scene 1" into the script but it doesnt change nething. So im think i wil have to use a direct reference thing (eg: navbar.portfolio gotandplay(87) ) or somthing but I cant write actionscript so i dont know what to do.

    this is my code so far:

    on (release) {
    gotoAndPlay("Scene 1", 87);
    }

    thanks for ne help



    GilesW webforumsuser@macromedia.com Guest

  3. #3

    Default Re: button prob

    Yes, it does sound like a problem of reference. It is difficult to help you without the file but to find the path to a movieclip, type trace (this) in its timeline.

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

Similar Threads

  1. PROB!PLEASE HELP
    By obrienkev in forum Macromedia Flash Actionscript
    Replies: 1
    Last Post: February 20th, 03:24 PM
  2. AS2.0 prob
    By findapollo in forum Macromedia Flash Actionscript
    Replies: 2
    Last Post: February 18th, 08:26 AM
  3. Flash/Director Nav button prob
    By theo in forum Macromedia Director Basics
    Replies: 3
    Last Post: September 5th, 06:04 PM
  4. me again with email via asp prob
    By Aaron Bertrand - MVP in forum ASP
    Replies: 0
    Last Post: August 20th, 01:31 PM
  5. [PHP] newbY prob
    By Jennifer Goodie in forum PHP Development
    Replies: 2
    Last Post: July 23rd, 07:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139