I work for a Cable Company Installing Internet, the number one problem is
NewDotNet, or Commonname Toolbar being installed, both are LSP's and corrupt
Winsock settings. Usual culprits for the install is any of the P2P file
sharing programs available.

But..

Here are some things to look for when not being able to obtain an IP
address:
1.) Is the Dhcp client set to "Automatic" in the Services Console?
2.) Is there a "Link" indicator on the back"RJ45" port of the modem? if it
is blinking or seems intermittent, The 10/100 NICs can sometimes become
unstable when set on "Autosense", configuring the Nic to stay at a 10mb half
duplex(or ISP parameters) will solve that issue.
3.)DSL love to use hard coded IP, Dns & other PPPoE stuff all over the
place...uninstall whatever you can.
4.)Some modems(ISP) require a computer network name, if the name is not
present you will not get an IP (even Tech support will know that) this is
usually good for only one computer.
5.)Viewing the Nic's mac address shows it has changed to all FFFF-FFFF-FFFF
or AAAA-AAAA- etc. even though the hardware will show good in Devices, you
are not going anywhere with that card.
6.)Rules in Zone Alarm, (installed or not) if you ever had used Zone Alarm,
uninstalling some versions, and disabling, then uninstalling can keep rules
and blocked ports..Only way I have found to repair this (so Far) was to
reinstall it, and select the "clean install" option. Once your up and
running, alllow all access, end task on it and uninstall it now if you don't
want it anymore. As well, if you use the McAfee OEM style Virus
scan/Firewall packaged with Dell and other brand name machines... This is
the most un-user friendly security software you can get...most times it just
has a mind of it's own.Disable what ever you can, until an IP address can be
obtained(usually Msconfig, and needs reboot after all is disabled)
7.)Some proxy settings forgotten in Internet Options, or Spyware such as
"MarketScore/NetSetter" is installed, which has running OssProxy.exe from sy
stem32 directory, usually replacing proxy script in the Internet Connections
Panel.
8.)Second computer to confirm it is not the Modem or node issue being the
ISP fault.

Just a few things to look at, as this is what I do when I come across one of
these problems in the field, and never had one that wouldn't go yet. My
guess and the most common fault is the NewDotNet being installed hijacked
the Winsock settings. So many of these have happened, I created a tool to
repair this(since XP lacks the ability to rebuild it's own keys) which has
worked flawlessly.
[url]http://members.shaw.ca/techcd/VB_Projects/WinsockFix.zip[/url]
Before reinstalling any OS....


"jeff" <goadusc.edu> wrote in message
news:02be01c33df4$c31f5170$a501280aphx.gbl...
> I recently had a cable modem installed by the cable
> company. Previous to the install, I was using DSL. I
> also use a D-Link wireless (802.11b) router/access
> point. The DSL and wireless setup has worked fine for
> the last year.
> With the cable modem, my windows XP is unable to obtain
> an IP address from the DHCP. I ran the connection repair
> option on the local area connection, but I got a message
> saying repair operation failed for Renewing the IP
> address and Refereshing all DHCP leases and re-
> registering DNS names. All options under the TCP/IP to
> obtain an IP address automatically are checked.
> When I plug the cable into my laptop ethernet port, the
> connection works fine. The cable tech suggested I
> reformat my hard drive. Is this my only option?