Professional Web Applications Themes

Can't connect to remote sql server from asp.net buk ok from Enterprise Manager - ASP.NET General

Remove now aspnet user from admin group! (no matter is a test server, is a bad practique). You server is win2003? I don't can connect to Sql Server using NT authentication but with Sql Server authentication is fine. Create user group with the rigth permision on the database, create a user (like WebUser) with strong password and connect with it......

  1. #1

    Default Re: Can't connect to remote sql server from asp.net buk ok from Enterprise Manager

    Remove now aspnet user from admin group! (no matter is a test server, is a
    bad practique). You server is win2003? I don't can connect to Sql Server
    using NT authentication but with Sql Server authentication is fine. Create
    user group with the rigth permision on the database, create a user (like
    WebUser) with strong password and connect with it...


    Mamcx Guest

  2. #2

    Default Re: Can't connect to remote sql server from asp.net buk ok from Enterprise Manager

    On Thu, 17 Jul 2003 17:53:16 -0500, Mamcx wrote:
    > Remove now aspnet user from admin group! (no matter is a test server, is a
    > bad practique). You server is win2003? I don't can connect to Sql Server
    > using NT authentication but with Sql Server authentication is fine. Create
    > user group with the rigth permision on the database, create a user (like
    > WebUser) with strong password and connect with it...
    aspnet has more rights that it should. I know and certainly this is not the
    cause of the problem.

    Rmember I said the app connects fine from my development machine. This
    means the user and password on the database work fine.

    Karim
    karim Guest

  3. #3

    Default Re: Can't connect to remote sql server from asp.net buk ok from Enterprise Manager

    you must use tcp/ip and standard security for your configuration to work.
    named pipes requires an authenticated connection and is subject to the one
    hop rule. turn off named pipe support on your sqlserver and see if you can
    still connect.

    -- bruce

    "karim" <karim341111yahoo11.com> wrote in message
    news:c857bbdd7527f5c6ec0c2021dbef6ed4free.teranew s.com...
    >
    > I have an asp.net app that can connect from my development box to a
    > database server.
    >
    > However the same app, when put on a web server box, can't connect to that
    > database server. Enterprise Manager and Query yzer on the web server
    > can connect just fine. I am using SQL Server authentication. aspnet user
    is
    > a member of the admin group. All 3 machines are part of the same domain.
    >
    > Both web server and database have tcp/ip and named pipes enabled.
    > One weird thing I noticed on the development box is that I can't telnet to
    > port 1433 of the database server even though my app connects fine.
    >
    > What am I missing?
    >
    > Karim

    bruce barker Guest

Similar Threads

  1. Replies: 2
    Last Post: July 31st, 04:21 PM
  2. Net::SSH::Perl to connect to a remote server via a web page
    By Christian Caron in forum PERL Modules
    Replies: 0
    Last Post: August 30th, 01:02 PM
  3. Replies: 0
    Last Post: July 1st, 02:04 PM
  4. CRASH: when trying to connect to remote server(mac)
    By Azryth webforumsuser@macromedia.com in forum Macromedia Dreamweaver
    Replies: 1
    Last Post: July 19th, 10:35 PM
  5. Replies: 2
    Last Post: June 26th, 10:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139