On Wed, Jun 25, 2003 at 10:41:31AM -0700, Rodney D. Myers wrote:
> I've attempted to create an "update" cdrom, by using;
>
> dpkg-scanpackages . /dev/null > Packages
>
> which created a "Packages" file.
>
> With this method, the cd I created has everything in the "root"
> directory.
>
> I've been trying to get "apt-cdrom" to add the contents to the
> listing, so I don't have to re-download the files, and to help a few
> people convert to debian.
>
> When I run apt-cdrom, I get the following;
>
> sudo apt-cdrom -a add
> Using CD-ROM mount point /cdrom/
> Unmounting CD-ROM
> Please insert a Disc in the drive and press enter
> Mounting CD-ROM
> Identifying.. [ffb907fd618f7a4beeae842981cf6e0e-2]
> Scanning Disc for index files.. Found 1 package indexes and 0 source indexes.
> This Disc is called:
> 'Debian Update Disk 1'
> Reading Package Indexes... Done
> Wrote 0 records.
> Writing new source list
> Source List entries for this Disc are:
> deb cdrom:[Debian Update Disk 1]/ /
> Repeat this process for the rest of the CDs in your set.
> W: No valid records were found.
>
>
> Any help would be apprciated.
I don't know how to fix this, but I've used 'debian-cd' to produce CDs
from piles of .debs, and they've always worked fine for me. Perhaps
have a look at that, if it's not too late.

--
Rob Weir <rweirertius.org> | [email]mlspamertius.org[/email] | [url]http://www.ertius.org/[/url]
GPG keys: 1024D/1E73B7CD, 4096R/3ABDE5EC | Do I look like I want aCC?
Words of the day: Project Monarch fish Majic Waco, Texas cypherpunk

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)

iD8DBQE++/tnvQ+DhR5zt80RAs1HAJ41gqCWZebIaf/9lpA8OO9f5BPiogCdHiPo
EqGCuqg4e4Hz1WypVx+MvUI=
=JkMO
-----END PGP SIGNATURE-----