In article <dkirk-77B119.01011712072003news.verizon.net>,
"D. Kirkpatrick" <dkirkverizon.net> wrote:
> Just set up a D-Link in home router.
>
> Internet is working ok.
>
> System 1 is a Mac G3 beige/OS 9.2.1 and System 2 is a Win95 system.
> I just tried to run a trace to a domain using WhatRoute as built in to
> OS 9 and it would not get passed the router it seems. I tried a copy
> of Anarchie 3.7 I had and got the same results. I seem to be able to
> run a WHOIS but that is also sketchey. Ping seems to work.
>
> I appear to be able to trace and ping OK from the Windows machine.
>
> I'm guessing I have to reset something at the Router, but what?
>
> Its a D-Link 604. It can be accessed via a web browser.
>
> DMK
Look for options to change from UDP to ICMP protocols for trace options.
Try changing that option.


I had a somewhat similar frustration for months with my router & OSX.

two G4s 450 & 933
MacSense (XSense) MIH 130A XRouter Pro
OS9.22 & OSX 10.2.4

====================
Virtually everything but TRACE worked fine with my router, all internet
apps etc.

I think PING & TRACE ROUTE all worked under OS9.22 through this same
router but I spend very little time in OS9 now.

TRACE ROUTE with failed with both WhatRoute and IPNetMonitor X under OSX.
=====================
What finally worked for me was both WhatRoute and IPNetMonitor X came
out with newer versions ( 1.814 & 1.2 respectively) and a new setting
option came with these new versions.

If I changed both programs (WhatRoute & IPNetMonitorX) from UDP to ICMP
for TRACE it worked through my router. By default both ran UDP. Prior
versions did not have this option.

I am far from a network expert, but I do know these protocals are used
in network packet management and messaging. I ran across a tidbit that
ICMP is more similar to what Windows uses for TRACERT (trace route in
windows). UDP is more a UNIX type protocol for Trace routines.

Most routers can fucntion as a hardware firewall and may be blocking
something UDP needs to work properly. Maybe we both needed to open some
port for UDP which our routers are blocking. If this is the case, I have
no idea what port numbers need to be opened.

Try switching UDP to ICMP and see if it will work for you. My TRACE now
work through my router, but it took me months to get it working under
OSX.

Good Luck
Morenuf