Professional Web Applications Themes

Cannot mount cdrom if I use GRUB - Debian

This must be a very simple and dumb problem, but I cannot figure it out. If I boot with LILO, I can mount my CD/DVD w/o any problem. If I boot with GRUB I get an error message that says that my /dev/dvd is not a valid block device (same with /dev/cdrom, /dev/sr0, /dev/scd0, even as root). I have this in fstabs: /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0 I have this in lilo.conf: append="hda=scsi hdb=scsi hdc=scsi hdd=scsi apm=power-off nomce wheelmouse" I have this in /boot/grub/menu.lst: # kopt=root=/dev/hda13 ro vga=791 hdc=scsi My CD/DVD is a Mata UJDA 720. Is the primary ...

  1. #1

    Default Cannot mount cdrom if I use GRUB

    This must be a very simple and dumb problem, but I cannot figure it out.

    If I boot with LILO, I can mount my CD/DVD w/o any problem.
    If I boot with GRUB I get an error message that says that my /dev/dvd is not a
    valid block device (same with /dev/cdrom, /dev/sr0, /dev/scd0, even as root).

    I have this in fstabs:
    /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
    I have this in lilo.conf:
    append="hda=scsi hdb=scsi hdc=scsi hdd=scsi apm=power-off nomce wheelmouse"
    I have this in /boot/grub/menu.lst:
    # kopt=root=/dev/hda13 ro vga=791 hdc=scsi

    My CD/DVD is a Mata UJDA 720. Is the primary drive in my second IDE (thus
    hdc), is under scsi emulation.



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Marino Fernandez Guest

  2. #2

    Default Re: Cannot mount cdrom if I use GRUB





    On Thu, 3 Jul 2003, Marino Fernandez wrote:
    > This must be a very simple and dumb problem, but I cannot figure it out.
    >
    > If I boot with LILO, I can mount my CD/DVD w/o any problem.
    > If I boot with GRUB I get an error message that says that my /dev/dvd is not a
    > valid block device (same with /dev/cdrom, /dev/sr0, /dev/scd0, even as root).
    >
    > I have this in fstabs:
    > /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
    > I have this in lilo.conf:
    > append="hda=scsi hdb=scsi hdc=scsi hdd=scsi apm=power-off nomce wheelmouse"
    > I have this in /boot/grub/menu.lst:
    > # kopt=root=/dev/hda13 ro vga=791 hdc=scsi
    did you try hdc=ide-scsi?

    wfg,

    Gaspard



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    gaspard@zeus.ugent.be Guest

  3. #3

    Default Re: Cannot mount cdrom if I use GRUB

    On Friday 04 July 2003 5:13 am, [email]gaspardzeus.ugent.be[/email] wrote:
    > On Thu, 3 Jul 2003, Marino Fernandez wrote:
    > > This must be a very simple and dumb problem, but I cannot figure it out.
    > >
    > > If I boot with LILO, I can mount my CD/DVD w/o any problem.
    > > If I boot with GRUB I get an error message that says that my /dev/dvd is
    > > not a valid block device (same with /dev/cdrom, /dev/sr0, /dev/scd0, even
    > > as root).
    > >
    > > I have this in fstabs:
    > > /dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
    > > I have this in lilo.conf:
    > > append="hda=scsi hdb=scsi hdc=scsi hdd=scsi apm=power-off nomce
    > > wheelmouse" I have this in /boot/grub/menu.lst:
    > > # kopt=root=/dev/hda13 ro vga=791 hdc=scsi
    >
    > did you try hdc=ide-scsi?

    Thank you, that was it!.
    Now I have this in /boot/grub/menu.lst:

    title Debian GNU/Linux, kernel 2.4.21-686
    root (hd0,12)
    kernel /boot/vmlinuz-2.4.21-686 root=/dev/hda13 ro vga=791 hdc=ide-scsi
    savedefault
    boot


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Marino Fernandez Guest

Similar Threads

  1. Where To Put GRUB Boot mbr???
    By Don in forum Ubuntu
    Replies: 4
    Last Post: June 4th, 06:39 AM
  2. Can't mount cdrom
    By dirk65mb in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: September 21st, 04:42 PM
  3. Installing from GRUB
    By ipsum in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: July 11th, 06:40 PM
  4. LILO --> GRUB
    By Kenneth Jacker in forum Debian
    Replies: 5
    Last Post: July 8th, 08:50 PM
  5. can't get a cdrom "configured" with apt-cdrom
    By Rob Weir in forum Debian
    Replies: 0
    Last Post: June 29th, 06:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139