Professional Web Applications Themes

CFMX 6.1 won't work after Windows 2003/IIS6 install - Coldfusion Server Administration

As I don't have a ton of experience installing and maintaining ColdFusion MX server-side, I assumed it would be a fairly carefree issue. However that has not been the case. A new web server we just got runs Win2003 Server, and our previous web servers ran 2000 Server. 2000 Server handled MX 6.0 pretty effortlessly, installing it as a stanadlone and then linking to the DLLs in our sites in IIS. After installing MX 6.0 on the new server I encountered problems, and then downloaded the 6.1 installer and updated the install. I still could not get any coldfusion pages ...

  1. #1

    Default CFMX 6.1 won't work after Windows 2003/IIS6 install

    As I don't have a ton of experience installing and maintaining ColdFusion MX
    server-side, I assumed it would be a fairly carefree issue. However that has
    not been the case. A new web server we just got runs Win2003 Server, and our
    previous web servers ran 2000 Server. 2000 Server handled MX 6.0 pretty
    effortlessly, installing it as a stanadlone and then linking to the DLLs in our
    sites in IIS.

    After installing MX 6.0 on the new server I encountered problems, and then
    downloaded the 6.1 installer and updated the install. I still could not get
    any coldfusion pages to load, but I could administer the sites. After several
    times uninstalling and reinstalling things didn't change, and now the
    administrator won't even load. Most recently I uninstalled the program and
    deleted all the old CFMX files anywhere on the harddrive (the "CFMX" folder and
    any "CFIDE" type folders) and reinstalled as a standalone program, integrated
    with all IIS sites.

    I still can't even get the administrator page to load and just get a Cannot
    Find Server error in IE. The only thing I could think of is this: Does my
    default site in IIS have to be on the same physical drive or partition as the
    other sites for my company? Currently the Default is on C: and the rest of the
    sites are on a data partition D:

    Anybody else have this same problem, or anything similar? I've been trying to
    install this for 2 weeks now and am close to my wits' end.

    fsu5ball Guest

  2. #2

    Default Re: CFMX 6.1 won't work after Windows 2003/IIS6 install

    CFMX 6.1 is supported with Windows 2003 out of the box. So, you should have no
    problems configuring it with IIS 6. I would recommend trying the following:
    1. Ensure that you are able to access .htm pages from the same directory that
    your CFIDE folder resides
    2. Open the Web Server Configuration Tool under Program Files -> Macromedia ->
    ColdFusion MX and remove the current IIS configured web site, then re-add it,
    ensuring that you checked the "Configure web site for coldfusion mx
    applications" box. You may also want to enable verbose logging of the
    connector under the advanced button.
    3. If you still cannot resolve any .cfm pages, run through the steps in "To
    Verify your IIS configuration" in this doent and manually configure the site:
    [url]http://livedocs.macromedia.com/coldfusion/6.1/htmldocs/config12.htm#wp1118876[/url]

    elish Guest

  3. #3

    Default Re: CFMX 6.1 won't work after Windows 2003/IIS6 install

    I have verified all these steps and have had no different results. HTML files
    still load under that directory. I did notice that there were no 'JRunScripts'
    virtual directories in my sites, but even creating those virtual directories
    manually for each site did nothing. I also noticed something rather curious.
    After a 6.1 install, the only reference to ColdFusion in 2003's Administrative
    Tools > Services is the "ColdFusion MX Application Server". The ColdFusion
    ODBC Agent and the ODBC Server are not there. Are they not supposed to be?
    Please help, as I do not want to have to roll back to 2000 Server in order to
    get ColdFusion working.

    fsu5ball Guest

  4. #4

    Default Re: CFMX 6.1 won't work after Windows 2003/IIS6 install

    Look in IIS for the default site and see if the /CFIDE folder is present. If
    so, navigate to /CFIDE/administrator/index.cfm and see if it will run.
    If not, look in the IIS properties for the master site, and see if the .cfm,
    ..cfc etc mappings are present, and that the Wildcard mapping is there as well.
    If not, you may need to rerun the connector bat file
    C:\CFusionMX7\bin\connectors\IIS_Connector.bat

    The Jrunscripts virtual dirs are not needed in 6.1. And the ODBC services will
    not be installed until you first log into the Cf administrator and complete the
    install wizard it runs you through then.

    Hope this helps



    Abinidi Guest

  5. #5

    Default Re: CFMX 6.1 won't work after Windows 2003/IIS6 install

    One other thing to check is make sure the IIS_WPG group is given full
    permissions to the wsconfig directory (and its subdirectories), as mentioned
    here: [url]http://www.macromedia.com/go/950218dc[/url] . I know you didn't specifically
    mention seeing the errors in these technotes, but its still worth a shot.

    DStanten Guest

Similar Threads

  1. WSCONFIG Problem - MX6.1 on Windows 2003/IIS6
    By ChrisHarr in forum Coldfusion Server Administration
    Replies: 1
    Last Post: November 21st, 10:06 PM
  2. CF7 / IIS6 / Win 2003 Server Install Problem
    By UKJools in forum Coldfusion - Getting Started
    Replies: 17
    Last Post: June 7th, 11:25 PM
  3. ColdFusion 4.01 on IIS6/Windows 2003
    By sgentzen in forum Coldfusion Server Administration
    Replies: 1
    Last Post: May 18th, 01:00 PM
  4. Windows 2003 IIS6 CF5 combination - need help
    By Libby in forum Macromedia ColdFusion
    Replies: 0
    Last Post: February 28th, 05:23 PM
  5. Windows 2003 IIS6.0
    By Kevin Wheeler in forum Windows Server
    Replies: 4
    Last Post: June 16th, 04:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139