Professional Web Applications Themes

CFMX7 and Local SQL Server Connections - Coldfusion Server Administration

I recently upgraded from CF5 to CFMX7. All went well, but I am now not able to access SQL Server DBs on the local Machine. When I Verify the Datasource via CF Admin, I am getting the following error. Connection verification failed for data source: lo_db_laptop java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket. Connection refused: connect The root cause was that: java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing socket. Connection refused: connect These Datasources were working fine in CF5, and have not been changed since migration. Has anyone experienced similar issues? Any suggestions as to what may be causing this? Many Thanks in ...

  1. #1

    Default CFMX7 and Local SQL Server Connections

    I recently upgraded from CF5 to CFMX7. All went well, but I am now not able
    to access SQL Server DBs on the local Machine.

    When I Verify the Datasource via CF Admin, I am getting the following error.

    Connection verification failed for data source: lo_db_laptop
    java.sql.SQLException: [Macromedia][SQLServer JDBC Driver]Error establishing
    socket. Connection refused: connect
    The root cause was that: java.sql.SQLException: [Macromedia][SQLServer JDBC
    Driver]Error establishing socket. Connection refused: connect

    These Datasources were working fine in CF5, and have not been changed since
    migration.

    Has anyone experienced similar issues? Any suggestions as to what may be
    causing this?

    Many Thanks in advance

    jjay@aus Guest

  2. #2

    Default Re: CFMX7 and Local SQL Server Connections

    What happens if you try using ODBC socket to connect to the database? Same way
    was used in CF5. Create System DSN first and then use it in datasource
    settings. It'd be interesting to see if that works.
    Alos, are you specifying username/password when creating datasources? Is your
    database configured for SQL Server authentication only or both SQL Server and
    Windows?

    dimaint Guest

  3. #3

    Default Re: CFMX7 and Local SQL Server Connections

    Hi dimaint, thanks for your reply.

    The datasources are created via ODBC Administrator as a System DSN. They are
    working fine via ODBC Data Source Administrator. And they were fine via CF5
    before upgrading to MX7.

    This is the case for Datasources that existed prior to upgrade, as well as any
    created post upgrade.

    I'm not specifying the username and password when creating or connecting to
    the Data Sources. Datasources are configured with Windows Authentication.

    Thanks again

    jjay@aus Guest

  4. #4

    Default Re: CFMX7 and Local SQL Server Connections

    Have you tried using Microsoft SQL Server JDBC drivers? When creating datasource, try to select Microsoft SQL Server from dropdown list of datasource types.
    dimaint Guest

  5. #5

    Default Re: CFMX7 and Local SQL Server Connections

    If you mean have I tried creating a DSN via the Cold Fusion Administrator, then
    yes I have, but still getting "Connection refused".

    As a side point. Any Access Datasources I had setup are working fine. It is
    just with SQL Server.

    jjay@aus Guest

  6. #6

    Default Re: CFMX7 and Local SQL Server Connections

    You might want to specify username/password when creating SQL Server DSN in CF
    Admin. Either username/password for specific domain user that has privilegies
    or if you have mixed authentication and specific SQL Server user, then use that
    user.

    dimaint Guest

  7. #7

    Default Re: CFMX7 and Local SQL Server Connections

    I managed to connect using an ODBC Socket, and that has got me connected fine
    for now. Will try connecting with UN&PW in future.

    I'm still keen to know though why these DSNs wouldn't work, so if anyone has
    any suggestions would love to hear them.

    Thanks for your help dimaint.

    jjay@aus Guest

  8. #8

    Default Re: CFMX7 and Local SQL Server Connections

    Review your odbc datasource in windows control panel. As you go thru to edit
    the DSN, I believe the 2nd page of the dialog will offer a 'client' button.
    Click and determine what client libraries are used. You likely will find it is
    a connection VIA pipes. JDBC connections require a TCPIP connection. You will
    need to update the mssql server to allow TCPIP, if that is the case.

    You should then be able to connect with jdbc.

    ksmith Guest

  9. #9

    Default Re: CFMX7 and Local SQL Server Connections

    Thanks for the suggestion Ken,

    Network libraries were already set to TCP/IP.

    Any more ideas?

    Thanks
    jjay@aus Guest

  10. #10

    Default Re: CFMX7 and Local SQL Server Connections

    First what version of mssql are you running?

    Next, create a test DSN using mssql/jdbc. Do not worry if it does not
    validate yet. Next create a simple test query using that datasource. "Select
    * from foo" is fine. What error does it return? Often the error from a query
    is much better than info given in cfadmin.

    ksmith Guest

Similar Threads

  1. connections to demo site on local PC
    By jan malcolm in forum Macromedia Contribute Connection Administrtion
    Replies: 0
    Last Post: November 5th, 02:12 PM
  2. script disable/enable local area connections
    By Tony in forum Windows Networking
    Replies: 1
    Last Post: July 13th, 03:58 PM
  3. Replies: 1
    Last Post: June 26th, 09:17 PM
  4. Setting vsftpd to only allow local connections...
    By Kenneth A Kauffman in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: June 26th, 06:27 PM
  5. Replies: 1
    Last Post: June 25th, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139