Professional Web Applications Themes

Changing journaling mode in ext3 - Linux Setup, Configuration & Administration

I already have an ext3 filesystem mounted as "/" As far as I know the journal mode enabled by default is "ordered". But I want to change it to "journal". So I have searched the doentation on how to do it and I have found that I have to change /etc/fstab putting "data=journal" in the option field of the filesystem. Despite of doentation my system does not restart telling the filesystem is read only and locks while starting system logger. Do you know how can I change the journaling mode effectivelly? Thanks Gianni Bragante...

  1. #1

    Default Changing journaling mode in ext3

    I already have an ext3 filesystem mounted as "/"
    As far as I know the journal mode enabled by default is "ordered". But I
    want to change it to "journal".
    So I have searched the doentation on how to do it and I have found that I
    have to change /etc/fstab putting "data=journal" in the option field of the
    filesystem.
    Despite of doentation my system does not restart telling the
    filesystem is read only and locks while starting system logger.

    Do you know how can I change the journaling mode effectivelly?

    Thanks
    Gianni Bragante


    Gianni Bragante Guest

  2. #2

    Default Re: Changing journaling mode in ext3

    Artemio <artemioartemio.net> wrote:
    > Gianni Bragante wrote:
    ....
    >> Do you know how can I change the journaling mode effectivelly?
    > Try "tune2fs" utility (man tune2fs for details).
    And how does tune2fs help in changing journaling mode?

    Using the proper /etc/fstab options is the way to go, post your fstab
    and the output of the 'mount' command or none will be able to help.

    --
    Michael Heiming

    Remove +SIGNS and www. if you expect an answer, sorry for
    inconvenience, but I get tons of SPAM
    Michael Heiming Guest

  3. #3

    Default Re: Changing journaling mode in ext3

    Michael, thank you for you answer.
    Here is the intended fstab that makes the computer unbootable:

    LABEL=/ / ext3 data=journal
    1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda5 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660
    noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0
    0

    This is the output of the mount command obtained when ext3 is using the
    deault setting of ordered:

    /dev/hda3 on / type ext3 (rw)
    none on /proc type proc (rw)
    usbdevfs on /proc/bus/usb type usbdevfs (rw)
    /dev/hda2 on /boot type ext3 (rw)
    none on /dev/pts type devpts (rw,gid=5,mode=620)
    none on /dev/shm type tmpfs (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

    I have also tried to modify the grub.conf file as I have found in a doent
    modifying the line:

    kernel /vmlinuz-2.4.20-18.9 ro root=LABEL=/ rootflags=data=journal

    but with no result.

    Any help will be great!

    Thanks
    Gianni Bragante


    Gianni Bragante Guest

  4. #4

    Default Re: Changing journaling mode in ext3

    Gianni Bragante <gbragantelibero.it> wrote:
    > Michael, thank you for you answer.
    > Here is the intended fstab that makes the computer unbootable:
    > LABEL=/ / ext3 data=journal
    > 1 1
    Try:

    LABEL=/ / ext3 defaults,data=journal 1 0

    Good luck

    --
    Michael Heiming

    Remove +SIGNS and www. if you expect an answer, sorry for
    inconvenience, but I get tons of SPAM
    Michael Heiming Guest

  5. #5

    Default Re: Changing journaling mode in ext3

    Gianni Bragante <gbragantelibero.it> wrote:
    > Michael,
    > I have followed your suggestions but with no luck. Even with the suggested
    > configuration the system behaves the same way, hanging on Starting system
    > logger. In several lines scrolling during the boot process the error "Read
    ....

    Did you try using the "rootflags=data=journal" in addition to your grub
    config, sorry I don't use grub.

    Perhaps I'd try if this doesn't work, changing the LABEL=/ in fstab to
    the real device.

    --
    Michael Heiming

    Remove +SIGNS and www. if you expect an answer, sorry for
    inconvenience, but I get tons of SPAM
    Michael Heiming Guest

  6. #6

    Default Re: Changing journaling mode in ext3

    Gianni Bragante wrote:

    [snipped]
    > Do you know how can I change the journaling mode effectivelly?
    did you add rootflags=data=journal to your kernel boot options?



    --
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~
    Michael J. Tobler: motorcyclist, surfer, # Black holes result
    skydiver, and author: "Inside Linux", # when God divides the
    "C++ HowTo", "C++ Unleashed" # universe by zero

    mjt Guest

  7. #7

    Default Re: Changing journaling mode in ext3

    Gianni Bragante wrote:
    > I have followed your suggestions but with no luck. Even with the suggested
    > configuration the system behaves the same way, hanging on Starting system
    >
    .... pls see my post

    --
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~
    Michael J. Tobler: motorcyclist, surfer, # Black holes result
    skydiver, and author: "Inside Linux", # when God divides the
    "C++ HowTo", "C++ Unleashed" # universe by zero

    mjt Guest

  8. #8

    Default Re: Changing journaling mode in ext3

    Gianni Bragante wrote:
    > I already have an ext3 filesystem mounted as "/"
    > As far as I know the journal mode enabled by default is "ordered". But I
    > want to change it to "journal".
    > So I have searched the doentation on how to do it and I have found that
    > I have to change /etc/fstab putting "data=journal" in the option field of
    > the filesystem.
    > Despite of doentation my system does not restart telling the
    > filesystem is read only and locks while starting system logger.
    >
    > Do you know how can I change the journaling mode effectivelly?
    Try "tune2fs" utility (man tune2fs for details).
    Artemio Guest

  9. #9

    Default Re: Changing journaling mode in ext3

    On Sat, 28 Jun 2003 15:22:27 +0000, Gianni Bragante wrote:
    > I already have an ext3 filesystem mounted as "/"
    > As far as I know the journal mode enabled by default is "ordered". But I
    > want to change it to "journal".
    > So I have searched the doentation on how to do it and I have found that I
    > have to change /etc/fstab putting "data=journal" in the option field of the
    > filesystem.
    > Despite of doentation my system does not restart telling the
    > filesystem is read only and locks while starting system logger.
    >
    > Do you know how can I change the journaling mode effectivelly?
    >
    > Thanks
    > Gianni Bragante
    not that i can help you too much Gianni but I had the same problem when I
    tried to use Ordered data when installing Suse 8.1 Pro on Friday evening.
    I'd get a ton of errors about a read only filesystem and eventually I'd
    get a kernel panic out of it. After reading deeply into the error messages
    that appeared initially I started messing with /etf/fstab but was
    modifying the wrong parameters. Finally for some reason I changed the way
    the journal was kept and changed it from "journal" to ordered" and it
    worked just fine. I specifically told the Suse installation program to
    use ordered (i didnt have preference for one over the other since i didn't
    know the differnce) but when I found out that what I chose didn't matter I
    was still a bit peeved over it. When / is being mounted the message
    displayed even says

    EXT3-fs: mounted filesystem with ordered data mode.
    VFS: Mounted root (ext3 filesystem) readonly.

    even though I chose "journal". It's almost like its hard coded in to print
    that out no matter how you tell it to do it. Anyway, I coudln't get it to work but I
    didn't spend nearly as much time on it as you have. U may just want to
    give up, lol.



    Glitch Guest

  10. #10

    Default Re: Changing journaling mode in ext3

    On Sat, 28 Jun 2003 15:22:27 +0000, Gianni Bragante wrote:
    > I already have an ext3 filesystem mounted as "/"
    > As far as I know the journal mode enabled by default is "ordered". But I
    > want to change it to "journal".
    > So I have searched the doentation on how to do it and I have found that I
    > have to change /etc/fstab putting "data=journal" in the option field of the
    > filesystem.
    > Despite of doentation my system does not restart telling the
    > filesystem is read only and locks while starting system logger.
    >
    > Do you know how can I change the journaling mode effectivelly?
    >
    > Thanks
    > Gianni Bragante

    It seems after reading your post again my situation could help you
    afterall. I kept thinking you wanted Ordered and not journaled but I got
    it backwards. Anyway, here is my fstab in case it helps.

    /dev/hdb3 / ext3 data=ordered 1 1
    Glitch Guest

Similar Threads

  1. ext3
    By Mage in forum PostgreSQL / PGSQL
    Replies: 15
    Last Post: January 18th, 05:24 PM
  2. CMYK mode keeps changing to RGB in Illustrator 9
    By Vicky_Payne@adobeforums.com in forum Adobe Illustrator Macintosh
    Replies: 3
    Last Post: May 28th, 03:56 PM
  3. Changing the size of the textboxes in edit mode
    By David Rainsford in forum ASP.NET Data Grid Control
    Replies: 1
    Last Post: April 1st, 06:05 PM
  4. changing logging mode
    By rkusenet in forum Informix
    Replies: 5
    Last Post: October 3rd, 07:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139