Clutch hemp there -- anagrama [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => <205h53xk9m.ln2@news.gates-of-hell.com> [ref] => <20051124145909@usenet.piggo.com> <20051125004307@usenet.piggo.com> [htmlstate] => on_nl2br [postusername] => SINNER [ip] => 99nesorjd@gates [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 8 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) --> changing locale - Ubuntu

changing locale - Ubuntu

Selecting a default locale with "dpkg-reconfigure" does not make that locale effective. Is there any way to change the locale of the system without rebooting? Regards, Bob -- _ |_) _ |_ Robert D. Hilliard <hilliarddebian.org> |_) (_) |_) 1294 S.W. Seagull Way <bobbobhilliard.net> Palm City, FL 34990 USA GPG Key ID: 390D6559 -- To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email] with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]...

  1. #1

    Default Changing locale

    Selecting a default locale with "dpkg-reconfigure" does not make
    that locale effective. Is there any way to change the locale of the
    system without rebooting?

    Regards,

    Bob
    --
    _
    |_) _ |_ Robert D. Hilliard <hilliarddebian.org>
    |_) (_) |_) 1294 S.W. Seagull Way <bobbobhilliard.net>
    Palm City, FL 34990 USA GPG Key ID: 390D6559



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Bob Hilliard Guest

  2. #2

    Default Re: Changing locale

    On Fri, Jul 18, 2003 at 11:51:19AM -0400, Bob Hilliard wrote:
    > Selecting a default locale with "dpkg-reconfigure" does not make
    > that locale effective. Is there any way to change the locale of the
    > system without rebooting?
    What does "effective" mean to you? Should the prompts change language,
    or is this for specific software? If it's for specific software, it could
    be that your LC_TYPE files were not properly installed. If that's the
    case, you might find the following useful:

    When I installed locales on Woody + unstable my libc6 and libc6-dev
    packages were upgraded. If you're running Woody + stable you should
    have no problems. To fix Woody + unstable you need to compile the
    locale definitions file manually (for each locale). I used this:
    localedef -v -c -i fr_CA -f UTF-8 /usr/lib/locale/fr_CA
    -v verbose
    -c force: output files even if there are warnings
    -i use this input file
    -f character map file
    /usr/lib/locale/fr_CA where to put the new file
    copied from: [url]http://xtrinsic.com/geek/articles/locales.phtml[/url]

    I hope that helps!

    emma

    --
    Emma Jane Hogbin
    [[ 416 417 2868 ][ [url]www.xtrinsic.com[/url] ]]


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Emma Jane Hogbin Guest

  3. #3

    Default Re: Changing locale

    Andreas Janssen <andreas.janssenbigfoot.com> writes:
    > Hello
    >
    > Bob Hilliard wrote:
    >
    >> Selecting a default locale with "dpkg-reconfigure" does not make
    >> that locale effective. Is there any way to change the locale of the
    >> system without rebooting?
    >
    > You can check if your settings were saved by editing /etc/environment.
    > Please don't forget to completeley log out to apply the changes.
    Thanks. That is the answer I was looking for. I hadn't been
    logging out.

    To answer another poster's question - if `locale' returns the
    new locale I consider the change has been effective.

    I would also like to know how to generate and set the `POSIX'
    locale. Although /usr/share/i18n/locales/POSIX exists,
    `dpkg-reconfigure locales' does not offer it as a choice, and if it is
    manually added to /etc/locale.gen, a subsequent `locale-gen' ignores
    POSIX.

    (I don't really want to run the POSIX locale. I am writing a
    script that needs to know the value of `LC_CTYPE' in the POSIX
    locale.)

    Regards,

    Bob
    --
    _
    |_) _ |_ Robert D. Hilliard <hilliarddebian.org>
    |_) (_) |_) 1294 S.W. Seagull Way <bobbobhilliard.net>
    Palm City, FL 34990 USA GPG Key ID: 390D6559



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Bob Hilliard Guest

  4. #4

    Default Re: Changing locale

    On Fri, Jul 18, 2003 at 05:23:58PM -0400, Bob Hilliard wrote:
    > I would also like to know how to generate and set the `POSIX'
    > locale. Although /usr/share/i18n/locales/POSIX exists,
    > `dpkg-reconfigure locales' does not offer it as a choice, and if it is
    > manually added to /etc/locale.gen, a subsequent `locale-gen' ignores
    > POSIX.
    > (I don't really want to run the POSIX locale. I am writing a
    > script that needs to know the value of `LC_CTYPE' in the POSIX
    > locale.)
    Does this file exist right now? I know I've had to add mine manually by
    using localedef which I pasted here earlier....
    [url]http://lists.debian.org/debian-user/2003/debian-user-200307/msg02591.html[/url]

    emma

    --
    Emma Jane Hogbin
    [[ 416 417 2868 ][ [url]www.xtrinsic.com[/url] ]]


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Emma Jane Hogbin Guest

  5. #5

    Default changing locale

    Dumb question since I've used linux for years, but have never had to
    worry about it. My previous distribution (RedHat) had a ISO-8859 (or
    whatever it is) locale.

    I've now installed and am using UTF-8 because, I think, I chose
    Australia as my location. I am now having trouble viewing some
    characters in slrn and mutt, for example.

    So, how do I change it back to the ISO-8859 one?

    --
    Troy Piggins
    Christmas thought: "Christmas is a time of eating,
    so Boxing Day is a time for pooing."
    Troy Piggins Guest

  6. #6

    Default Re: changing locale

    * Troy Piggins wrote in alt.os.linux.ubuntu:
    > Dumb question since I've used linux for years, but have never had to
    > worry about it. My previous distribution (RedHat) had a ISO-8859 (or
    > whatever it is) locale.
    > I've now installed and am using UTF-8 because, I think, I chose
    > Australia as my location. I am now having trouble viewing some
    > characters in slrn and mutt, for example.
    > So, how do I change it back to the ISO-8859 one?
    I had the exact same problem:

    Try setting the locale to en_US.ISO8859-1 (or just en_US). You may need
    to generate the additional locales by running (as root):

    $ sudo dpkg-reconfigure locales

    then set the environment variable LC_CTYPE to the above

    $ export LC_CTYPE='en_US.ISO-8859-1'

    you need to set LANG the same.

    Then start slrn.

    Worked wonders for me.
    --
    David
    Long life is in store for you.
    SINNER Guest

  7. #7

    Default Re: changing locale

    * SINNER wrote:
    > * Troy Piggins wrote in alt.os.linux.ubuntu:
    >> Dumb question since I've used linux for years, but have never had to
    >> worry about it. My previous distribution (RedHat) had a ISO-8859 (or
    >> whatever it is) locale.
    >
    >> I've now installed and am using UTF-8 because, I think, I chose
    >> Australia as my location. I am now having trouble viewing some
    >> characters in slrn and mutt, for example.
    >
    >> So, how do I change it back to the ISO-8859 one?
    >
    > I had the exact same problem:
    >
    > Try setting the locale to en_US.ISO8859-1 (or just en_US). You may need
    > to generate the additional locales by running (as root):
    >
    > $ sudo dpkg-reconfigure locales
    >
    > then set the environment variable LC_CTYPE to the above
    >
    > $ export LC_CTYPE='en_US.ISO-8859-1'
    >
    > you need to set LANG the same.
    >
    > Then start slrn.
    >
    > Worked wonders for me.
    Yep - that did it. Thanks.

    Actually I only needed to select "en_AU" for it to work.

    Added to ~/.bash_profile:
    export LC_CTYPE='en_AU.ISO-8859-1'
    export LANG='en_AU.ISO-8859-1'

    I'm new to the Debian packaging system, so still learning the apt-get,
    dpkg-* tools etc. Thanks for the pointers.

    --
    Troy Piggins
    Christmas thought: "Christmas is a time of eating,
    so Boxing Day is a time for pooing."
    Troy Piggins Guest

  8. #8

    Default Re: changing locale

    * Troy Piggins wrote in alt.os.linux.ubuntu:

    [...]
    > I'm new to the Debian packaging system, so still learning the apt-get,
    > dpkg-* tools etc. Thanks for the pointers.
    Ditto, I came to Ubuntu/Debian from Mandr* so I am still learning as
    well. Glad it worked.
    --
    David
    The Temple Church <--> Clutch hemp there
    -- anagrama
    SINNER Guest

  9. #9

    Default Re: changing locale

    On Thu, 24 Nov 2005 16:09:40 +0000, SINNER wrote:
    >> I'm new to the Debian packaging system, so still learning the apt-get,
    >> dpkg-* tools etc. Thanks for the pointers.
    >
    > Ditto, I came to Ubuntu/Debian from Mandr* so I am still learning as well.
    > Glad it worked.
    Hey SINNER, I remember you from the Mandr* groups. I started using Breezy
    after "upgrading" from Mandr* LE2005 to 2006. I really miss MCC and urpmi
    but slowly getting used to Ubuntu.

    Wayne
    --
    Registered Linux user #375994
    [url]http://www.geocities.jp/rondonko/[/url]

    Wayne Guest

  10. #10

    Default Re: changing locale

    * Wayne wrote in alt.os.linux.ubuntu:
    > On Thu, 24 Nov 2005 16:09:40 +0000, SINNER wrote:
    >>> I'm new to the Debian packaging system, so still learning the apt-get,
    >>> dpkg-* tools etc. Thanks for the pointers.
    >> Ditto, I came to Ubuntu/Debian from Mandr* so I am still learning as well.
    >> Glad it worked.
    > Hey SINNER, I remember you from the Mandr* groups. I started using Breezy
    > after "upgrading" from Mandr* LE2005 to 2006. I really miss MCC and urpmi
    > but slowly getting used to Ubuntu.

    Hey Wayne :)

    I miss MCC but aptitude/apt-get kick azz and are at least comparable
    with urpmi if not better.

    --
    David
    Loose bits sink chips.
    SINNER Guest

Similar Threads

  1. potential changes to Locale-PO
    By Kalle Olavi Niemitalo in forum PERL Modules
    Replies: 0
    Last Post: February 26th, 02:45 PM
  2. Locale in verity
    By Munii in forum Coldfusion - Getting Started
    Replies: 6
    Last Post: April 17th, 01:09 PM
  3. [PHP-DEV] Locale
    By Wojtek Meler in forum PHP Development
    Replies: 0
    Last Post: September 3rd, 09:04 AM
  4. Changing locale for WE8ISO8859-P1
    By in forum Sun Solaris
    Replies: 3
    Last Post: July 31st, 07:07 PM
  5. PHP and my locale
    By Joozju in forum PHP Development
    Replies: 0
    Last Post: July 8th, 08:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139