Professional Web Applications Themes

Client Side Webservices - ASP.NET Web Services

I hope that someone can help me with this problem. I am currently writing a Web Application that uses client side webservice technology utlizing the webservice.htc file from mircosoft. For the longest time everything had been going great, but recently when I started adding web methods to the asmx.cs file none of my breakpooints are being hit. When this first started I was able to get things working again by killing the asp_net process, deleteing the .dll and .pdb files for the project, restarting IIS and then re-compiling the project. This would usually get it workign for a while. Then ...

  1. #1

    Default Client Side Webservices

    I hope that someone can help me with this problem. I am
    currently writing a Web Application that uses client side
    webservice technology utlizing the webservice.htc file
    from mircosoft. For the longest time everything had been
    going great, but recently when I started adding web
    methods to the asmx.cs file none of my breakpooints are
    being hit. When this first started I was able to get
    things working again by killing the asp_net process,
    deleteing the .dll and .pdb files for the project,
    restarting IIS and then re-compiling the project. This
    would usually get it workign for a while. Then it would
    re-vert back to not hitting breakpoints. Now, for some
    reason, after this last web method I have just added I
    can't get it to ever hit my breakpoints. I can tell that
    it is running through the methods, because it is doing
    some transformations that only happen in the method, but
    it never steps into the method. Also, it also errors out
    at times and returns an error "Invalid Argument". My
    thought on this is that it is a bogus error becuase all
    my arguemnts are correct. Hopefully I explained myself
    good enough. Thank you in advnace for the help and have
    a great day!

    Paul ><>
    Paul Gorman Guest

  2. #2

    Default Re: Client Side Webservices

    Hi Paul,

    Is it possible you are getting back cached results? Maybe cached web
    methods, or cached web controls, ...

    Michel

    "Paul Gorman" <pgnospamgormansolutions.com> wrote in message
    news:00de01c3bf53$88334cc0$a501280aphx.gbl...
    > I hope that someone can help me with this problem. I am
    > currently writing a Web Application that uses client side
    > webservice technology utlizing the webservice.htc file
    > from mircosoft. For the longest time everything had been
    > going great, but recently when I started adding web
    > methods to the asmx.cs file none of my breakpooints are
    > being hit. When this first started I was able to get
    > things working again by killing the asp_net process,
    > deleteing the .dll and .pdb files for the project,
    > restarting IIS and then re-compiling the project. This
    > would usually get it workign for a while. Then it would
    > re-vert back to not hitting breakpoints. Now, for some
    > reason, after this last web method I have just added I
    > can't get it to ever hit my breakpoints. I can tell that
    > it is running through the methods, because it is doing
    > some transformations that only happen in the method, but
    > it never steps into the method. Also, it also errors out
    > at times and returns an error "Invalid Argument". My
    > thought on this is that it is a bogus error becuase all
    > my arguemnts are correct. Hopefully I explained myself
    > good enough. Thank you in advnace for the help and have
    > a great day!
    >
    > Paul ><>

    Michel Guest

Similar Threads

  1. flashcom: client side cant access server side
    By u_sq in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: June 28th, 09:16 PM
  2. Controls with a client side onLoad function or seting a cursor server side
    By Geoff Davis in forum ASP.NET Building Controls
    Replies: 3
    Last Post: January 15th, 03:54 AM
  3. Replies: 9
    Last Post: October 17th, 07:25 PM
  4. server-side ASP w/ client -side component
    By Miguel Guerreiro in forum ASP Components
    Replies: 1
    Last Post: August 5th, 12:09 AM
  5. button evet ---- server side - client side ???
    By yaya coco in forum ASP.NET General
    Replies: 1
    Last Post: July 4th, 10:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139