Professional Web Applications Themes

cloneModelFromCastMember error - Macromedia Director 3D

Hiya, i am trying to dynamically assign a model to a 3D Shockwave charcater when a user logs into my application (using good old MUS). When a user sets up their account, they choose pieces from a menu to build their charcater. When they have finished the member names of all the pieces are stored as attributes on the DBObject. When called for, the attributes are then translated back into member names and i am trying to use the same cloneModelFromCastMember script to reassign them back together to build their character when they next log in using the following: member("man").cloneModelFromCastmember("head1", ...

  1. #1

    Default cloneModelFromCastMember error

    Hiya, i am trying to dynamically assign a model to a 3D Shockwave charcater
    when a user logs into my application (using good old MUS). When a user sets
    up their account, they choose pieces from a menu to build their charcater.
    When they have finished the member names of all the pieces are stored as
    attributes on the DBObject.

    When called for, the attributes are then translated back into member names
    and i am trying to use the same cloneModelFromCastMember script to reassign
    them back together to build their character when they next log in using the
    following:

    member("man").cloneModelFromCastmember("head1", "head", member(head))

    The (head) variable is the relevant content[1] from my call from the
    database.

    However when this is called i get the following error:



    Script error: Error

    member("man").cloneModelFromCastmember("head1", "head", member(head))

    -2147196928


    I tried looking up this error code but could not find it's translation, has
    anybody got any idea what this error is trying to say and even better, how
    to overcome this error?

    Thanks

    Jay


    Jay Guest

  2. #2

    Default Re: cloneModelFromCastMember error

    Sorry my fault - i hadnt preloaded( ) the 3D members

    all fixed now!

    thx anyway

    "Jay" <jayfield1979msn.com> wrote in message
    news:bne8os$c2k$1forums.macromedia.com...
    > Hiya, i am trying to dynamically assign a model to a 3D Shockwave
    charcater
    > when a user logs into my application (using good old MUS). When a user
    sets
    > up their account, they choose pieces from a menu to build their charcater.
    > When they have finished the member names of all the pieces are stored as
    > attributes on the DBObject.
    >
    > When called for, the attributes are then translated back into member names
    > and i am trying to use the same cloneModelFromCastMember script to
    reassign
    > them back together to build their character when they next log in using
    the
    > following:
    >
    > member("man").cloneModelFromCastmember("head1", "head", member(head))
    >
    > The (head) variable is the relevant content[1] from my call from the
    > database.
    >
    > However when this is called i get the following error:
    >
    >
    >
    > Script error: Error
    >
    > member("man").cloneModelFromCastmember("head1", "head", member(head))
    >
    > -2147196928
    >
    >
    > I tried looking up this error code but could not find it's translation,
    has
    > anybody got any idea what this error is trying to say and even better, how
    > to overcome this error?
    >
    > Thanks
    >
    > Jay
    >
    >

    Jay Guest

  3. #3

    Default Re: cloneModelFromCastMember error

    Jay wrote:
    > Sorry my fault - i hadnt preloaded( ) the 3D members
    Exactly. You can also use resetWorld() and check for the mediaReady of
    SW3D member and state = 4.
    --
    Agustín María Rodríguez | [email]agustinOnWine.com.ar[/email] | [url]www.OnWine.com.ar[/url]

    Agustín María Rodríguez Guest

  4. #4

    Default Re: cloneModelFromCastMember error

    yeah thx, that will help aviod errors when people with slower connections
    try to tretive their 3D members, i forget not everone has an 8mb backbone
    connection to the net like my uni!

    "Agustín María Rodríguez" <agustinonwine.com.ar> wrote in message
    news:bneavp$epk$1forums.macromedia.com...
    > Jay wrote:
    >
    > > Sorry my fault - i hadnt preloaded( ) the 3D members
    >
    > Exactly. You can also use resetWorld() and check for the mediaReady of
    > SW3D member and state = 4.
    > --
    > Agustín María Rodríguez | [email]agustinOnWine.com.ar[/email] | [url]www.OnWine.com.ar[/url]
    >

    Jay Guest

  5. #5

    Default Re: cloneModelFromCastMember error

    Jay wrote:
    > yeah thx, that will help aviod errors when people with slower connections
    > try to tretive their 3D members, i forget not everone has an 8mb backbone
    > connection to the net like my uni!
    Just for the sake of clarity, this has nothing to do with the
    connection. There´s a technote about how to clone correctly. The goal is
    making Director having totally "initialized" the 3D member from where
    you´re going to clone a model. The challenge is making the 3D member
    reach that state without being on the stage.

    HTH,
    --
    Agustín María Rodríguez | [email]agustinOnWine.com.ar[/email] | [url]www.OnWine.com.ar[/url]

    Agustín María Rodríguez Guest

Similar Threads

  1. using cloneModelFromCastMember
    By Roofy in forum Macromedia Director 3D
    Replies: 0
    Last Post: September 17th, 02:09 AM
  2. cloneModelFromCastMember
    By darylku in forum Macromedia Director 3D
    Replies: 7
    Last Post: April 18th, 04:33 PM
  3. cloneModelFromCastmember - error message help
    By mufc 1974 in forum Macromedia Director 3D
    Replies: 2
    Last Post: February 16th, 05:54 PM
  4. CloneModelFromCastMember : Script error: Error
    By Webfoot Ben in forum Macromedia Director 3D
    Replies: 0
    Last Post: December 4th, 06:36 AM
  5. using the CloneModelFromCastMember
    By Roofy in forum Macromedia Director 3D
    Replies: 2
    Last Post: September 23rd, 10:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139