Professional Web Applications Themes

Configuring hostname, domainname, and IP address - Linux Setup, Configuration & Administration

HI, Sorry to ask another dumb question. I want to configure my Redhat Advanced server 2.1 to into a local network. I plan to have only two nodes. hostname: red ip address: 10.0.0.1 domainname: testrac.com hostname: white ip address: 10.0.0.2 domainname: testrac.com So far, I am only working with the first machine, red. I'm trying to get the machine to recognize itself as red.testrac.com, at IP 10.0.0.1. On domain: testrac.com I have modified these files: cat /etc/hosts # Do not remove the following line, or various programs # that require network functionality will fail. 127.0.0.1 red red.testrac.com localhost.localdomain localhost 10.0.0.1 ...

  1. #1

    Default Configuring hostname, domainname, and IP address

    HI,

    Sorry to ask another dumb question.

    I want to configure my Redhat Advanced server 2.1 to
    into a local network. I plan to have only two nodes.

    hostname: red
    ip address: 10.0.0.1
    domainname: testrac.com

    hostname: white
    ip address: 10.0.0.2
    domainname: testrac.com

    So far, I am only working with the first machine, red.
    I'm trying to get the machine to recognize itself as
    red.testrac.com, at IP 10.0.0.1. On domain: testrac.com


    I have modified these files:

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 red red.testrac.com localhost.localdomain localhost
    10.0.0.1 red red.testrac.com


    cat /etc/sysconfig/network
    NETWORKING=yes
    HOSTNAME=red.testrac.com



    hostname
    red.testrac.com

    hostname --short
    red

    hostname --long
    red
    (odd. Why not the whole name?)


    domainname
    (none)

    dnsdomainname
    - nothing


    ping red.testrac.com

    PING red (127.0.0.1) from 127.0.0.1 : 56(84) bytes of data.
    64 bytes from red (127.0.0.1): icmp_seq=0 ttl=255 time=281 usec

    - looks at 127.0.0.1, not 10.0.0.1


    ping 10.0.0.1
    connect: Network is unreachable

    ------------

    I would like the command domainname to return:
    testrac.com, and ping 10.0.0.1 to find itself.

    What am I missing here? It is something with the dns?


    Thanks
    linuxquestion@yahoo.com Guest

  2. #2

    Default Re: Configuring hostname, domainname, and IP address

    com wrote: 
    Switch the red and the red.testrac.com in your host file. 
    Look to your /etc/hosts file. You have red.testrac.com as 127.0.0.1 as
    well as 10.0.0.1 and it is finding the 127.0.0.1 first. Remove the red
    and red.testrac.com from the 127.0.0.1 line. 
    Off the top of my head I am not sure about the domainname commands
    result but I will see what I can find.

    --
    Thanks
    Charles LaCour
    Charles Guest

  3. #3

    Default Re: Configuring hostname, domainname, and IP address

    On 1 Jan 2004 17:13:08 -0800, com wrote:
     
    Umm try it this way...

    127.0.0.1 localhost.localdomain localhost
    10.0.0.1 red.testrac.com red

    The lo and eth0 nics must have unique names (1st name after the IP
    address) and unique aliases (subsequent names on same line).
     
    I think you should also have a gateway statement in the
    /etc/sysconfig/network file, something like...

    GATEWAY=10.0.0.254


    FYI: The new convention is that .1 is the gateway device and the old
    convention is that .254 is the gateway device. Truth be know, it can be
    any valid IP within your network. Just be aware that most network
    devices (like routers) will have a factory default of one or the other.


    Brad
    --
    "Diplomacy is the art of letting someone else get your way."
    Unknown
    Bradley W. Olin
    http://www.bwo1.com
    Brad Guest

  4. #4

    Default Re: Configuring hostname, domainname, and IP address

    com wrote:
     

    The format is FQDN followed by aliases

    This is what it should read instead
    127.0.0.1 red.testrac.com red localhost.localdomain localhost
    --------------- +++ +++++++++++++++++++++ +++++++++
    where ---- is the fully qualified domainname
    and ++++ are aliases
     

    Ok
     

    Because the hosts file is barfed
     

    Ok
     

    Should read
    dnsdomainname
    testrac.com red


    Later Dude
    Baho Guest

  5. #5

    Default Re: Configuring hostname, domainname, and IP address

    On 02/01/04 14:01, after a futile battle with the keyboard, Baho Utot
    wrote ... [/ref]
    localhost 
    >
    >
    > The format is FQDN followed by aliases
    >
    > This is what it should read instead
    > 127.0.0.1 red.testrac.com red localhost.localdomain localhost
    > --------------- +++ +++++++++++++++++++++ +++++++++
    > where ---- is the fully qualified domainname and ++++ are aliases
    >[/ref]

    I am running like this: not declaring my eth0 address in hosts at all
    (see the comment why). Dunno if the reasoning is correct, but everything
    works this way.

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost lefty9
    # Notes 14 November 2003 - DT
    # Define lefty9 in localhost so gnome runs more quickly
    # through the loopback interface.
    # The following makes sendmail and sm-client start slowly
    #192.168.0.1 lefty9 # lefty running Redhat 9

    --
    Best regards,
    David Tangye
    Redhat Linux user since 1997
    Make sure you remove the 3 syllable spam trap in the reply address

    David Guest

  6. #6

    Default Re: Configuring hostname, domainname, and IP address

    Thanks for the responses. Ok, I tried this:

    change /etc/hosts to:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 red.testrac.com red localhost.localdomain localhost
    10.0.0.1 red.testrac.com red

    reboot

    ping -c 1 red
    PING red.testrac.com (127.0.0.1) from 127.0.0.1 : 56(84) bytes of data.
    64 bytes from red.testrac.com (127.0.0.1): icmp_seq=0 ttl=255 time=302 usec

    # ping -c 1 red.testrac.com
    PING red.testrac.com (127.0.0.1) from 127.0.0.1 : 56(84) bytes of data.
    64 bytes from red.testrac.com (127.0.0.1): icmp_seq=0 ttl=255 time=17 usec

    - it's still looking at 127.0.0.1

    hostname --long
    red.testrac.com

    hostname --short
    red


    But, it still can't see the IP address that I want to assign
    to this machine:

    ping -c 1 10.0.0.1
    connect: Network is unreachable

    dnsdomainname
    testrac.com

    How do I assign the IP address to the machine?

    Thanks


    ---------------

    BTW, I notice that your domain is: philippines-island.org Two of
    my girlfriends were Phillipina (not at the same time). They
    picked me. They had long hair past their waist.


    ---------------


    Baho Utot <org> wrote in message news:<philippines-island.org>... 
    >
    > The format is FQDN followed by aliases
    >
    > This is what it should read instead
    > 127.0.0.1 red.testrac.com red localhost.localdomain localhost
    > --------------- +++ +++++++++++++++++++++ +++++++++
    > where ---- is the fully qualified domainname
    > and ++++ are aliases

    >
    > Ok

    >
    > Because the hosts file is barfed

    >
    > Ok

    >
    > Should read
    > dnsdomainname
    > testrac.com red
    >
    >
    > Later Dude[/ref]
    linuxquestion@yahoo.com Guest

  7. #7

    Default Re: Configuring hostname, domainname, and IP address

    On 2 Jan 2004 13:20:44 -0800, com wrote: 


    Well, make up your mind.
    If you want 10,0,0,1
    127.0.0.1 localhost.localdomain localhost
    10.0.0.1 red.testrac.com red
    or
    127.0.0.1 red.testrac.com red localhost.localdomain localhost
    Bit Guest

  8. #8

    Default Re: Configuring hostname, domainname, and IP address

    com wrote:
     

    Thats because the 127.0.0.1 line is before the 10.0.0.1 try to swap them.
     

    If I understand the problem then it is assigned by ifconfig on boot, either
    by DHCP or a static setting.

     

    Yes I don't think two at the same time works ;)



    Baho Guest

  9. #9

    Default Re: Configuring hostname, domainname, and IP address

    com wrote: 
    >>
    >>The format is FQDN followed by aliases
    >>
    >>This is what it should read instead
    >> 127.0.0.1 red.testrac.com red localhost.localdomain localhost
    >> --------------- +++ +++++++++++++++++++++ +++++++++
    >>where ---- is the fully qualified domainname
    >>and ++++ are aliases
    >>
    >> 
    >>
    >>Ok
    >>
    >> 
    >>
    >>Because the hosts file is barfed
    >>
    >> 
    >>
    >>Ok
    >>
    >> 
    >>
    >>Should read
    >>dnsdomainname
    >>testrac.com red
    >>
    >>
    >>Later Dude[/ref][/ref]
    Did you read my earlier reply to your post?

    By having the short name, red, first in your /etc/hosts file that is
    considered your host name long or short. In your /etc/hosts file you
    should have each name and IP only once. By having red and
    red.testrac.com on two different lines with different IPs is ambiguous
    and likely not to produce the results you want. If you want to display
    the domain try hostname -d. If you take a look at the man pages the
    domainname command is used to show or set the systemís NIS/YP domain name.

    Your /etc/hosts file should look like this:
    127.0.0.1 localhost.localdomain localhost
    10.0.0.1 red.testrac.com red


    To dig further into your issue then please provide the output of the
    following commands:

    ifconfig -a
    netstat -nr
    cat /etc/sysconfig/network-scripts/eth0
    cat /etc/resolv.conf
    cat /nsswitch.conf

    --
    Thanks
    Charles LaCour
    Charles Guest

  10. #10

    Default Re: Configuring hostname, domainname, and IP address

    On Fri, 02 Jan 2004 23:21:22 GMT, Charles LaCour
    <homelinux.com> wrote:
     [/ref]

    fyi: a reboot is not required here
     [/ref]

    Yup. That is what you told it to do. BT said it well, make up your
    mind...
     

    Obviously not, nor mine.

    btw: I wouldn't have repeated almost exactly your post except that your
    news server is better connected than mine. Sorry about that, I'll try
    harder to not stutter your words. :)


    Brad
    --
    "Diplomacy is the art of letting someone else get your way."
    Unknown
    Bradley W. Olin
    http://www.bwo1.com
    Brad Guest

  11. #11

    Default Re: Configuring hostname, domainname, and IP address

    Brad Olin wrote: [/ref]
    >
    >
    > fyi: a reboot is not required here
    >
    > [/ref]
    >
    >
    > Yup. That is what you told it to do. BT said it well, make up your
    > mind...
    >

    >
    >
    > Obviously not, nor mine.
    >
    > btw: I wouldn't have repeated almost exactly your post except that your
    > news server is better connected than mine. Sorry about that, I'll try
    > harder to not stutter your words. :)
    >
    >
    > Brad[/ref]
    No problem, I don't mind if you repeat what I say. I have done the same
    thing, now I try to remember to check for new posts just before I submit
    my reply especially if it has taken me a while to put together my response.

    --
    Thanks
    Charles LaCour
    Charles Guest

  12. #12

    Default Re: Configuring hostname, domainname, and IP address

    On 03/01/04 09:21, after an epic battle with a keyboard, Charles LaCour
    wrote ... 

    Agreed. Repeating FQDN and aliases is wrong, as is switching them. RTFM.

    com wrote: 

    The ip address for ethernet, on Redhat systems at least , is in
    somewhere like /etc/sysconfig/networking/devices/ifcfg-eth0. This is mine:

    DEVICE=eth0
    BOOTPROTO=none
    BROADCAST=192.168.0.255
    IPADDR=192.168.0.1
    NETMASK=255.255.255.0
    NETWORK=192.168.0.0
    ONBOOT=yes
    USERCTL=no
    PEERDNS=no
    TYPE=Ethernet
    GATEWAY=192.168.0.254

    Note my IP address at IPADDR=192.168.0.1

    --
    Best regards,
    David Tangye - Redhat Linux user since 1997
    Reply to com.au
    Make sure you remove the 3 syllable spam trap in the reply address

    David Guest

  13. #13

    Default Re: Configuring hostname, domainname, and IP address

    On Thu, 01 Jan 2004 17:13:08 -0800, linuxquestion wrote:
     

    Actually, /etc/hosts on *each* machine should look like this:

    127.0.0.1 localhost # and only localhost
    127.0.0.2 localhost.localdomain # may be unnecessary
    10.0.0.1 red.testrac.com red
    10.0.0.2 white.testrac.com white

    Ed Guest

  14. #14

    Default Re: Configuring hostname, domainname, and IP address

    David Tangye wrote:
     
    >
    > Agreed. Repeating FQDN and aliases is wrong, as is switching them. RTFM.
    >[/ref]
    Ok lets take this example shall we:
    127.0.0.1 red.testrac.com red localhost.localdomain localhost

    What is wrong with this....nothing if we RTFM we find that the only FQDN is
    red.testrac.com, red localhost.localdomain localhost are aliases.
    There is nothing that states you cannot have white.testrac.com as an alias.
    If we are dealing with a single machine then it is quite proper.
    Lookup the definition of an alias.
     

    This can be 127.0.0.1 red.testrac.com red localhost.localdomain localhost
    and 10.0.0.1 set in /etc/sysconfig/networking/devices/ifcfg-eth0 and the
    problem is solved.

    Now this may be a problem on a network w/o DNS as each host file would be
    unique to that machine as in white.testrac.com host file being:
    127.0.0.1 white.testrac.com white localhost.localdomain localhost
    10.0.0.1 red.testrac.com red

    and red.testrac.com being:
    127.0.0.1 red.testrac.com red localhost.localdomain localhost
    10.0.0.2 white.testrac.com white

    The easist way:

    127.0.0.1 localhost.localdomain localhost
    10.0.0.1 red.testrac.com red
    10.0.0.2 white.testrac.com white

    With DNS the first way works every time.

    Agreed?
    Baho Guest

  15. #15

    Default Re: Configuring hostname, domainname, and IP address

    Yes, I did try what you suggested. But it didn't work.

    -----------------

    change /etc/hosts to:

    127.0.0.1 localhost.localdomain localhost
    10.0.0.1 red.testrac.com red

    reboot:

    ping red
    connect: Network is unreachable

    ping red.testrac.com
    connect: Network is unreachable

    dnsdomainname
    testrac.com

    -----------------

    Maybe I am phrasing the question wrong, but the original question is
    to get the machine to recognize itself as ALL of:

    127.0.0.1, 10.0.0.1, red.testrac.com, red

    So, if I ping 10.0.0.1, it should immediately find itself.
    Later, I will connect a second node (10.0.0.2), and it should
    immediately find it also. I believe that I am correct when I
    assume that, if a machine can't find itself, it will not find
    the second machine.

    Perhaps another way to phrase the question would be:
    how do I set the IP address, domainname, and hostname
    for an individual machine?



    ---------------------------------



    Charles LaCour <homelinux.com> wrote in message news:<04rJb.38954$socal.rr.com>... 
    > >
    > >
    > > fyi: a reboot is not required here
    > >
    > > 
    > >
    > >
    > > Yup. That is what you told it to do. BT said it well, make up your
    > > mind...
    > >
    > > 
    > >
    > >
    > > Obviously not, nor mine.
    > >
    > > btw: I wouldn't have repeated almost exactly your post except that your
    > > news server is better connected than mine. Sorry about that, I'll try
    > > harder to not stutter your words. :)
    > >
    > >
    > > Brad[/ref]
    > No problem, I don't mind if you repeat what I say. I have done the same
    > thing, now I try to remember to check for new posts just before I submit
    > my reply especially if it has taken me a while to put together my response.[/ref]
    linuxquestion@yahoo.com Guest

  16. #16

    Default Re: Configuring hostname, domainname, and IP address

    > To dig further into your issue then please provide the output of the 

    -----------------

    Ok, nothing like surprises! It looks like the ethernet is not
    setup. Even though I have Ethernet, I believe on the motherboard.


    While not connected to the internet:

    -------------------
    cat /etc/sysconfig/network-scripts/eth0
    cat: /etc/sysconfig/network-scripts/eth0: No such file or directory

    - odd, since my motherboard comes with a built in ethernet.


    -------------------

    hostname -d
    testrac.com

    -------------------

    ifconfig -a
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:210 errors:0 dropped:0 overruns:0 frame:0
    TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0
    RX bytes:14562 (14.2 Kb) TX bytes:14562 (14.2 Kb)

    -------------------
    netstat -nr

    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window
    irtt Iface
    127.0.0.0 0.0.0.0 255.0.0.0 U 40 0
    0 lo



    -------------------
    cat /etc/resolv.conf
    domain testrac.com


    -------------------

    In the Redhat hardware browser GUI, I can find nothing looking like
    an ethernet card. There is:
    CDROM, Floppy disks, hard disks, system devices, and USB devices
    Under system devices, there is four: USB UHCI Root hub

    I went into the Windows boot, and exported information from
    System info, network.


    [Adapter]

    Item Value
    Name [00000001] Intel(R) PRO/100 VE Network Connection
    Adapter Type Ethernet 802.3
    Product Type Intel(R) PRO/100 VE Network Connection
    Installed Yes
    PNP Device ID PCI\VEN_8086&DEV_1050&SUBSYS_01551028&REV_02\4&1C6 60DD6&0&40F0
    Last Reset 1/3/2004 11:48 AM
    Index 1
    Service Name E100B
    IP Address 0.0.0.0
    IP Subnet
    Default IP Gateway Not Available
    DHCP Enabled Yes
    DHCP Server
    DHCP Lease Expires Not Available
    DHCP Lease Obtained Not Available
    MAC Address 00:07:E9:3C:E3:24
    Memory Address 0xFCFFB000-0xFCFFBFFF
    I/O Port 0x0000DF40-0x0000DF7F
    IRQ Channel IRQ 20
    Driver c:\windows\system32\drivers\e100b325.sys (7.0.26.0 built by:
    WinDDK, 142.00 KB (145,408 bytes), 1/1/1980 12:00 AM)


    So, what docs do I need to be reading to configure the ethernet,
    and network?


    If this wasn't a big enough surprise, get this. I exported the
    text file from windows. But, cat network.txt | grep -i ethernet
    finds nothing. But, cat network.txt | wc gives me 492 lines.
    Even grep doesn't want to work today!


    Thanks
    linuxquestion@yahoo.com Guest

  17. #17

    Default Re: Configuring hostname, domainname, and IP address

    On 3 Jan 2004 08:36:44 -0800, com wrote:
     

    Your /etc/hosts finally looks reasonable. The error message that you
    now report indicates the network is not working...

    I'll quote Charles' earlier post

    To dig further into your issue then please provide the output of the
    following commands:

    ifconfig -a
    netstat -nr
    cat /etc/sysconfig/network-scripts/eth0
    cat /etc/resolv.conf
    cat /etc/nsswitch.conf


    Brad
    --
    "Until you make peace with who you are, you'll never be content with
    what you have." Doris Mortman

    Bradley W. Olin
    http://www.bwo1.com
    Brad Guest

  18. #18

    Default Re: Configuring hostname, domainname, and IP address

    In comp.os.linux.networking com wrote: 

    Yes it did.
     
     

    This is now presumably a correct /etc/hosts. What is your hostname?
    What machine is "red"? And which interface have you assigned the IP
    10.0.0.1 too, if it is this machine?
     

    Don't! What on earth do you think that will do?
     

    So? All that means is that you haven't set an interface to talk to
    10./8 on.
     

    Quite right. But it should have told you the IP number too!
     

    Fine.
     

    There is no semantics to "recognize".
     

    It knows all that it needs to know.
     

    What do you mean? It does no finding. It simply sends the packets to
    the interface through which 10./8 is routed. If you have an interface
    configured as 10.0.0.1, then the kernel itself will intercept the
    packets and answer for it.

    So we deduce that you forgot to configure an interface as 10.0.0.1.
     

    I don't understand what you mean. Please use normal terminology!
     

    It doesn't do any "finding".
     
     

    There is no such thing as "the IP address". Machines normally have
    many. At least one per interface. Machines do have a unique hostname
    (with a unique domainname too), however, and you set it with
    "hostname", unsurprisingly.

    You may choose to set a FQDN with hostname, in which case the
    domainname is defined immediately as the trailing portion. If
    you only set an alias with hostname (e.g. "red"), then that alias
    will be looked up in /etc/hosts to find a canonical name
    ("red.testrac.com") which must be the first entry on the line on which
    the alias occurs. And the canonical name must be a FQDN, in order that
    the domainname be derived from it.

    Unsurprisingly too, you set the IP address of an interface with
    "ifconfig".

    Even more unsurprisingly, you set the routing out through your various
    interfaces with "route".

    So cease making a mess of this perfectly straightforward stuff.

    Peter
    P.T. Guest

  19. #19

    Default Re: Configuring hostname, domainname, and IP address

    com wrote: 
    >
    >
    > -----------------
    >
    > Ok, nothing like surprises! It looks like the ethernet is not
    > setup. Even though I have Ethernet, I believe on the motherboard.
    >
    >
    > While not connected to the internet:
    >
    > -------------------
    > cat /etc/sysconfig/network-scripts/eth0
    > cat: /etc/sysconfig/network-scripts/eth0: No such file or directory
    >
    > - odd, since my motherboard comes with a built in ethernet.
    >
    >
    > -------------------
    >
    > hostname -d
    > testrac.com
    >
    > -------------------
    >
    > ifconfig -a
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > UP LOOPBACK RUNNING MTU:16436 Metric:1
    > RX packets:210 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0
    > RX bytes:14562 (14.2 Kb) TX bytes:14562 (14.2 Kb)
    >
    > -------------------
    > netstat -nr
    >
    > Kernel IP routing table
    > Destination Gateway Genmask Flags MSS Window
    > irtt Iface
    > 127.0.0.0 0.0.0.0 255.0.0.0 U 40 0
    > 0 lo
    >
    >
    >
    > -------------------
    > cat /etc/resolv.conf
    > domain testrac.com
    >
    >
    > -------------------
    >
    > In the Redhat hardware browser GUI, I can find nothing looking like
    > an ethernet card. There is:
    > CDROM, Floppy disks, hard disks, system devices, and USB devices
    > Under system devices, there is four: USB UHCI Root hub
    >
    > I went into the Windows boot, and exported information from
    > System info, network.
    >
    >
    > [Adapter]
    >
    > Item Value
    > Name [00000001] Intel(R) PRO/100 VE Network Connection
    > Adapter Type Ethernet 802.3
    > Product Type Intel(R) PRO/100 VE Network Connection
    > Installed Yes
    > PNP Device ID PCI\VEN_8086&DEV_1050&SUBSYS_01551028&REV_02\4&1C6 60DD6&0&40F0
    > Last Reset 1/3/2004 11:48 AM
    > Index 1
    > Service Name E100B
    > IP Address 0.0.0.0
    > IP Subnet
    > Default IP Gateway Not Available
    > DHCP Enabled Yes
    > DHCP Server
    > DHCP Lease Expires Not Available
    > DHCP Lease Obtained Not Available
    > MAC Address 00:07:E9:3C:E3:24
    > Memory Address 0xFCFFB000-0xFCFFBFFF
    > I/O Port 0x0000DF40-0x0000DF7F
    > IRQ Channel IRQ 20
    > Driver c:\windows\system32\drivers\e100b325.sys (7.0.26.0 built by:
    > WinDDK, 142.00 KB (145,408 bytes), 1/1/1980 12:00 AM)
    >
    >
    > So, what docs do I need to be reading to configure the ethernet,
    > and network?
    >
    >
    > If this wasn't a big enough surprise, get this. I exported the
    > text file from windows. But, cat network.txt | grep -i ethernet
    > finds nothing. But, cat network.txt | wc gives me 492 lines.
    > Even grep doesn't want to work today!
    >
    >
    > Thanks[/ref]
    When you did the install did it ask you about the network setup?

    In the meantime run the redhat-config-network application and try to
    configure a new ethernet device using "Intel EtherExpress Pro 100B" as
    the adapter type.

    It that fails then try the following commands and let me know the output:
    ethtool -i eth0
    lsmod

    --
    Thanks
    Charles LaCour
    Charles Guest

  20. #20

    Default Re: Configuring hostname, domainname, and IP address

    com wrote:
     [/ref]


    mine is called /etc/sysconfig/network-scripts/ifcfg-eth0

    [ok, so it's an old versn of RH] What does:

    $ ls /etc/sysconfig/network-scripts

    give?

    Robert Guest

Page 1 of 2 12 LastLast

Similar Threads

  1. Changing hostname / IP address
    By Five in forum Informix
    Replies: 16
    Last Post: January 18th, 11:14 PM
  2. Replies: 0
    Last Post: July 7th, 07:42 PM
  3. NIS domainname vs FQN
    By Steve Fabac in forum SCO
    Replies: 0
    Last Post: July 2nd, 04:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139