Professional Web Applications Themes

connection concentrator and shared memory - IBM DB2

I am trying to use the database connection concentrator (maxagents < maxconnections) on UDB8 FP2. As soon as I set it like that when I try to connect to the database I get a shared memory error. Here are the details: with this config: Priority of agents (AGENTPRI) = SYSTEM Max number of existing agents (MAXAGENTS) = 20 Agent pool size (NUM_POOLAGENTS) = 20 Initial number of agents in pool (NUM_INITAGENTS) = 0 Max number of coordinating agents (MAX_COORDAGENTS) = 20 Max no. of concurrent coordinating agents (MAXCAGENTS) = MAX_COORDAGENTS Max number of client connections (MAX_CONNECTIONS) = 200 I get: ...

  1. #1

    Default connection concentrator and shared memory

    I am trying to use the database connection concentrator (maxagents <
    maxconnections) on UDB8 FP2. As soon as I set it like that when I try to
    connect to the database I get a shared memory error. Here are the details:

    with this config:

    Priority of agents (AGENTPRI) = SYSTEM
    Max number of existing agents (MAXAGENTS) = 20
    Agent pool size (NUM_POOLAGENTS) = 20
    Initial number of agents in pool (NUM_INITAGENTS) = 0
    Max number of coordinating agents (MAX_COORDAGENTS) = 20
    Max no. of concurrent coordinating agents (MAXCAGENTS) = MAX_COORDAGENTS
    Max number of client connections (MAX_CONNECTIONS) = 200

    I get:

    $ db2 connect to c814db
    SQL1084C Shared memory segments cannot be allocated. SQLSTATE=57019

    If I change maxagents, num_poolagents and max_coordagents = max_connections
    it works fine.

    Any ideas?



    /Frank





    Frank Guest

  2. #2

    Default Re: connection concentrator and shared memory

    Frank,

    The connection concentrator is enabled by setting max_coordagents <
    max_connections (not maxagents < max_connections).

    Larry Edelstein

    Frank Apap wrote:
     

    Larry Guest

  3. #3

    Default Re: connection concentrator and shared memory


    "Larry Edelstein" <ibm.com> wrote in message
    news:ibm.com... 

    When I try to change just one it complains about the restraint that
    maxagents = max_coordagents.

    Is there a way around that?

    I changed both maxagents and max_coordagents.

    /Frank



    Frank Guest

Similar Threads

  1. Shared memory and Mac OS X
    By Wes in forum PostgreSQL / PGSQL
    Replies: 5
    Last Post: February 22nd, 04:01 AM
  2. Shared Memory/Shared Buffers
    By Alex Turner in forum PostgreSQL / PGSQL
    Replies: 1
    Last Post: January 28th, 04:09 PM
  3. Shared video memory
    By Reza Saheban in forum Macromedia Freehand
    Replies: 0
    Last Post: March 6th, 10:49 PM
  4. Shared memory in OS X?
    By Mike H. in forum Mac Programming
    Replies: 3
    Last Post: September 30th, 03:46 AM
  5. I think I need a DB with no shared memory
    By dimonex in forum Informix
    Replies: 1
    Last Post: July 3rd, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139