Professional Web Applications Themes

"Connection refused" - FreeBSD

People, I must have bumped into this before, but it still stumps me. What would my sendmail on sage/ns1.thought.org get a "Connection refused" from my major server, tao.thought.org? Mail is queued in ns1. Any ideas what I'm missing in /etc OR /etc/mail in my new FreeBSD?? thanks, gary -- Gary Kline org www.thought.org Public service Unix...

  1. #1

    Default "Connection refused"


    People,

    I must have bumped into this before, but it still stumps me.
    What would my sendmail on sage/ns1.thought.org get a
    "Connection refused" from my major server, tao.thought.org?
    Mail is queued in ns1.

    Any ideas what I'm missing in /etc OR /etc/mail in my new
    FreeBSD??

    thanks,

    gary




    --
    Gary Kline org www.thought.org Public service Unix

    Gary Guest

  2. #2

    Default Re: "Connection refused"

    On Mar 15, 2005, at 7:03 PM, Gary Kline wrote: 

    DNS for that address is broken, so sendmail on the other machine is
    unable to get a valid a record to make a connection, so you get
    "connection refused":

    5-pi% dig tao.thought.org.
    ; <<>> DiG 9.3.0 <<>> tao.thought.org.
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21895
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;tao.thought.org. IN A

    ;; AUTHORITY SECTION:
    thought.org. 600 IN SOA ns1.thought.org.
    hostmaster.thought.org. 2005021201 3600 300 2419200 3600

    --
    -Chuck

    Charles Guest

  3. #3

    Default Re: "Connection refused"

    On Tue, Mar 15, 2005 at 07:14:43PM -0500, Charles Swiger wrote: 
    >
    > DNS for that address is broken, so sendmail on the other machine is
    > unable to get a valid a record to make a connection, so you get
    > "connection refused":
    >[/ref]

    tao is on my private 10.0.0.247 IP. I *have* added
    ns1.thought.org to my /etc/mail/access file and did a
    "# make maps"; I also reinitialized sendmail.

    Still get "Connection refused" /etc/hosts* andn
    /etc/resolv.conf look good. What else??


    gary


     

    --
    Gary Kline org www.thought.org Public service Unix

    Gary Guest

  4. #4

    Default Re: "Connection refused"

    Gary Kline wrote: 
    [ ... ] 
    >
    > tao is on my private 10.0.0.247 IP. I *have* added
    > ns1.thought.org to my /etc/mail/access file and did a
    > "# make maps"; I also reinitialized sendmail.
    >
    > Still get "Connection refused" /etc/hosts* andn
    > /etc/resolv.conf look good. What else??[/ref]

    You can try telnet'ing to port 25 on the problem host from your other machine
    by hand and see what happens. However, sendmail really wants valid DNS for
    mail servers, so changing /etc/hosts probably isn't going going to be enough.
    Consider using a mailertable entry with [10.0.0.247] to disable MX lookups,
    rather than a hostname...

    --
    -Chuck

    Chuck Guest

  5. #5

    Default Re: "Connection refused"

    On Wed, Mar 16, 2005 at 12:07:29AM -0500, Chuck Swiger wrote: 
    > [ ... ] 
    > >
    > > tao is on my private 10.0.0.247 IP. I *have* added
    > > ns1.thought.org to my /etc/mail/access file and did a
    > > "# make maps"; I also reinitialized sendmail.
    > >
    > > Still get "Connection refused" /etc/hosts* andn
    > > /etc/resolv.conf look good. What else??[/ref]
    >
    > You can try telnet'ing to port 25 on the problem host from your other
    > machine by hand and see what happens. However, sendmail really wants valid
    > DNS for mail servers, so changing /etc/hosts probably isn't going going to
    > be enough. Consider using a mailertable entry with [10.0.0.247] to disable
    > MX lookups, rather than a hostname...
    >[/ref]

    This is strange; I just allowed telnet in /etc/inetd.conf and
    reinitialized; from here on sage/ns1, this.

    telnet tao 25
    Trying 10.0.0.247...
    telnet: connect to address 10.0.0.247: Connection refused
    telnet: Unable to connect to remote host

    Could I be missing something in rc.conf?

    gary

     

    --
    Gary Kline org www.thought.org Public service Unix

    Gary Guest

  6. #6

    Default RE: "Connection refused"

    > > 

    No need to enable telnet in inetd.conf if you're just using it to test
    a tcp connection to another host, that's only if you want to be able to
    log on to the host from another machine using telnet.
     

    Hmm you should get a basic connection, on tao whats the output of
    sockstat -4 |grep :25
    I get
    root sendmail 651 3 tcp4 *:25 *:*

    i.e. is sendmail actualy running ? if yes, is it listening on any ip other
    than 127.0.0.1 ? (mine is listening on *)
    If still yes then do you have a firewall or tcpwrappers blocking access ?

    Assuming base sendmail (not ports) what is the output of
    grep sendmail /etc/rc.conf
    (should be sendmail_enable="YES" unless you are using sendmail from ports)


    Vince

     
    >
    > --
    > Gary Kline org www.thought.org
    > Public service Unix
    >
    > _______________________________________________
    > org mailing list
    > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
    > To unsubscribe, send any mail to
    > "org"
    >[/ref]

    Vince Guest

  7. #7

    Default Re: "Connection refused"

    On Wed, Mar 16, 2005 at 10:33:10PM -0000, Vince wrote: 
    > >
    > > This is strange; I just allowed telnet in /etc/inetd.conf and
    > > reinitialized; from here on sage/ns1, this.[/ref]
    >
    > No need to enable telnet in inetd.conf if you're just using it to test
    > a tcp connection to another host, that's only if you want to be able to
    > log on to the host from another machine using telnet.

    >
    > Hmm you should get a basic connection, on tao whats the output of
    > sockstat -4 |grep :25
    > I get
    > root sendmail 651 3 tcp4 *:25 *:*
    >
    > i.e. is sendmail actualy running ? if yes, is it listening on any ip other
    > than 127.0.0.1 ? (mine is listening on *)[/ref]


    root sendmail 13287 3 tcp4 *:25 *:*

    So it's the same... .

     


    Ah, so it was the _enable="NO" that was causing the trouble.
    I just got mail flowing to tao by using the rc.conf from
    a different server that accepted mail from ns1.thought.org.
    I just asked the list some questions about my mods to
    /etc/rc.conf on my home server; you've answered my question
    while I was answering other email. :-)

    Just to be sure I'll turn off the sendmail_enable, restart,
    and see it the connection is refused.


    live and learn...

    gary


     

    --
    Gary Kline org www.thought.org Public service Unix

    Gary Guest

Similar Threads

  1. "Contribute cannot verify your connection information."on a Local / Network connection
    By Nabhanabha in forum Macromedia Contribute Connection Administrtion
    Replies: 5
    Last Post: February 22nd, 08:37 PM
  2. Replies: 6
    Last Post: March 14th, 10:40 PM
  3. NIC-activation => Xlib: connection to ":0.0" refused by server
    By Doru-Catalin in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: October 17th, 04:53 AM
  4. "Connection Reset by Peer" or "hang"
    By Aurelien Derouineau in forum Debian
    Replies: 0
    Last Post: July 22nd, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139