Professional Web Applications Themes

CS: Scripts do not appear in Scripts menu - Adobe Illustrator Macintosh

I have several utility AppleScripts that I created for Illustrator 10. I'd like to use these in CS, and they work correctly when I choose "Browse" under the Scripts menu, navigate to the script, and run it. However, I can't get EITHER these scripts or the Adobe-supplied default scripts to appear in CS's Scripts menu. The menu appears blank except for the "Browse" option. I have tried the procedure in the help file (which worked in Illustrator 10): Add the scripts to the Presets>Scripts folder, quit CS, then relaunch it. No luck. I also have tried deleting the CS prefs ...

  1. #1

    Default CS: Scripts do not appear in Scripts menu

    I have several utility AppleScripts that I created for Illustrator 10. I'd like to use these in CS, and they work correctly when I choose "Browse" under the Scripts menu, navigate to the script, and run it.

    However, I can't get EITHER these scripts or the Adobe-supplied default scripts to appear in CS's Scripts menu. The menu appears blank except for the "Browse" option.

    I have tried the procedure in the help file (which worked in Illustrator 10): Add the scripts to the Presets>Scripts folder, quit CS, then relaunch it. No luck. I also have tried deleting the CS prefs folder, with no result.

    Anyone know what I need to do to get ANY scripts to appear in this menu? Thanks...
    jlw99@adobeforums.com Guest

  2. #2

    Default Re: CS: Scripts do not appear in Scripts menu

    I just added a script to my AI CS Script folder and it appears there and works just fine.

    Do you launch AI from an alias say on the desktop or have you moved the application out of the AI folder?
    Wade_Zimmerman@adobeforums.com Guest

  3. #3

    Default Re: CS: Scripts do not appear in Scripts menu

    Wade, thanks for checking.

    I had been launching AI from a dock icon, but tried double-clicking directly on the icon; didn't help. All the CS stuff is still in its default install location.

    I found that the Scripts folder had different permission settings than the other folders in Presets, but changing it to match didn't help.

    To summarize:

    * Any scripts installed in the Presets>Scripts folder do NOT display in the CS Scripts menu; the only thing that shows is the "Browse" option.

    * The same scripts installed in Illustrator 10's Presets>Scripts folder display correctly in the Scripts menu.

    * The scripts do run correctly in CS if I choose Browse and navigate to them manually; I just can't get them to display in the menu. I use some of these scripts dozens of times per day, so having to browse them every time is a productivity hit.

    Any other thoughts, anyone? I guess the next play is to reinstall CS, but that's a major nuisance...
    jlw99@adobeforums.com Guest

  4. #4

    Default Re: CS: Scripts do not appear in Scripts menu

    Okay, I reinstalled CS and now the scripts show up properly.

    Problem solved, but mysterious. I still always wind up wishing I knew WHY these things happened...
    jlw99@adobeforums.com Guest

Similar Threads

  1. How di I use scripts?
    By Steve_Dorsey@adobeforums.com in forum Adobe Indesign Windows
    Replies: 2
    Last Post: July 24th, 02:35 PM
  2. Where should PHP scripts go?
    By Andrew C. in forum PHP Development
    Replies: 4
    Last Post: April 7th, 04:02 PM
  3. Contextual Menu Parent Scripts : update and init script available
    By Karl Sigiscar in forum Macromedia Director 3D
    Replies: 1
    Last Post: January 26th, 08:57 PM
  4. scripts that control other scripts
    By kiaoraFiona webforumsuser@macromedia.com in forum Macromedia Director Lingo
    Replies: 8
    Last Post: October 6th, 05:07 PM
  5. Scripts - Somebody know how to do this?
    By RC in forum PHP Development
    Replies: 1
    Last Post: July 15th, 05:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139