Professional Web Applications Themes

CSS style not being applied in browser - Macromedia Dreamweaver

I've begun creating a website for which I am creating custom CSS Styles to apply fonts/size/colour etc to all the text in the pages. Seems easy - create style sheet - select block of text and apply style. When I am in Dreamweaver and I hit F12 to preview in browser everything looks fine, however if I shut dreamweaver and from within internet explorer choose open file and open my pages locally all the CSS formatting is lost. Doesn't appear. All gets upgly-looking and goes to default. Any ideas why this is happenning? Only have one CSS file. In the ...

  1. #1

    Default CSS style not being applied in browser

    I've begun creating a website for which I am creating custom CSS Styles to apply fonts/size/colour etc to all the text in the pages. Seems easy - create style sheet - select block of text and apply style. When I am in Dreamweaver and I hit F12 to preview in browser everything looks fine, however if I shut dreamweaver and from within internet explorer choose open file and open my pages locally all the CSS formatting is lost. Doesn't appear. All gets upgly-looking and goes to default.
    Any ideas why this is happenning? Only have one CSS file. In the same root folder as the pages. Tried it both with and without a doctype at the start of the html file. Is it something that will be different once uploaded?
    So far I am only testing using a mac with internet explorer 5.1 (it's only the first couple of days, testing on other platforms this weekend).


    Danielle_K_ webforumsuser@macromedia.com Guest

  2. #2

    Default Re: CSS style not being applied in browser

    "Danielle_K_" [email]webforumsusermacromedia.com[/email] wrote:
    > I've begun creating a website for which I am creating custom CSS Styles to apply fonts/size/colour etc to all the text in the pages. Seems easy - create style sheet - select block of text and apply style. When I am in Dreamweaver and I hit F12 to preview in browser everything looks fine, however if I shut dreamweaver and from within internet explorer choose open file and open my pages locally all the CSS formatting is lost. Doesn't appear. All gets upgly-looking and goes to default.
    > Any ideas why this is happenning? Only have one CSS file. In the same root folder as the pages. Tried it both with and without a doctype at the start of the html file. Is it something that will be different once uploaded?
    > So far I am only testing using a mac with internet explorer 5.1 (it's only the first couple of days, testing on other platforms this weekend).
    Sounds as if the path to the style sheet is wrong.
    Change to code view, look in the head of the page and find:
    <link rel="stylesheet" href="styles.css" type="text/css">
    (in this example, the CSS is called "styles.css")
    Since you have the sheet in the same folder as the page, the path
    indicated after "href=" should simply be the sheet's name. No slashes,
    dots or anything else.

    HTH
    --
    Dan Vendel - *GOF*
    [url]http://www.vendel.info[/url]
    Contact me directly by clicking here:
    [url]http://contact.vendel.info[/url]
    Formmail tutorial:
    [url]http://www.vendel.info/tut/formmail.html[/url]
    Nested table demonstration:
    [url]http://www.vendel.info/tabletut/[/url]

    Dan Vendel *GOF* Guest

  3. #3

    Default Re: CSS style not being applied in browser

    Thanks Dan, that was the problem

    in article [email]3F0D1578.20106_the_bottom_of_the_post.com[/email], Dan Vendel *GOF* at
    [email]see_my_signature__the_bottom_of_the_post.com[/email] wrote on 10/7/03 5:27 PM:
    > "Danielle_K_" [email]webforumsusermacromedia.com[/email] wrote:
    >
    >> I've begun creating a website for which I am creating custom CSS Styles to
    >> apply fonts/size/colour etc to all the text in the pages. Seems easy - create
    >> style sheet - select block of text and apply style. When I am in Dreamweaver
    >> and I hit F12 to preview in browser everything looks fine, however if I shut
    >> dreamweaver and from within internet explorer choose open file and open my
    >> pages locally all the CSS formatting is lost. Doesn't appear. All gets
    >> upgly-looking and goes to default.
    >> Any ideas why this is happenning? Only have one CSS file. In the same root
    >> folder as the pages. Tried it both with and without a doctype at the start of
    >> the html file. Is it something that will be different once uploaded?
    >> So far I am only testing using a mac with internet explorer 5.1 (it's only
    >> the first couple of days, testing on other platforms this weekend).
    >
    > Sounds as if the path to the style sheet is wrong.
    > Change to code view, look in the head of the page and find:
    > <link rel="stylesheet" href="styles.css" type="text/css">
    > (in this example, the CSS is called "styles.css")
    > Since you have the sheet in the same folder as the page, the path
    > indicated after "href=" should simply be the sheet's name. No slashes,
    > dots or anything else.
    >
    > HTH
    Danielle Kunowski Guest

Similar Threads

  1. pls help : font name not applied
    By Raghu Raman in forum ASP.NET Building Controls
    Replies: 0
    Last Post: November 22nd, 05:27 PM
  2. Fonts change when graphic style gradient applied
    By Kimberly_Perkins@adobeforums.com in forum Adobe Illustrator Windows
    Replies: 6
    Last Post: June 18th, 08:16 AM
  3. Replies: 0
    Last Post: April 26th, 07:06 PM
  4. why I cant' view a STYLE applied to label
    By juavizga in forum ASP.NET General
    Replies: 0
    Last Post: July 27th, 11:44 PM
  5. php upgrade not being applied - please help!
    By Dan Foster in forum PHP Development
    Replies: 5
    Last Post: July 17th, 05:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139