Professional Web Applications Themes

DB2 Connect to AS/400 failed - IBM DB2

Greeting all, DB2 Ver 7.2 I have installed with the IBM DB Connect on the local database OS/2 in order to set the remote database access to AS/400. Currently, I got the problem to logon to the prompt node logon screen for remote database with return error code SQL30081N, SQLSTATE=08001, 10061. The basic info setting for the AS/400 database as follows 1.In CCA, Click on Add button will come out Add Database Wizard Screen to configure a connection. 2.Source options as Use a profile, Search the network, or Manually configure a connection to a database. Choose the option Manually Configure ...

  1. #1

    Default DB2 Connect to AS/400 failed

    Greeting all,

    DB2 Ver 7.2

    I have installed with the IBM DB Connect on the local database OS/2 in
    order to set the remote database access to AS/400. Currently, I got
    the problem to logon to the prompt node logon screen for remote
    database with return error code SQL30081N, SQLSTATE=08001, 10061.


    The basic info setting for the AS/400 database as follows

    1.In CCA, Click on Add button will come out Add Database Wizard Screen
    to configure a connection.

    2.Source options as Use a profile, Search the network, or Manually
    configure
    a connection to a database. Choose the option Manually Configure a
    connection
    to a database. Click on Next.

    3.Select a communication protocol. Click on TCP/IP.

    4.Mark the database physically resides on a host or AS/400 system and
    select
    connect directly to the server. Click on Next.

    5.In Specify TCP/IP communication parameters.
    a.Host name: 172.16.2.250
    b.Port number: 446 (default)

    6.Click on Next.

    7.In Specify the name of the database to which you want to connect.
    a.Database name: SA400E
    b.Database alias: SA400E
    c.Comment: AS/400 Database

    8.Click on Next.

    9.In Register this database as an ODBC data source (if ODBC
    installed).
    a.Deselect this database for ODBC

    10.Click on Next.

    11.In (Optional) Specify the node options.
    a.Select Configure node options (Optional)
    b.System name : SA400E
    c.Operating System : OS/400

    12.Click on Next.

    13.In (Optional) Specify the security options. (Choose SERVER) Click
    on Next.

    14.In (Optional) Configure Host or AS/400 option.

    15.Click on Finish will close the wizard screen and come back to CCA
    Screen.

    16.On CCA Screen, click on Test will prompt out Connection to DB2
    Database
    Dialog.

    17.Input the User ID (lmsusd) and Password (lmspwd). The USERID and
    PASSWORD
    are the remote userid and password. Click on OK.

    18.Node Logon screen display.
    a.Userid: lmsusd
    b.Password: lmspwd
    c.Node Name : SA400E00 (display)

    19.Click on OK to test the connection to AS/400.

    20.Click Close on CCA Screen.

    Some generated logging for your dianogsis as below:

    1) Tested with pctt.exe for TCP/IP with pct.ini file. Please refer to
    attached pctt.ini and generated logging file tcpip.txt for your
    reference. Below is the return code:

    | retcode = <10061> +----[ TCPIP.connect ]-----[ ERROR
    ]------------

    pctt.ini file
    --------------
    --------------------------------------------------------
    # PCT.INI
    # Protocol Communication Tester INI File
    # This file contains the Protocol Specific Configuration
    # Parameters & values to be used in conjunction with
    # the Protocol Communication Tester (PCTx).
    #
    # Defaults will be used if the parameter is not listed.
    #--------------------------------------------------------

    [TCPIP]
    ServerHostName = MYSEHNET.SA400E
    ServerHostAddress = MYSEHNET.SA400E
    ServerIPAddress = 172.16.2.251
    ServiceName = SA400E
    ServerPort = 446

    TCPIP.txt
    ----------
    Reading configuration parameters
    ==> pct.ini file was found... using file specified protocol values!
    Protocol Tester values...
    Client/Server : Client
    Connections : 1
    Buffer Size : 500
    Transaction Iterations : 1
    Trace : OFF
    Service : Send/Recv/Verify
    Keep Connections : NO
    Delayed Send (secs) : 0
    Local TCPIP specific values...
    Hostname : LMSDOM
    HostAddress : LMSDOM
    IPAddress : 172.16.2.31

    Server TCPIP specific Values...
    Server Hostname : MYSEHNET.SA400E
    Server HostAddress : 400088880002
    Server IPAddress : 172.16.2.250
    Service Name : SA400E
    Server Port : 446

    - Initializing the Protocol Date: 6-20-2003 Time: 14:
    9:49:28
    - Connecting to Remote System Date: 6-20-2003 Time: 14:
    9:49:28
    | retcode = < 0> ----[ TCPIP.socket ]-----[ SUCCESS
    ]------------
    | retcode = <10061> +----[ TCPIP.connect ]-----[ ERROR
    ]------------
    +===== ERROR ================================================== ========
    | retcode = <10061> -> Connection refused
    +================================================= =====================



    2) db2diag.log for datadase TCPIP error.

    DIA3202C The TCP/IP call "connect" returned an errno="10061".


    May I know what is the proper way to resolve all this problems? Is
    there any configuration that needs to be set in AS/400? All the
    necessary services both
    at the client and AS/400 has been started. What else could i look
    into?

    Thanks in advance.

    Please help

    Uthuras
    Uthuras Guest

  2. #2

    Default Re: DB2 Connect to AS/400 failed

    What have you done on the AS/400 side? There are "things" that must be done
    on the AS/400 in order to enable distribute db communications. See the
    "Connectivity Supplement" at
    [url]http://www-3.ibm.com/cgi-bin/db2www/data/db2/udb/winos2unix/support/v7pubs.d2w/en_main[/url]
    ..

    Larry Edelstein

    Uthuras wrote:
    > Greeting all,
    >
    > DB2 Ver 7.2
    >
    > I have installed with the IBM DB Connect on the local database OS/2 in
    > order to set the remote database access to AS/400. Currently, I got
    > the problem to logon to the prompt node logon screen for remote
    > database with return error code SQL30081N, SQLSTATE=08001, 10061.
    >
    > The basic info setting for the AS/400 database as follows
    >
    > 1.In CCA, Click on Add button will come out Add Database Wizard Screen
    > to configure a connection.
    >
    > 2.Source options as Use a profile, Search the network, or Manually
    > configure
    > a connection to a database. Choose the option Manually Configure a
    > connection
    > to a database. Click on Next.
    >
    > 3.Select a communication protocol. Click on TCP/IP.
    >
    > 4.Mark the database physically resides on a host or AS/400 system and
    > select
    > connect directly to the server. Click on Next.
    >
    > 5.In Specify TCP/IP communication parameters.
    > a.Host name: 172.16.2.250
    > b.Port number: 446 (default)
    >
    > 6.Click on Next.
    >
    > 7.In Specify the name of the database to which you want to connect.
    > a.Database name: SA400E
    > b.Database alias: SA400E
    > c.Comment: AS/400 Database
    >
    > 8.Click on Next.
    >
    > 9.In Register this database as an ODBC data source (if ODBC
    > installed).
    > a.Deselect this database for ODBC
    >
    > 10.Click on Next.
    >
    > 11.In (Optional) Specify the node options.
    > a.Select Configure node options (Optional)
    > b.System name : SA400E
    > c.Operating System : OS/400
    >
    > 12.Click on Next.
    >
    > 13.In (Optional) Specify the security options. (Choose SERVER) Click
    > on Next.
    >
    > 14.In (Optional) Configure Host or AS/400 option.
    >
    > 15.Click on Finish will close the wizard screen and come back to CCA
    > Screen.
    >
    > 16.On CCA Screen, click on Test will prompt out Connection to DB2
    > Database
    > Dialog.
    >
    > 17.Input the User ID (lmsusd) and Password (lmspwd). The USERID and
    > PASSWORD
    > are the remote userid and password. Click on OK.
    >
    > 18.Node Logon screen display.
    > a.Userid: lmsusd
    > b.Password: lmspwd
    > c.Node Name : SA400E00 (display)
    >
    > 19.Click on OK to test the connection to AS/400.
    >
    > 20.Click Close on CCA Screen.
    >
    > Some generated logging for your dianogsis as below:
    >
    > 1) Tested with pctt.exe for TCP/IP with pct.ini file. Please refer to
    > attached pctt.ini and generated logging file tcpip.txt for your
    > reference. Below is the return code:
    >
    > | retcode = <10061> +----[ TCPIP.connect ]-----[ ERROR
    > ]------------
    >
    > pctt.ini file
    > --------------
    > --------------------------------------------------------
    > # PCT.INI
    > # Protocol Communication Tester INI File
    > # This file contains the Protocol Specific Configuration
    > # Parameters & values to be used in conjunction with
    > # the Protocol Communication Tester (PCTx).
    > #
    > # Defaults will be used if the parameter is not listed.
    > #--------------------------------------------------------
    >
    > [TCPIP]
    > ServerHostName = MYSEHNET.SA400E
    > ServerHostAddress = MYSEHNET.SA400E
    > ServerIPAddress = 172.16.2.251
    > ServiceName = SA400E
    > ServerPort = 446
    >
    > TCPIP.txt
    > ----------
    > Reading configuration parameters
    > ==> pct.ini file was found... using file specified protocol values!
    > Protocol Tester values...
    > Client/Server : Client
    > Connections : 1
    > Buffer Size : 500
    > Transaction Iterations : 1
    > Trace : OFF
    > Service : Send/Recv/Verify
    > Keep Connections : NO
    > Delayed Send (secs) : 0
    > Local TCPIP specific values...
    > Hostname : LMSDOM
    > HostAddress : LMSDOM
    > IPAddress : 172.16.2.31
    >
    > Server TCPIP specific Values...
    > Server Hostname : MYSEHNET.SA400E
    > Server HostAddress : 400088880002
    > Server IPAddress : 172.16.2.250
    > Service Name : SA400E
    > Server Port : 446
    >
    > - Initializing the Protocol Date: 6-20-2003 Time: 14:
    > 9:49:28
    > - Connecting to Remote System Date: 6-20-2003 Time: 14:
    > 9:49:28
    > | retcode = < 0> ----[ TCPIP.socket ]-----[ SUCCESS
    > ]------------
    > | retcode = <10061> +----[ TCPIP.connect ]-----[ ERROR
    > ]------------
    > +===== ERROR ================================================== ========
    > | retcode = <10061> -> Connection refused
    > +================================================= =====================
    >
    > 2) db2diag.log for datadase TCPIP error.
    >
    > DIA3202C The TCP/IP call "connect" returned an errno="10061".
    >
    > May I know what is the proper way to resolve all this problems? Is
    > there any configuration that needs to be set in AS/400? All the
    > necessary services both
    > at the client and AS/400 has been started. What else could i look
    > into?
    >
    > Thanks in advance.
    >
    > Please help
    >
    > Uthuras
    Larry Guest

Similar Threads

  1. FMS 3 Connect.Failed (very strange!)
    By dEPUTsTERONE in forum Macromedia Flash Flashcom
    Replies: 0
    Last Post: February 24th, 02:54 PM
  2. NetConnection.Connect.Failed
    By cosmits in forum Macromedia Flash Flashcom
    Replies: 2
    Last Post: September 12th, 02:02 AM
  3. Trying to connect to FMS via rtmp:// failed
    By Speegs in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: February 9th, 01:53 PM
  4. Mechanize 500 connect failed
    By Paul Kraus in forum PERL Beginners
    Replies: 1
    Last Post: December 2nd, 04:20 PM
  5. Failed to connect over VPN from dynamic IP
    By Graham in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: July 11th, 09:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139