Professional Web Applications Themes

DBD::Informix Installation problems on Linux - Informix

Greetings, Perhaps this problem has been answered before, but my search of the web and newsgroups hasn't yielded any results. Apologies at the outset for not having able to find the answer on my own. I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped. In doing perl Makefile.PL my compilation bombs at this point: ############### .... lib/DBD/Informix/Defaults.pm written OK esqlvrsn.h written OK esqlinfo.h written OK Testing whether your Informix test environment will work... ESQLTEST Program Running: (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler ...

  1. #1

    Default DBD::Informix Installation problems on Linux


    Greetings,

    Perhaps this problem has been answered before, but my search of the web and newsgroups
    hasn't yielded any results. Apologies at the outset for not having able to find the
    answer on my own.

    I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used
    DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped.

    In doing perl Makefile.PL my compilation bombs at this point:

    ###############
    ....

    lib/DBD/Informix/Defaults.pm written OK
    esqlvrsn.h written OK
    esqlinfo.h written OK

    Testing whether your Informix test environment will work...
    ESQLTEST Program Running:
    (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler Exp $
    $INFORMIXDIR is set to '/usr/local/informix'.
    $INFORMIXSERVER is set to 'leeloo'.
    $DBI_DBNAME unset - defaulting to 'stores'.
    $DBD_INFORMIX_DATABASE unset - defaulting to 'stores'.
    $DBD_INFORMIX_DATABASE2 unset - defaulting to 'stores'.
    $DBD_INFORMIX_USERNAME is set to 'informix'.
    $DBD_INFORMIX_USERNAME2 is set to 'informix'.
    $DBD_INFORMIX_PASSWORD is set.
    $DBD_INFORMIX_PASSWORD2 is set.
    Testing connection to stores
    CONNECT TO 'stores' with user info
    SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.

    Testing concurrent connection to stores
    CONNECT TO 'stores' with user info
    SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.


    *** Your Informix environment is not usable
    *** You must fix it before building or testing DBD::Informix
    ....
    ###############

    Some details:
    OS - Redhat Linux 6.2, kernel-2.2.24-6.2.3
    Informix Online 5.10.UD1 installed and running
    INFORMIX-ESQL Version 9.16.UC1



    contents of /usr/local/informix/sqlhosts
    # demo_on onipcshm on_hostname on_servername
    # demo_se seipcpip se_hostname sqlexec
    leelooshm onipcshm leeloo dummy
    leeloosoc onsoctcp leeloo leeloo


    Some Environments Info:
    HOSTNAME=leeloo
    HOSTTYPE=i386
    INFORMIXDIR=/usr/local/informix
    INFORMIXSERVER=leeloo
    LD_LIBRARY_PATH=:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql
    OSTYPE=Linux
    PATH=/usr/local/informix/bin:/usr/sbin:/sbin:.:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/informix
    SHELL=/bin/bash
    SHLVL=1
    SQLEXEC=/usr/local/informix/lib/sqlturbo
    TERM=vt100

    DBD_INFORMIX_PASSWORD2, DBD_INFORMIX_PASSWORD omitted from the environments listing here but set.



    Any help or guidance would be appreciated.

    Max

    Professor Bruno Guest

  2. #2

    Default Re: DBD::Informix Installation problems on Linux

    Professor Bruno wrote:
    > Greetings,
    >
    > Perhaps this problem has been answered before, but my search of the web and newsgroups
    > hasn't yielded any results. Apologies at the outset for not having able to find the
    > answer on my own.
    >
    > I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used
    > DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped.
    >
    > In doing perl Makefile.PL my compilation bombs at this point:
    >
    > ###############
    > ...
    >
    > lib/DBD/Informix/Defaults.pm written OK
    > esqlvrsn.h written OK
    > esqlinfo.h written OK
    >
    > Testing whether your Informix test environment will work...
    > ESQLTEST Program Running:
    > (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler Exp $
    > $INFORMIXDIR is set to '/usr/local/informix'.
    > $INFORMIXSERVER is set to 'leeloo'.
    > $DBI_DBNAME unset - defaulting to 'stores'.
    > $DBD_INFORMIX_DATABASE unset - defaulting to 'stores'.
    > $DBD_INFORMIX_DATABASE2 unset - defaulting to 'stores'.
    > $DBD_INFORMIX_USERNAME is set to 'informix'.
    > $DBD_INFORMIX_USERNAME2 is set to 'informix'.
    > $DBD_INFORMIX_PASSWORD is set.
    > $DBD_INFORMIX_PASSWORD2 is set.
    > Testing connection to stores
    > CONNECT TO 'stores' with user info
    > SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    >
    > Testing concurrent connection to stores
    > CONNECT TO 'stores' with user info
    > SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    >
    >
    > *** Your Informix environment is not usable
    > *** You must fix it before building or testing DBD::Informix
    > ...
    > ###############
    >
    > Some details:
    > OS - Redhat Linux 6.2, kernel-2.2.24-6.2.3
    > Informix Online 5.10.UD1 installed and running
    > INFORMIX-ESQL Version 9.16.UC1
    >
    >
    >
    > contents of /usr/local/informix/sqlhosts
    > # demo_on onipcshm on_hostname on_servername
    > # demo_se seipcpip se_hostname sqlexec
    > leelooshm onipcshm leeloo dummy
    > leeloosoc onsoctcp leeloo leeloo
    >
    >
    > Some Environments Info:
    > HOSTNAME=leeloo
    > HOSTTYPE=i386
    > INFORMIXDIR=/usr/local/informix
    > INFORMIXSERVER=leeloo
    > LD_LIBRARY_PATH=:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql
    > OSTYPE=Linux
    > PATH=/usr/local/informix/bin:/usr/sbin:/sbin:.:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/informix
    > SHELL=/bin/bash
    > SHLVL=1
    > SQLEXEC=/usr/local/informix/lib/sqlturbo
    > TERM=vt100
    >
    > DBD_INFORMIX_PASSWORD2, DBD_INFORMIX_PASSWORD omitted from the environments listing here but set.
    >
    >
    >
    > Any help or guidance would be appreciated.
    >
    > Max
    >
    I've never used DBD but:

    The sqlhosts file must be located in $INFORMIXDIR/etc/sqlhosts or
    pointed to a location by $INFORMIXSQLHOSTS

    You apparently don't have the $INFORMIXSQLHOSTS environment set and have
    the file directly in $INFORMIXDIR instead of $INFORMIXDIR/etc


    Regards

    Fernando Nunes Guest

  3. #3

    Default Re: DBD::Informix Installation problems on Linux

    Fernando Nunes <spamdomus.online.pt> wrote:
    : Professor Bruno wrote:
    :> Greetings,
    :>
    :> Perhaps this problem has been answered before, but my search of the web and newsgroups
    :> hasn't yielded any results. Apologies at the outset for not having able to find the
    :> answer on my own.
    :>
    :> I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used
    :> DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped.
    :>
    :> In doing perl Makefile.PL my compilation bombs at this point:
    :>
    :> ###############
    :> ...
    :>
    :> lib/DBD/Informix/Defaults.pm written OK
    :> esqlvrsn.h written OK
    :> esqlinfo.h written OK
    :>
    :> Testing whether your Informix test environment will work...
    :> ESQLTEST Program Running:
    :> (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler Exp $
    :> $INFORMIXDIR is set to '/usr/local/informix'.
    :> $INFORMIXSERVER is set to 'leeloo'.
    :> $DBI_DBNAME unset - defaulting to 'stores'.
    :> $DBD_INFORMIX_DATABASE unset - defaulting to 'stores'.
    :> $DBD_INFORMIX_DATABASE2 unset - defaulting to 'stores'.
    :> $DBD_INFORMIX_USERNAME is set to 'informix'.
    :> $DBD_INFORMIX_USERNAME2 is set to 'informix'.
    :> $DBD_INFORMIX_PASSWORD is set.
    :> $DBD_INFORMIX_PASSWORD2 is set.
    :> Testing connection to stores
    :> CONNECT TO 'stores' with user info
    :> SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    :>
    :> Testing concurrent connection to stores
    :> CONNECT TO 'stores' with user info
    :> SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    :>
    :>
    :> *** Your Informix environment is not usable
    :> *** You must fix it before building or testing DBD::Informix
    :> ...
    :> ###############
    :>
    :> Some details:
    :> OS - Redhat Linux 6.2, kernel-2.2.24-6.2.3
    :> Informix Online 5.10.UD1 installed and running
    :> INFORMIX-ESQL Version 9.16.UC1
    :>
    :>
    :>
    :> contents of /usr/local/informix/sqlhosts
    :> # demo_on onipcshm on_hostname on_servername
    :> # demo_se seipcpip se_hostname sqlexec
    :> leelooshm onipcshm leeloo dummy
    :> leeloosoc onsoctcp leeloo leeloo
    :>
    :>
    :> Some Environments Info:
    :> HOSTNAME=leeloo
    :> HOSTTYPE=i386
    :> INFORMIXDIR=/usr/local/informix
    :> INFORMIXSERVER=leeloo
    :> LD_LIBRARY_PATH=:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql
    :> OSTYPE=Linux
    :> PATH=/usr/local/informix/bin:/usr/sbin:/sbin:.:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/informix
    :> SHELL=/bin/bash
    :> SHLVL=1
    :> SQLEXEC=/usr/local/informix/lib/sqlturbo
    :> TERM=vt100
    :>
    :> DBD_INFORMIX_PASSWORD2, DBD_INFORMIX_PASSWORD omitted from the environments listing here but set.
    :>
    :>
    :>
    :> Any help or guidance would be appreciated.
    :>
    :> Max
    :>

    : I've never used DBD but:

    : The sqlhosts file must be located in $INFORMIXDIR/etc/sqlhosts or
    : pointed to a location by $INFORMIXSQLHOSTS

    Ooops, typo on my part. sqlhosts is located in /usr/local/informix/etc

    : You apparently don't have the $INFORMIXSQLHOSTS environment set and have
    : the file directly in $INFORMIXDIR instead of $INFORMIXDIR/etc

    I set $INFORMIXSQLHOSTS but the installation still bombs in the same place.

    Further, I've tried installing both DBD-Informix-2003.04 and DBD-Informix-1.04.PC1
    and both bomb in the same place on running perl Makefile.PL

    I have upgraded to DBI-1.37, btw.

    Thanks for your advice; would appreciate any further guidance to get through this.


    : Regards


    Max Pyziur
    Professor Bruno Guest

  4. #4

    Default Re: DBD::Informix Installation problems on Linux


    Pulling my own chain ...
    Professor Bruno <pyzpanix.com> wrote:
    : Fernando Nunes <spamdomus.online.pt> wrote:
    : : Professor Bruno wrote:
    : :> Greetings,
    : :>
    : :> Perhaps this problem has been answered before, but my search of the web and newsgroups
    : :> hasn't yielded any results. Apologies at the outset for not having able to find the
    : :> answer on my own.
    : :>
    : :> I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used
    : :> DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped.
    : :>
    : :> In doing perl Makefile.PL my compilation bombs at this point:
    : :>
    : :> ###############
    : :> ...
    : :>
    : :> lib/DBD/Informix/Defaults.pm written OK
    : :> esqlvrsn.h written OK
    : :> esqlinfo.h written OK
    : :>
    : :> Testing whether your Informix test environment will work...
    : :> ESQLTEST Program Running:
    : :> (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler Exp $
    : :> $INFORMIXDIR is set to '/usr/local/informix'.
    : :> $INFORMIXSERVER is set to 'leeloo'.
    : :> $DBI_DBNAME unset - defaulting to 'stores'.
    : :> $DBD_INFORMIX_DATABASE unset - defaulting to 'stores'.
    : :> $DBD_INFORMIX_DATABASE2 unset - defaulting to 'stores'.
    : :> $DBD_INFORMIX_USERNAME is set to 'informix'.
    : :> $DBD_INFORMIX_USERNAME2 is set to 'informix'.
    : :> $DBD_INFORMIX_PASSWORD is set.
    : :> $DBD_INFORMIX_PASSWORD2 is set.
    : :> Testing connection to stores
    : :> CONNECT TO 'stores' with user info
    : :> SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    : :>
    : :> Testing concurrent connection to stores
    : :> CONNECT TO 'stores' with user info
    : :> SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    : :>
    : :>
    : :> *** Your Informix environment is not usable
    : :> *** You must fix it before building or testing DBD::Informix
    : :> ...
    : :> ###############
    : :>
    : :> Some details:
    : :> OS - Redhat Linux 6.2, kernel-2.2.24-6.2.3
    : :> Informix Online 5.10.UD1 installed and running
    : :> INFORMIX-ESQL Version 9.16.UC1
    : :>
    : :>
    : :>
    : :> contents of /usr/local/informix/sqlhosts
    : :> # demo_on onipcshm on_hostname on_servername
    : :> # demo_se seipcpip se_hostname sqlexec
    : :> leelooshm onipcshm leeloo dummy
    : :> leeloosoc onsoctcp leeloo leeloo
    : :>
    : :>
    : :> Some Environments Info:
    : :> HOSTNAME=leeloo
    : :> HOSTTYPE=i386
    : :> INFORMIXDIR=/usr/local/informix
    : :> INFORMIXSERVER=leeloo
    : :> LD_LIBRARY_PATH=:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql
    : :> OSTYPE=Linux
    : :> PATH=/usr/local/informix/bin:/usr/sbin:/sbin:.:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/informix
    : :> SHELL=/bin/bash
    : :> SHLVL=1
    : :> SQLEXEC=/usr/local/informix/lib/sqlturbo
    : :> TERM=vt100
    : :>
    : :> DBD_INFORMIX_PASSWORD2, DBD_INFORMIX_PASSWORD omitted from the environments listing here but set.
    : :>
    : :>
    : :>
    : :> Any help or guidance would be appreciated.
    : :>
    : :> Max
    : :>

    : : I've never used DBD but:

    : : The sqlhosts file must be located in $INFORMIXDIR/etc/sqlhosts or
    : : pointed to a location by $INFORMIXSQLHOSTS

    : Ooops, typo on my part. sqlhosts is located in /usr/local/informix/etc

    : : You apparently don't have the $INFORMIXSQLHOSTS environment set and have
    : : the file directly in $INFORMIXDIR instead of $INFORMIXDIR/etc

    : I set $INFORMIXSQLHOSTS but the installation still bombs in the same place.

    : Further, I've tried installing both DBD-Informix-2003.04 and DBD-Informix-1.04.PC1
    : and both bomb in the same place on running perl Makefile.PL

    : I have upgraded to DBI-1.37, btw.

    : Thanks for your advice; would appreciate any further guidance to get through this.



    As a self-followup, my expeience with Informix installations on Linux has been
    periodic. I have installed the following Informix pieces on my RH 6.2 box.
    ONLINE 5.10.UD1
    INFORMIX-SQL Version 7.20.UD1
    INFORMIX-ESQL Version 9.51.UC1
    INFORMIX-4GL Version 7.20.UD1

    I've started and run ONLINE along with it's companion piece dbaccess. As yet, I
    haven't tested ESQL or 4GL.

    I've tried running Informix-SQL, but it fails.

    Interestingly, I receive the same errors using Informix-SQL and trying to
    run perl Makefile.PL.

    Trying different scenarios, when $INFORMIXSERVER is set to 'leeloo' (per
    the above mentioned sqlhosts file) I get the following error:
    SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.

    When setting $INFORMIXSERVER to leeloosoc, adding the line 1536/tcp to /etc/services,
    and turning ipchains off (the box connects to the Internet and has an ipchain firewall)
    I get:
    SQL: -908: Attempt to connect to database server (leeloosoc) failed.
    ISAM: 107: ISAM error: record is locked.

    When setting $INFORMIXSERVER to leelooshm with ipchains on (I'm not making a tcp/ip connection
    here) I get:
    Testing connection to stores
    CONNECT TO 'stores' with user info
    SQL: -25588: The appl process cannot connect to the database server leelooshm.
    ISAM: 2: No such file or directory


    If anyone can shed any light on this ...

    Much thanks.


    : : Regards


    : Max Pyziur
    [recycle]
    Professor Bruno Guest

  5. #5

    Default Re: DBD::Informix Installation problems on Linux



    Wow.... ;)

    Let's look at your setup carefully:

    SQLHOSTS:

    # demo_on onipcshm on_hostname on_servername
    # demo_se seipcpip se_hostname sqlexec
    leelooshm onipcshm leeloo dummy
    leeloosoc onsoctcp leeloo leeloo

    the columns are as follow:

    1st - INFORMIXSERVER name
    2nd - Protocolo (usually onsoctcp or onipcshm
    3rd - hostname (be sure your environment can ping it)
    4th - service name ou port (if name must be specified in /etc/services)

    So, if you have "leelosoc" on the 1st column you muste use it and not leeloo.
    The other errors (no such file...) can be due to bad onconfig (tbconfig if online 5).

    Take a good look at "SERVERNAME" and "DBSERVERALIAS". You must configure a name for each "name" you want it to answer.
    So, if you want SOC and SHM you must user both entries. For instance, SERVERNAME=leeloosoc and DBSERVERALIAS=leelooshm

    Regards.

    Fernando Nunes Guest

  6. #6

    Default Re: DBD::Informix Installation problems on Linux

    Your INFORMIXSERVER is set the host name and not leelooshm/soc

    Professor Bruno wrote:
    >
    > Greetings,
    >
    > Perhaps this problem has been answered before, but my search of the web and newsgroups
    > hasn't yielded any results. Apologies at the outset for not having able to find the
    > answer on my own.
    >
    > I'm trying to compile DBI:DBD for Informix. I've successfully compiled, installed, and used
    > DBI:DBD for MySQL and PostgreSQL. This one, though has got me a bit stumped.
    >
    > In doing perl Makefile.PL my compilation bombs at this point:
    >
    > ###############
    > ...
    >
    > lib/DBD/Informix/Defaults.pm written OK
    > esqlvrsn.h written OK
    > esqlinfo.h written OK
    >
    > Testing whether your Informix test environment will work...
    > ESQLTEST Program Running:
    > (#)$Id: esqltest.ec,v 100.3 2002/02/08 22:49:23 jleffler Exp $
    > $INFORMIXDIR is set to '/usr/local/informix'.
    > $INFORMIXSERVER is set to 'leeloo'.
    > $DBI_DBNAME unset - defaulting to 'stores'.
    > $DBD_INFORMIX_DATABASE unset - defaulting to 'stores'.
    > $DBD_INFORMIX_DATABASE2 unset - defaulting to 'stores'.
    > $DBD_INFORMIX_USERNAME is set to 'informix'.
    > $DBD_INFORMIX_USERNAME2 is set to 'informix'.
    > $DBD_INFORMIX_PASSWORD is set.
    > $DBD_INFORMIX_PASSWORD2 is set.
    > Testing connection to stores
    > CONNECT TO 'stores' with user info
    > SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    >
    > Testing concurrent connection to stores
    > CONNECT TO 'stores' with user info
    > SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    >
    > *** Your Informix environment is not usable
    > *** You must fix it before building or testing DBD::Informix
    > ...
    > ###############
    >
    > Some details:
    > OS - Redhat Linux 6.2, kernel-2.2.24-6.2.3
    > Informix Online 5.10.UD1 installed and running
    > INFORMIX-ESQL Version 9.16.UC1
    >
    > contents of /usr/local/informix/sqlhosts
    > # demo_on onipcshm on_hostname on_servername
    > # demo_se seipcpip se_hostname sqlexec
    > leelooshm onipcshm leeloo dummy
    > leeloosoc onsoctcp leeloo leeloo
    >
    > Some Environments Info:
    > HOSTNAME=leeloo
    > HOSTTYPE=i386
    > INFORMIXDIR=/usr/local/informix
    > INFORMIXSERVER=leeloo
    > LD_LIBRARY_PATH=:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql:/usr/local/informix/lib:/usr/local/informix/lib/esql
    > OSTYPE=Linux
    > PATH=/usr/local/informix/bin:/usr/sbin:/sbin:.:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/informix
    > SHELL=/bin/bash
    > SHLVL=1
    > SQLEXEC=/usr/local/informix/lib/sqlturbo
    > TERM=vt100
    >
    > DBD_INFORMIX_PASSWORD2, DBD_INFORMIX_PASSWORD omitted from the environments listing here but set.
    >
    > Any help or guidance would be appreciated.
    >
    > Max
    --
    Paul Watson #
    Oninit Ltd # Growing old is mandatory
    Tel: +44 1436 672201 # Growing up is optional
    Fax: +44 1436 678693 #
    Mob: +44 7818 003457 #
    [url]www.oninit.com[/url] #
    Paul Watson Guest

  7. #7

    Default Re: DBD::Informix Installation problems on Linux

    Professor Bruno wrote:
    [...snip...]
    > : Further, I've tried installing both DBD-Informix-2003.04 and DBD-Informix-1.04.PC1
    > : and both bomb in the same place on running perl Makefile.PL
    > : I have upgraded to DBI-1.37, btw.
    >
    > As a self-followup, my expeience with Informix installations on Linux has been
    > periodic. I have installed the following Informix pieces on my RH 6.2 box.
    > ONLINE 5.10.UD1
    > INFORMIX-SQL Version 7.20.UD1
    > INFORMIX-ESQL Version 9.51.UC1
    > INFORMIX-4GL Version 7.20.UD1
    >
    > I've started and run ONLINE along with it's companion piece dbaccess. As yet, I
    > haven't tested ESQL or 4GL.
    >
    > I've tried running Informix-SQL, but it fails.
    >
    > Interestingly, I receive the same errors using Informix-SQL and trying to
    > run perl Makefile.PL.
    >
    > Trying different scenarios, when $INFORMIXSERVER is set to 'leeloo' (per
    > the above mentioned sqlhosts file) I get the following error:
    > SQL: -25596: The INFORMIXSERVER value is not listed in the sqlhosts file or the Registry.
    >
    > When setting $INFORMIXSERVER to leeloosoc, adding the line 1536/tcp to /etc/services,
    > and turning ipchains off (the box connects to the Internet and has an ipchain firewall)
    > I get:
    > SQL: -908: Attempt to connect to database server (leeloosoc) failed.
    > ISAM: 107: ISAM error: record is locked.
    >
    > When setting $INFORMIXSERVER to leelooshm with ipchains on (I'm not making a tcp/ip connection
    > here) I get:
    > Testing connection to stores
    > CONNECT TO 'stores' with user info
    > SQL: -25588: The appl process cannot connect to the database server leelooshm.
    > ISAM: 2: No such file or directory
    >
    >
    > If anyone can shed any light on this ...

    You've gotten one of the key pieces of information from other people -
    you must set $INFORMIXSERVER to one of the entries in your sqlhosts
    files (based on the first column).

    What I've not yet seen is any discussion of the fact that you're using
    OnLine 5.10 (on Linux - that means it must be a SCO port running in a
    compatibility box, I think; did you consider OnLine 5.20 instead?),
    and therefore you need to have I-Star (or, possibly, I-Net) running -
    you need $INFORMIXDIR/lib/sqlexecd up and running and listening for
    the network connections, and hence $INFORMIXSERVER needs to be set to
    leelootcp and not leelooshm. You can check whether the system header
    /usr/include/sys/errno.h defines an error 107 -- that may be more
    relevant than the assumed ISAM error code.

    However, until programs such as ISQL and I4GL can connect to the
    database server, there is little point in attempting to build
    DBD::Informix. You must be able to connect smoothly to your database
    to be able to build DBD::Informix.

    Incidentally, if you were using OnLine 5.20 and the latest CSDK 2.81
    (ESQL/C 9.53), then you would be able to configure an olipcpip
    connection direct to the server without having to run I-Star (and you
    would get the I-Star software as part of the base package, rather than
    as a separately purchasable item).


    --
    Jonathan Leffler #include <disclaimer.h>
    Email: [email]jlefflerearthlink.net[/email], [email]jlefflerus.ibm.com[/email]
    Guardian of DBD::Informix v2003.04 -- [url]http://dbi.perl.org/[/url]

    Jonathan Leffler Guest

Similar Threads

  1. Installation problems on Linux.. RH9
    By JVCJVC in forum Macromedia Flash Flashcom
    Replies: 6
    Last Post: April 6th, 08:25 AM
  2. Informix SE installation problem / Please help
    By Adrian Talmatski in forum Informix
    Replies: 1
    Last Post: October 20th, 05:35 PM
  3. [SPAM] Informix for linux
    By Webmaster IIUG - Stuart Litel in forum Informix
    Replies: 0
    Last Post: September 22nd, 02:36 PM
  4. Informix/Linux Redhat AS 2.1
    By schirap in forum Informix
    Replies: 0
    Last Post: August 6th, 10:07 AM
  5. informix 4gl linux
    By BG in forum Informix
    Replies: 0
    Last Post: July 1st, 12:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139