Professional Web Applications Themes

Debian lilo won't boot Redhat - Debian

On Thu, 2003-06-26 at 20:57, Ross Boylan wrote: > I got a system with Red Hat 9 preinstalled, booting with lilo. After > making some space, I installed Debian (testing) on it. I thought it > would be good to preserve the ability to boot into RH, so I mounted its > partitions under /red in linux this is the wrong thing to do, don't mount the redhat partition there, just use root=/dev/hdXX for redhat, where hdXX is the red hat root partition, you want redhat to use that partition as / not as /red > , and modified its ...

  1. #1

    Default Re: Debian lilo won't boot Redhat

    On Thu, 2003-06-26 at 20:57, Ross Boylan wrote:
    > I got a system with Red Hat 9 preinstalled, booting with lilo. After
    > making some space, I installed Debian (testing) on it. I thought it
    > would be good to preserve the ability to boot into RH, so I mounted its
    > partitions under /red in linux
    this is the wrong thing to do, don't mount the redhat partition there,
    just use root=/dev/hdXX for redhat, where hdXX is the red hat root
    partition,
    you want redhat to use that partition as / not as /red
    > , and modified its lilo.conf to use these
    > new paths. (That is, I created /etc/lilo.conf under Debian based on the
    > lilo conf from RH).
    >
    > Surprisingly, I find I'm unable to start RH doing this. I get
    > Kernel panic: No init found. Try passing init= option to the kernel
    > (it is already getting that option).
    > On the other hand, if I chroot to /red and run lilo -b /dev/fd0, I get
    > something I can boot off.
    that's right because the systen expects everything to be under / and not
    under /red

    Bijan



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Bijan Soleymani Guest

  2. #2

    Default Re: Debian lilo won't boot Redhat

    On Friday 27 June 2003 03:57, Ross Boylan wrote:
    > I got a system with Red Hat 9 preinstalled, booting with lilo. After
    > making some space, I installed Debian (testing) on it. I thought it
    > would be good to preserve the ability to boot into RH, so I mounted
    > its partitions under /red in linux, and modified its lilo.conf to use
    > these new paths. (That is, I created /etc/lilo.conf under Debian
    > based on the lilo conf from RH).
    >
    > Surprisingly, I find I'm unable to start RH doing this. I get
    > Kernel panic: No init found. Try passing init= option to the kernel
    > (it is already getting that option).
    I have the same problem with booting Mandrake 9.1 using Debian Lilo. I
    can boot other distros OK (like slack) but I get the same kernel panic
    message when booting mandrake 9.1

    I don't have RedHat, so I can't verify that, but it seems we have the
    same problem.

    Any suggestions anyone?

    I can post my lilo.conf and fstab if you want

    Cheers

    --
    /* "It only takes 20 years for a liberal to become a
    conservative without changing a single idea."
    --Robert Anton Wilson*/
    Aryan Ameri


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Aryan Ameri Guest

  3. #3

    Default Re: Debian lilo won't boot Redhat

    On Fri, 2003-06-27 at 12:51, Ross Boylan wrote:
    > To clarify: I mounted the red hat partitions under /red when running
    > Debian. My understanding is the lilo's map, and so it's boot process,
    > use absolute disk locations and so shouldn't care how I get to the
    > files. The lilo.conf under Debian refers to them like /red/boot/...
    oh ok, sorry about that.
    > RedHat's fstab does refer to the partitions as /dev/sdaXX, and does
    > not use the /red root.
    >
    > So I don't think the use of /red is the source of the problem. Of
    > course, at this point, everything is suspect. I have triple-checked
    > that I'm actually referring to the right partitions under Debian.
    Could you post the lilo.conf file. It could help out in figuring what is
    wrong.

    P.S. I usually copy all the different kernels onto the same partition
    (seperate /boot, or / of one system in particular) and boot off of that
    and then use root=partition to decide which system to use.

    Bijan



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Bijan Soleymani Guest

  4. #4

    Default Re: Debian lilo won't boot Redhat

    On Fri, 2003-06-27 at 13:39, Bijan Soleymani wrote:
    > On Fri, 2003-06-27 at 12:51, Ross Boylan wrote:
    > > To clarify: I mounted the red hat partitions under /red when running
    > > Debian. My understanding is the lilo's map, and so it's boot process,
    > > use absolute disk locations and so shouldn't care how I get to the
    > > files. The lilo.conf under Debian refers to them like /red/boot/...
    > oh ok, sorry about that.
    >
    > > RedHat's fstab does refer to the partitions as /dev/sdaXX, and does
    > > not use the /red root.
    > >
    > > So I don't think the use of /red is the source of the problem. Of
    > > course, at this point, everything is suspect. I have triple-checked
    > > that I'm actually referring to the right partitions under Debian.
    >
    > Could you post the lilo.conf file. It could help out in figuring what is
    > wrong.
    >
    > P.S. I usually copy all the different kernels onto the same partition
    > (seperate /boot, or / of one system in particular) and boot off of that
    > and then use root=partition to decide which system to use.
    >
    > Bijan
    The kernels are all in one partition. It's /boot under RH, /red/boot under
    Debian. For debian, /boot is a symlink to /red/boot/debian, so all my debian
    stuff is in a subdir. Rather complicated, I know.

    The system with the relevant lilo.conf isn't speaking to the world yet, but I
    think I can mail the file out under a separate cover. It should appear on the
    list shortly after this message.



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Ross Boylan Guest

  5. #5

    Default Debian lilo won't boot Redhat

    Here's the lilo.conf for debian that doesn't work for the RH sections.
    I've deleted 2 additional stanzas that are variations on the ones you see below:

    prompt
    timeout=50
    #compact
    default=debian
    boot=/dev/sda
    lba32
    install=/boot/boot-menu.b
    map=/boot/map
    vga=0xa

    image=/vmlinuz
    label=debian
    initrd=/initrd.img
    root=/dev/sda7

    # modified slightly from redhat
    #install=/boot/boot.b
    #message=/boot/message
    #linear

    image=/red/boot/vmlinuz-2.4.20-18.9smp
    label=linux
    initrd=/red/boot/initrd-2.4.20-18.9smp.img
    read-only
    append="hdb=ide-scsi root=LABEL=/"
    root=/dev/sda2


    In contrast, here's RH's original lilo.conf, again deleting a nearly
    identical second entry. This works if I chroot /red /bin/bash and do
    lilo:

    prompt
    timeout=50
    default=linux
    boot=/dev/sda
    map=/boot/map
    install=/boot/boot.b
    message=/boot/message
    linear

    image=/boot/vmlinuz-2.4.20-18.9smp
    label=linux
    initrd=/boot/initrd-2.4.20-18.9smp.img
    read-only
    append="hdb=ide-scsi root=LABEL=/"


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Ross Boylan Guest

  6. #6

    Default Re: Debian lilo won't boot Redhat

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    On Fri, Jun 27, 2003 at 02:51:54PM -0700, Ross Boylan wrote:
    > image=/red/boot/vmlinuz-2.4.20-18.9smp
    > label=linux
    > initrd=/red/boot/initrd-2.4.20-18.9smp.img
    > read-only
    > append="hdb=ide-scsi root=LABEL=/"
    > root=/dev/sda2
    Add a boot= line under the root= line? I think that should fix it,
    let us know if it works.

    - --
    .''`. Baloo Ursidae <balooursine.ca>
    : :' : proud Debian admin and user
    `. `'`
    `- Debian - when you have better things to do than fix a system
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQE+/rHRJ5vLSqVpK2kRAn5AAKDW8zxi0QSeq9VPndfN5cLG/AqcQQCfZsVa
    m+d5u1rJ0vzDBym2d6YzX+4=
    =pDSp
    -----END PGP SIGNATURE-----


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Paul Johnson Guest

  7. #7

    Default Re: Debian lilo won't boot Redhat

    On 26 Jun 2003 17:57:34 -0700
    Ross Boylan <rossbiostat.ucsf.edu> wrote:
    > I got a system with Red Hat 9 preinstalled, booting with lilo. After
    > making some space, I installed Debian (testing) on it. I thought it
    > would be good to preserve the ability to boot into RH, so I mounted its
    > partitions under /red in linux, and modified its lilo.conf to use these
    > new paths. (That is, I created /etc/lilo.conf under Debian based on the
    > lilo conf from RH).
    lilo finds files based on physical location on the hard drive; it doesn't
    understand file systems.

    I'm assuming you have RH and Debian on different partitions on your hard
    drive, say /dev/hda1 for RH and /dev/hda3 for Debian (even if your partition
    numbers aren't exactly like that).

    To be able to boot either system you need to decide which system you will
    use to configure the boot loader. Let's say you choose Debian.

    Boot Debian. Mount the partition containing RH's kernel, for example /red.

    Edit /etc/lilo.conf. Make a stanza to boot RH, and for the kernel's
    location, specify /red/path/to/RH/kernel.

    Run /sbin/lilo.

    You should then be able to choose either the Debian or RH system at the lilo
    boot prompt.

    There is no need to mount any part of the RH system to your Debian
    filesystem until you want to re-configure lilo.

    You can get rid of this problem by using grub. Grub understands file
    systems, and its configuration is a simple text file.

    [url]http://www.linuxjournal.com/article.php?sid=4622[/url]

    Kevin


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Kevin McKinley Guest

  8. #8

    Default Re: Debian lilo won't boot Redhat

    On Fri, 27 Jun 2003 14:51:54 -0700
    Ross Boylan <rossbiostat.ucsf.edu> wrote:
    > image=/red/boot/vmlinuz-2.4.20-18.9smp
    > label=linux
    > initrd=/red/boot/initrd-2.4.20-18.9smp.img
    > read-only
    > append="hdb=ide-scsi root=LABEL=/"
    > root=/dev/sda2
    What's "root=LABEL=/"?

    I'd get rid of that and use just 'append="hdb=ide-scsi"'.

    Kevin


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Kevin McKinley Guest

  9. #9

    Default Re: Debian lilo won't boot Redhat

    Aryan Ameri wrote:
    > I don't have RedHat, so I can't verify that, but it seems we have the
    > same problem.
    >
    > Any suggestions anyone?
    It sounds like these distributions are using an initrd, and your lilo
    setup is not passing the necessary parameters to the kernel to get it
    mounted, maybe?

    --
    see shy jo

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQE/AE7P3xwsXJZQhyMRAjgUAJ97/g1LU1SopXEi4i5dxpOvWL125gCgkgMs
    z0IRO5fW8MMRYIT5e5l90Qg=
    =iY+u
    -----END PGP SIGNATURE-----

    Joey Hess Guest

  10. #10

    Default Re: Debian lilo won't boot Redhat

    * Ross Boylan (rossbiostat.ucsf.edu) [030629 00:24]:
    > Here's the lilo.conf for debian that doesn't work for the RH sections.
    How does it not work? Does lilo not run (i.e. refuses to install in
    /dev/sda)? Do you get a LILO prompt? Does the kernel begin to load and
    but fail to load the initrd?

    good times,
    Vineet
    --
    [url]http://www.doorstop.net/[/url]
    --
    [url]http://www.eff.org/[/url] Defeinding freedom in the digital world

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.0.6 (GNU/Linux)
    Comment: For info see [url]http://www.gnupg.org[/url]

    iD8DBQE/Ax707z3S33fUb9ERAkMpAKDKGarRy3rjO/pkOB7uwcAfkwtBowCgt3L8
    Stut9l45lL+yx2MTHUzf5o4=
    =wlrq
    -----END PGP SIGNATURE-----

    Vineet Kumar Guest

Similar Threads

  1. Floppy boot option in Lilo
    By Darsin in forum Linux Setup, Configuration & Administration
    Replies: 8
    Last Post: August 9th, 07:05 AM
  2. boot problem after Mandrake upgrade and cannot make LILO work
    By Giovanni in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: August 9th, 02:02 AM
  3. Change *first* bootloader from Lilo to Winxp with boot.ini
    By silly in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: July 3rd, 03:49 AM
  4. dual boot problems: LILO stops at LI
    By Douglas Mayne in forum Linux Setup, Configuration & Administration
    Replies: 11
    Last Post: July 2nd, 09:23 AM
  5. Using Lilo to boot more than one Linux distro.
    By Jon Haugsand in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: June 30th, 12:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139