Professional Web Applications Themes

debian user needs helps! - Linux Setup, Configuration & Administration

how can i disable "sl0"? and what is that for? thanks:) debian:/etc# ifconfig eth0 Link encap:Ethernet HWaddr 00:C0:4F:C0:FA:21 inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1263 errors:0 dropped:0 overruns:0 frame:0 TX packets:1124 errors:0 dropped:0 overruns:0 carrier:62 collisions:0 txqueuelen:100 RX bytes:124138 (121.2 KiB) TX bytes:127088 (124.1 KiB) Interrupt:11 Base address:0xdc00 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:3924 Metric:1 RX packets:644 errors:0 dropped:0 overruns:0 frame:0 TX packets:644 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:42361 (41.3 KiB) TX bytes:42361 (41.3 KiB) sl0 Link encap:Serial Line IP inet addr:192.168.0.100 P-t-P:192.168.0.100 Mask:255.255.255.255 UP POINTOPOINT RUNNING NOARP ...

  1. #1

    Default debian user needs helps!

    how can i disable "sl0"? and what is that for? thanks:)

    debian:/etc# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:C0:4F:C0:FA:21
    inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1263 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1124 errors:0 dropped:0 overruns:0 carrier:62
    collisions:0 txqueuelen:100
    RX bytes:124138 (121.2 KiB) TX bytes:127088 (124.1 KiB)
    Interrupt:11 Base address:0xdc00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:3924 Metric:1
    RX packets:644 errors:0 dropped:0 overruns:0 frame:0
    TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:42361 (41.3 KiB) TX bytes:42361 (41.3 KiB)

    sl0 Link encap:Serial Line IP
    inet addr:192.168.0.100 P-t-P:192.168.0.100
    Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:10
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    debian:/etc#

    pc_newbie Guest

  2. #2

    Default disable sl0 device (was Re: debian user needs helps!)

    Please mend you subject line.

    pc_newbie <aycomputermail.net> wrote:
    > how can i disable "sl0"? and what is that for? thanks:)
    man ifconfig. ifconfig sl0 down. rmmod slip, or whatever.

    It's a serial line protocol carrying a tcp link. SLIP. Usually
    deprecated in favour of PPP. I believe slip can run over tcp
    and things like telnet connections too, but I may be wrong.

    > sl0 Link encap:Serial Line IP
    > inet addr:192.168.0.100 P-t-P:192.168.0.100 Mask:255.255.255.255
    > UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:10
    > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Peter
    Peter T. Breuer Guest

  3. #3

    Default Re: disable sl0 device (was Re: debian user needs helps!)

    Peter T. Breuer wrote:
    > Please mend you subject line.
    >
    > pc_newbie <aycomputermail.net> wrote:
    >
    >>how can i disable "sl0"? and what is that for? thanks:)
    >
    >
    > man ifconfig. ifconfig sl0 down. rmmod slip, or whatever.
    >
    > It's a serial line protocol carrying a tcp link. SLIP. Usually
    > deprecated in favour of PPP. I believe slip can run over tcp
    > and things like telnet connections too, but I may be wrong.
    >
    >
    >
    >>sl0 Link encap:Serial Line IP
    >> inet addr:192.168.0.100 P-t-P:192.168.0.100 Mask:255.255.255.255
    >> UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    >> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    >> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    >> collisions:0 txqueuelen:10
    >> RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    >
    >
    > Peter
    THanks a lot, can i disable it at boot time, so that i don't need to
    shut it down everytime i reboot my machine?

    pc_newbie Guest

  4. #4

    Default Re: disable sl0 device (was Re: debian user needs helps!)

    pc_newbie <aycomputermail.net> wrote:
    > Peter T. Breuer wrote:
    > >>how can i disable "sl0"? and what is that for? thanks:)
    > > man ifconfig. ifconfig sl0 down. rmmod slip, or whatever.
    > >
    > >>sl0 Link encap:Serial Line IP
    > >> inet addr:192.168.0.100 P-t-P:192.168.0.100 Mask:255.255.255.255
    > >> UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    > >> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    > >> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    > >> collisions:0 txqueuelen:10
    > >> RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    > >
    > THanks a lot, can i disable it at boot time, so that i don't need to
    Just stop starting it! That's a silly question - why are you loading the
    module and configuring the interface? You must have configured it as
    your network device. Remove from your interfaces defn.
    > shut it down everytime i reboot my machine?
    Not starting it would seem to be simpler than stopping it!

    Peter
    Peter T. Breuer Guest

  5. #5

    Default Re: debian user needs helps!

    Take a look at "/etc/network/interfaces". You probably specified the
    SLIP interface during the installation. You can remove or comment out
    the SLIP section.

    pc_newbie (aycomputermail.net) wrote:
    : how can i disable "sl0"? and what is that for? thanks:)

    : debian:/etc# ifconfig
    : eth0 Link encap:Ethernet HWaddr 00:C0:4F:C0:FA:21
    : inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
    : UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    : RX packets:1263 errors:0 dropped:0 overruns:0 frame:0
    : TX packets:1124 errors:0 dropped:0 overruns:0 carrier:62
    : collisions:0 txqueuelen:100
    : RX bytes:124138 (121.2 KiB) TX bytes:127088 (124.1 KiB)
    : Interrupt:11 Base address:0xdc00

    : lo Link encap:Local Loopback
    : inet addr:127.0.0.1 Mask:255.0.0.0
    : UP LOOPBACK RUNNING MTU:3924 Metric:1
    : RX packets:644 errors:0 dropped:0 overruns:0 frame:0
    : TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
    : collisions:0 txqueuelen:0
    : RX bytes:42361 (41.3 KiB) TX bytes:42361 (41.3 KiB)

    : sl0 Link encap:Serial Line IP
    : inet addr:192.168.0.100 P-t-P:192.168.0.100
    : Mask:255.255.255.255
    : UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    : RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    : TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    : collisions:0 txqueuelen:10
    : RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    : debian:/etc#
    Alex Yung Guest

  6. #6

    Default Re: debian user needs helps!

    On Thu, 11 Sep 2003 00:00:41 +1000, pc_newbie <aycomputermail.net> wrote:
    >
    >
    > how can i disable "sl0"? and what is that for? thanks:)
    >
    > debian:/etc# ifconfig
    > eth0 Link encap:Ethernet HWaddr 00:C0:4F:C0:FA:21
    > inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
    > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    > RX packets:1263 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:1124 errors:0 dropped:0 overruns:0 carrier:62
    > collisions:0 txqueuelen:100
    > RX bytes:124138 (121.2 KiB) TX bytes:127088 (124.1 KiB)
    > Interrupt:11 Base address:0xdc00
    >
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > UP LOOPBACK RUNNING MTU:3924 Metric:1
    > RX packets:644 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:0
    > RX bytes:42361 (41.3 KiB) TX bytes:42361 (41.3 KiB)
    >
    > sl0 Link encap:Serial Line IP
    > inet addr:192.168.0.100 P-t-P:192.168.0.100
    > Mask:255.255.255.255
    > UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:10
    > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    >
    > debian:/etc#
    >

    SLIP "serial-line-internet-protocol" . You can use it with a null-modem
    cable to connect two boxes if you have configured serial ports. Can be
    handy.

    The interface is being configured by a script in /etc/init.d, I'm pretty
    sure. Try grep -rn 'sl0' /etc/init.d

    HTH

    Alan C


    --

    take control of your mailbox ----- elrav1 ----- [url]http://tinyurl.com/l55a[/url]


    Alan Connor Guest

  7. #7

    Default Re: debian user needs helps!

    Alan Connor wrote:
    > On Thu, 11 Sep 2003 00:00:41 +1000, pc_newbie <aycomputermail.net> wrote:
    >
    >>
    >>how can i disable "sl0"? and what is that for? thanks:)
    >>
    >>debian:/etc# ifconfig
    >>eth0 Link encap:Ethernet HWaddr 00:C0:4F:C0:FA:21
    >> inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
    >> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    >> RX packets:1263 errors:0 dropped:0 overruns:0 frame:0
    >> TX packets:1124 errors:0 dropped:0 overruns:0 carrier:62
    >> collisions:0 txqueuelen:100
    >> RX bytes:124138 (121.2 KiB) TX bytes:127088 (124.1 KiB)
    >> Interrupt:11 Base address:0xdc00
    >>
    >>lo Link encap:Local Loopback
    >> inet addr:127.0.0.1 Mask:255.0.0.0
    >> UP LOOPBACK RUNNING MTU:3924 Metric:1
    >> RX packets:644 errors:0 dropped:0 overruns:0 frame:0
    >> TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
    >> collisions:0 txqueuelen:0
    >> RX bytes:42361 (41.3 KiB) TX bytes:42361 (41.3 KiB)
    >>
    >>sl0 Link encap:Serial Line IP
    >> inet addr:192.168.0.100 P-t-P:192.168.0.100
    >>Mask:255.255.255.255
    >> UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    >> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    >> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    >> collisions:0 txqueuelen:10
    >> RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    >>
    >>debian:/etc#
    >>
    >
    >
    >
    > SLIP "serial-line-internet-protocol" . You can use it with a null-modem
    > cable to connect two boxes if you have configured serial ports. Can be
    > handy.
    >
    > The interface is being configured by a script in /etc/init.d, I'm pretty
    > sure. Try grep -rn 'sl0' /etc/init.d
    >
    > HTH
    >
    > Alan C
    >
    >
    > --
    >
    > take control of your mailbox ----- elrav1 ----- [url]http://tinyurl.com/l55a[/url]
    >
    >

    all done!, thanks :)

    pc_newbie Guest

  8. #8

    Default Re: debian user needs helps!

    On Thu, 11 Sep 2003 14:47:45 +1000, pc_newbie <aycomputermail.net> wrote:
    >
    > all done!, thanks :)
    >
    Cool


    AC


    --

    take control of your mailbox ----- elrav1 ----- [url]http://tinyurl.com/l55a[/url]


    Alan Connor Guest

Similar Threads

  1. Meta: Scoring debian-user with mutt?
    By Jesse Meyer in forum Debian
    Replies: 2
    Last Post: August 6th, 02:10 PM
  2. Meta: Scoring debian-user with mutt?
    By hashi#pooq.com@pooq.com in forum Debian
    Replies: 0
    Last Post: August 3rd, 07:00 PM
  3. [gmane.linux.debian.user] PowerManagement mysteries
    By Alban Browaeys in forum Debian
    Replies: 0
    Last Post: August 1st, 06:00 AM
  4. debian-user-digest Digest V2003 #2112
    By John Stevenson in forum Debian
    Replies: 0
    Last Post: July 23rd, 07:40 PM
  5. debian-user be forever young
    By ZHAO Wei in forum Debian
    Replies: 0
    Last Post: June 29th, 08:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139