Professional Web Applications Themes

DEBUG help please? LoadXml error - ugh. - ASP.NET General

Hi, I know EVERYONE says this, but I'm using code that works fine in another form but I get an error on a new one. In my web page, I have imported the usual system references, System.XML, etc., then I retrieve an xml string from a db and set if as varXML. I then do Dim xDoc As XmlDoent xDoc.LoadXML(varXML) Dim Elem As XmlElement = xDoc.SelectSingleNode("my xpath") In debug, I can see the varXML string is there and correct (exactly as used elsewhere). The error is the dreaded "object not set to an instance of the object". Could someone please ...

  1. #1

    Default DEBUG help please? LoadXml error - ugh.

    Hi, I know EVERYONE says this, but I'm using code that works fine in
    another form but I get an error on a new one.

    In my web page, I have imported the usual system references, System.XML,
    etc., then I retrieve an xml string from a db and set if as varXML. I
    then do

    Dim xDoc As XmlDoent
    xDoc.LoadXML(varXML)
    Dim Elem As XmlElement = xDoc.SelectSingleNode("my xpath")

    In debug, I can see the varXML string is there and correct (exactly as
    used elsewhere).

    The error is the dreaded "object not set to an instance of the object".

    Could someone please tell me how I can debug this further? Where else do
    I look?

    Thank you.
    Kathy

    *** Sent via Developersdex [url]http://www.developersdex.com[/url] ***
    Don't just participate in USENET...get rewarded for it!
    Kathy Burke Guest

  2. #2

    Default Re: DEBUG help please? LoadXml error - ugh.

    Now you are a real developer.

    have fun.

    "Kathy Burke" <kathyburke40attbi.com> wrote in message
    news:eDkaci6VDHA.1748TK2MSFTNGP12.phx.gbl...
    > I'm hanging my head in shame, really I am, you should see me.
    >
    > Copied from another page where it xmlDoent was used before. So
    > embarrassed.
    >
    > thanks for saving my sanity...for today at least.
    >
    > Kathy
    >
    > *** Sent via Developersdex [url]http://www.developersdex.com[/url] ***
    > Don't just participate in USENET...get rewarded for it!

    MS News Guest

Similar Threads

  1. Error while trying to debug
    By Guest in forum ASP.NET Security
    Replies: 2
    Last Post: March 21st, 11:33 AM
  2. Debug Error when Running WEb Applicatoin - HELP!
    By Ash in forum ASP.NET Security
    Replies: 17
    Last Post: August 6th, 09:55 PM
  3. Replies: 3
    Last Post: July 29th, 12:25 AM
  4. cannot debug Internal Server Error
    By Evertjan. in forum ASP
    Replies: 2
    Last Post: July 28th, 11:37 PM
  5. Debug error message
    By John Black in forum ASP.NET General
    Replies: 0
    Last Post: July 25th, 07:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139