Professional Web Applications Themes

Display special characters (umlaut) on console - Linux Setup, Configuration & Administration

I installed Debian and now I my console doesn't display special characters of other languages any more (accents, umlaute). I switched the keyboard to other layouts, but when I hit an umlaut key, there appeared a wrong character or nothing or it beeped. I wrote a file with some of these characters in X Windows (where it works), displayed it on a text console and strange (well, not the expected) characters appeared. I tried various 'consolechars', but without success. What am I missing? -- ------------------------------------------------- Frank Hrebabetzky Tel.: +55 / 48 / 235 1106 Florianopolis +55 / 48 / 9998 ...

  1. #1

    Default Display special characters (umlaut) on console

    I installed Debian and now I my console doesn't display special
    characters of other languages any more (accents, umlaute).

    I switched the keyboard to other layouts, but when I hit an umlaut
    key, there appeared a wrong character or nothing or it beeped.

    I wrote a file with some of these characters in X Windows (where it
    works), displayed it on a text console and strange (well, not the
    expected) characters appeared.

    I tried various 'consolechars', but without success.

    What am I missing?

    --
    -------------------------------------------------
    Frank Hrebabetzky Tel.: +55 / 48 / 235 1106
    Florianopolis +55 / 48 / 9998 7686
    Brazil email: [email]frankhterra.com.br[/email]
    frank@terra.com.br Guest

  2. #2

    Default Re: Display special characters (umlaut) on console

    Hello

    [email]frankterra.com.br[/email] (<frankterra.com.br>) wrote:
    > I installed Debian and now I my console doesn't display special
    > characters of other languages any more (accents, umlaute).
    >
    > I switched the keyboard to other layouts, but when I hit an umlaut
    > key, there appeared a wrong character or nothing or it beeped.
    >
    > I wrote a file with some of these characters in X Windows (where it
    > works), displayed it on a text console and strange (well, not the
    > expected) characters appeared.
    >
    > I tried various 'consolechars', but without success.
    >
    > What am I missing?
    Maybe you need to setup a matching font. Take a look at

    /etc/console-tools/config.

    My has this line:

    SCREEN_FONT=lat0-16

    With this Umlaute and even Euro should work (with the
    euro-support-console package installed and configured locales).

    best regards
    Andreas Janssen

    --
    Andreas Janssen
    [email]andreas.janssenbigfoot.com[/email]
    PGP-Key-ID: 0xDC801674
    Registered Linux User #267976
    Andreas Janssen Guest

  3. #3

    Default Re: Display special characters (umlaut) on console

    In article <bhre99$acq$03$1news.t-online.com>, Andreas Janssen wrote:
    > Hello
    >
    > [email]frankterra.com.br[/email] (<frankterra.com.br>) wrote:
    >
    >> I installed Debian and now I my console doesn't display special
    >> characters of other languages any more (accents, umlaute).
    >>
    >> I switched the keyboard to other layouts, but when I hit an umlaut
    >> key, there appeared a wrong character or nothing or it beeped.
    >>
    >> I wrote a file with some of these characters in X Windows (where it
    >> works), displayed it on a text console and strange (well, not the
    >> expected) characters appeared.
    >>
    >> I tried various 'consolechars', but without success.
    >>
    >> What am I missing?
    >
    > Maybe you need to setup a matching font. Take a look at
    >
    > /etc/console-tools/config.
    That is an interesting file, didn't know that. Well, what I did last
    night is installing all the fonts I found on my Debian Woody CDs. The
    installation program (dselect) configured something and all of a
    sudden it worked. I don't remember what I was doing exactly because it
    was 2:00 in the morning, but I think it has to do with that strange
    'fonty' thing, which appearently is no program and has no manpage.

    -------------------------------------------------
    Frank Hrebabetzky Tel.: +55 / 48 / 235 1106
    Florianopolis +55 / 48 / 9998 7686
    Brazil email: [email]frankhterra.com.br[/email]
    frank@terra.com.br Guest

  4. #4

    Default Re: Display special characters (umlaut) on console

    [email]frankterra.com.br[/email] writes:
    >I installed Debian and now I my console doesn't display special
    >characters of other languages any more (accents, umlaute).
    >I switched the keyboard to other layouts, but when I hit an umlaut
    >key, there appeared a wrong character or nothing or it beeped.
    >I wrote a file with some of these characters in X Windows (where it
    >works), displayed it on a text console and strange (well, not the
    >expected) characters appeared.
    >I tried various 'consolechars', but without success.
    >What am I missing?
    There are several things here:

    Sometimes to get non-ASCII characters to work you need to deal
    with locales, for example, by exporting LC_CTYPE:

    export LC_CTYPE=en_GB

    This makes some programs recognise and print such characters.

    With respect to a shell, you need some special variables set,
    for example in your ~/.inputrc file before the shell starts. I have

    set meta-flag on
    set convert-meta off
    set output-meta on

    in mine; meta-flag, also known as input-meta, allows you to use
    8-bit characters in input; stop convert-meta to prevent the
    output routines from printing 8-bit characters with a prefix,
    and set output-meta on for the same. (I'm not sure what happens
    when you have only one or the other of these set like this.)

    When you are speaking of X and of console mode, you will sometimes
    find some differences between the visible forms of some non-ASCII
    graphic characters. For example, German upper-case vowels with
    umlauts display fine for me in both modes, but upper case A with
    French accents works fine in X, but not in console mode. Your
    mileage may vary!

    Note that there is a useful howto about the Euro character; it
    will give you some information about console fonts and key codes
    which are applicable in other respects involving extended character
    sets.

    -- Owen
    [email]LeBlancmcc.ac.uk[/email]
    LeBlanc@mcc.ac.uk Guest

Similar Threads

  1. Special characters
    By phil_dude in forum Macromedia ColdFusion
    Replies: 2
    Last Post: September 10th, 02:06 PM
  2. xml and special characters
    By German Hernandez in forum Macromedia Flash Data Integration
    Replies: 4
    Last Post: May 14th, 12:02 AM
  3. More special characters in FH
    By maciekk in forum Macromedia Freehand
    Replies: 1
    Last Post: July 19th, 11:11 AM
  4. Special Characters - Mac vs. PC - Help
    By tracetm2 webforumsuser@macromedia.com in forum Macromedia Director Lingo
    Replies: 2
    Last Post: August 29th, 06:29 PM
  5. Special characters #,$ etc
    By Mark Denham in forum Informix
    Replies: 1
    Last Post: August 1st, 05:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139