I found out that some of the lower end laser printers don't support Postscript drivers. As is the case with my samsung.