In article <Pine.SC5.4.10.10306231923490.25576-100000ris.UniXpress.com>,
Lucky Leavell <luckyunixpress.com> wrote:
>OS: OSR5.0.6a
>Modem: MultiTech MT2834ZDX (latest firmware rev)
>Port: COM1
>
>The other symptoms were the following error
>messages on the console when attempting a dial in:
>
> /etc/getty -t60 tty1A m (date_time stamp): Bad speed
>
> INIT: Commands respawning too rapidly ...
> id: Se1A: "/etc/getty -t60 tty1A m"
>
....
>(The 9600 speed and gettydef label was specified by their application vendor
>so I did not feel free to try one for hardware flow control.)
>
>inittab lines:
>
> Se1a:234:respawn:/etc/getty tty1a m
> Se1A:234:respawn:/etc/getty tty1A m
>
>gettydefs entry:
>
> m # B9600 HUPCL # B9600 CS8 SANE HUPCL TAB3 ECHOE #\r\nlogin: # m
>
>Devices file entries:
>
> ACU tty1A - 9600 MultiModem_MT2834ZDX
> Direct tty1a - 9600 direct
....
>Can anyone point out what I am missing here?
>(ANY suggestions will be greatly appreciated.)
"Bad speed" indicates that after getty ran the modem dialer to initialize the
line, it found that the serial port Baud rate did not match the rate given for
the gettydefs entry you're using. In general this should only happen if you
use the -f option to getty, but it can also happen if another process is
holding the line open - like another getty. See if you continue to have this
problem if you disable tty1a. If you do, try running the dialer manually with
debugging turned on:

/usr/lib/uucp/MultiModem_MT2834ZDX -x9 -h tty1A 9600

Also do '/etc/fuser /dev/tty1[aA]' to see if anything else has the line open.

John
--
John DuBois [email]spcecdtarmory.com[/email] KC6QKZ/AE [url]http://www.armory.com/~spcecdt/[/url]