Professional Web Applications Themes

dual boot problems: LILO stops at LI - Linux Setup, Configuration & Administration

On Wed, 25 Jun 2003 08:28:44 -0600, Brian Myers wrote: > I know this is a common problem in setting up dual-boot systems. I've > searched through the newsgroups; apparently the likely cause is some > mismatch in disk geometry. But I've tried messing with those settings in > lilo.conf without succeeding. So here's the relevant information; maybe > one of you can diagnose it better than I. > > <snip> > > By default, my lilo.conf came this way: > > # Support LBA for large hard disks. > # > lba32 > #linear > > # Specifies the ...

  1. #1

    Default Re: dual boot problems: LILO stops at LI

    On Wed, 25 Jun 2003 08:28:44 -0600, Brian Myers wrote:
    > I know this is a common problem in setting up dual-boot systems. I've
    > searched through the newsgroups; apparently the likely cause is some
    > mismatch in disk geometry. But I've tried messing with those settings in
    > lilo.conf without succeeding. So here's the relevant information; maybe
    > one of you can diagnose it better than I.
    >
    > <snip>
    >
    > By default, my lilo.conf came this way:
    >
    > # Support LBA for large hard disks.
    > #
    > lba32
    > #linear
    >
    > # Specifies the boot device. This is where Lilo installs its boot
    > # block. It can be either a partition, or the raw device, in which
    > # case it installs in the MBR, and will overwrite the current MBR.
    > #
    > boot=/dev/hde2
    >
    > <snip>
    >
    > Brian
    >
    The boot loader can be either on the MBR or on a partition BIOS parameter
    block,"BPB."

    [url]http://www.tldp.org/HOWTO/mini/LILO-2.html#ss2.1[/url]

    From your lilo.conf, it looks like the loader is on the BPB, and not on
    the MBR. I think in this case, you would
    1.Fix lilo.conf: boot=/dev/hde
    2.Install LILO on the MBR of hde
    3.Save that MBR as a file (as I presume you have been doing.)

    BTW, I switched to grub as the loader. It works for me as the overall boot
    manager.

    I recently wrote this:
    [url]http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=pan.2003.06.23.08.25.22.246539.1832%40world net.att.net[/url]

    --Douglas Mayne
    Douglas Mayne Guest

  2. #2

    Default Re: dual boot problems: LILO stops at LI

    Thanks. Your explanation makes sense to me, but I tried the steps without
    success. Perhaps I didn't do them correctly?
    > 1.Fix lilo.conf: boot=/dev/hde
    I did that, commenting out the old hde2 line.
    > 2.Install LILO on the MBR of hde
    After step 1 I typed /etc/lilo and it ran--I assume that's what "installing"
    consists of?
    > 3.Save that MBR as a file (as I presume you have been doing.)
    I ran dd if=/dev/hde of=/floppy/linimage.bin bs=512 count=1 (and then copied
    the file to hdc.)

    Now when I try to launch Linux I get this output:

    LI
    LI

    Perhaps I'll look into grub as you recommend; maybe it's easier to
    configure.

    In the meantime I'd welcome further advice on this problem if anyone has
    more insights.

    Brian



    Brian Myers Guest

  3. #3

    Default Re: dual boot problems: LILO stops at LI

    On Sun, 29 Jun 2003 09:41:13 -0600, Brian Myers wrote:
    > Thanks. Your explanation makes sense to me, but I tried the steps
    > without success. Perhaps I didn't do them correctly?
    >
    >> 1.Fix lilo.conf: boot=/dev/hde
    >
    > I did that, commenting out the old hde2 line.
    >
    >> 2.Install LILO on the MBR of hde
    >
    > After step 1 I typed /etc/lilo and it ran--I assume that's what
    > "installing" consists of?
    Were any error messages issued?

    You can issue this command to test your configuration before installing:
    # lilo -v -t

    If there are no errors

    # lilo -v

    Refer to man lilo for more details. I am not so good at using LILO these
    days.
    >
    >> 3.Save that MBR as a file (as I presume you have been doing.)
    >
    > I ran dd if=/dev/hde of=/floppy/linimage.bin bs=512 count=1 (and then
    > copied the file to hdc.)
    >
    > Now when I try to launch Linux I get this output:
    >
    > LI
    > LI
    >
    > Perhaps I'll look into grub as you recommend; maybe it's easier to
    > configure.
    >
    > In the meantime I'd welcome further advice on this problem if anyone has
    > more insights.
    >
    > Brian
    >
    I assumed you edited the original lilo.conf you posted.

    If that is the complete file, it is missing the "stanza" which specifies
    the kernel, and (perhaps) other necessary information. This page shows
    an example:

    [url]http://www.geocities.com/CYBERKABILA/main/lilo.htm[/url]

    It also shows common LILO errors. It shows the LI lilo error
    indicates, "LILO cannot find kernel image." This error can be caused by
    multiple failures.

    Please post the complete /etc/lilo.conf file.


    --Douglas Mayne
    Douglas Mayne Guest

  4. #4

    Default Re: dual boot problems: LILO stops at LI


    Brian Myers wrote:
    >
    > I know this is a common problem in setting up dual-boot systems. I've
    > searched through the newsgroups; apparently the likely cause is some
    > mismatch in disk geometry.
    I recently had a "LI" boot failure as well, which I don't believe had
    anything to do with disk geometry issues.

    Before rebooting, I had run lilo which returned an error message. The
    error message related to the fact that some of the entries in lilo.conf
    had gone stale, in the sense that the kernels they referenced no longer
    existed (they had been removed).

    I fixed the lilo.conf problem, but forgot to re-run lilo. When I
    rebooted, the boot process stopped at "LI".

    So: your problem may be solved by simply re-running lilo. That is what
    it took me to rectify the situation. Note though that this is not
    straightforward:

    - boot from a floppy, probably into a rescue image (I'm using RedHat)
    - chroot to your root partition
    - run lilo
    - reboot

    I haven't tried it any other way, but I expect that lilo must be run
    with all of the file systems in the same places as where they are when
    your system is up & running (hence the chroot).

    Hope this helps.

    Jan
    Jan Ceuleers Guest

  5. #5

    Default Re: dual boot problems: LILO stops at LI

    > It's more or less a waste of time asking about LILO or Grub
    > if you don't give your lilo.conf or grub.conf .
    Sorry! the first note in this thread has an except from my lilo.conf. Here
    is the full file, in case that helps.

    ------------------

    # /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
    # --------------- `install-mbr(8)', `/usr/share/doc/lilo/',
    # and `/usr/share/doc/mbr/'.

    # +---------------------------------------------------------------+
    # | !! Reminder !! |
    # | |
    # | Don't forget to run `lilo' after you make changes to this |
    # | conffile, `/boot/bootmess.txt', or install a new kernel. The |
    # | computer will most likely fail to boot if a kernel-image |
    # | post-install script or you don't remember to run `lilo'. |
    # | |
    # +---------------------------------------------------------------+

    # Support LBA for large hard disks.
    #
    lba32
    #linear

    # Overrides the default mapping between harddisk names and the BIOS'
    # harddisk order. Use with caution.
    #disk=/dev/hde
    # bios=0x81

    #disk=/dev/sda
    # bios=0x80

    # Specifies the boot device. This is where Lilo installs its boot
    # block. It can be either a partition, or the raw device, in which
    # case it installs in the MBR, and will overwrite the current MBR.
    #
    boot=/dev/hde2

    # Specifies the device that should be mounted as root. (`/')
    #
    root=/dev/hde2

    # Enable map compaction:
    # Tries to merge read requests for adjacent sectors into a single
    # read request. This drastically reduces load time and keeps the
    # map smaller. Using `compact' is especially recommended when
    # booting from a floppy disk. It is disabled here by default
    # because it doesn't always work.
    #
    # compact

    # Installs the specified file as the new boot sector
    # You have the choice between: bmp, compat, menu and text
    # Look in /boot/ and in lilo.conf(5) manpage for details
    #
    install=/boot/boot-menu.b

    # Specifies the location of the map file
    #
    map=/boot/map

    # You can set a password here, and uncomment the `restricted' lines
    # in the image definitions below to make it so that a password must
    # be typed to boot anything but a default configuration. If a
    # command line is given, other than one specified by an `append'
    # statement in `lilo.conf', the password will be required, but a
    # standard default boot will not require one.
    #
    # This will, for instance, prevent anyone with access to the
    # console from booting with something like `Linux init=/bin/sh',
    # and thus becoming `root' without proper authorization.
    #
    # Note that if you really need this type of security, you will
    # likely also want to use `install-mbr' to reconfigure the MBR
    # program, as well as set up your BIOS to disallow booting from
    # removable disk or CD-ROM, then put a password on getting into the
    # BIOS configuration as well. Please RTFM `install-mbr(8)'.
    #
    # password=tatercounter2000

    # Specifies the number of deciseconds (0.1 seconds) LILO should
    # wait before booting the first image.
    #
    delay=20

    # You can put a customized boot message up if you like. If you use
    # `prompt', and this computer may need to reboot unattended, you
    # must specify a `timeout', or it will sit there forever waiting
    # for a keypress. `single-key' goes with the `alias' lines in the
    # `image' configurations below. eg: You can press `1' to boot
    # `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
    #
    # message=/boot/bootmess.txt
    # prompt
    # single-key
    # delay=100
    # timeout=100

    # Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
    #
    # vga=ask
    # vga=9
    #
    vga=normal

    # Kernel command line options that apply to all installed images go
    # here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
    # the Linux kernel `Doentation' directory.
    #
    # append=""

    # Boot up Linux by default.
    #
    default=Linux

    image=/vmlinuz
    label=Linux
    read-only
    # restricted
    # alias=1

    image=/vmlinuz.old
    label=LinuxOLD
    read-only
    optional
    # restricted
    # alias=2

    # If you have another OS on this machine to boot, you can uncomment the
    # following lines, changing the device name on the `other' line to
    # where your other OS' partition is.
    #
    # other=/dev/hda4
    # label=HURD
    # restricted
    # alias=3


    Brian Myers Guest

  6. #6

    Default Re: dual boot problems: LILO stops at LI

    Brian Myers wrote:
    >> It's more or less a waste of time asking about LILO or Grub
    >> if you don't give your lilo.conf or grub.conf .
    >
    > Sorry! the first note in this thread has an except from my lilo.conf. Here
    > is the full file, in case that helps.
    Well, I asked for it,
    but I'm not really the person to advise you on it!
    (I use grub, for one thing.)

    But what command do you use to install lilo?

    If I were in your position I would install LILO on the MBR of /dev/sda ,
    by replacing "boot=/dev/hde2" by "boot=/dev/sda".

    You are trying to install LILO on the partition /dev/hde2
    of what I assume is the second hard disk.
    Although this might be possible by including the command "bios=0x81"
    (and making this partition active with fdisk)
    it seems rather complicated to me.
    (The bios command makes the machine think this is the first disk.
    I don't know if that will work with your setup.
    It's normally used with /dev/hda and /dev/hdb, or /dev/sda and /dev/sdb.)

    ================================================== ==========
    > lba32
    # Overrides the default mapping between harddisk names and the BIOS'
    > # harddisk order. Use with caution.
    > #disk=/dev/hde
    > # bios=0x81
    >
    > #disk=/dev/sda
    > # bios=0x80
    >
    > # Specifies the boot device. This is where Lilo installs its boot
    > # block. It can be either a partition, or the raw device, in which
    > # case it installs in the MBR, and will overwrite the current MBR.
    > #
    > boot=/dev/hde2
    >
    > # Specifies the device that should be mounted as root. (`/')
    > #
    > root=/dev/hde2
    > # Installs the specified file as the new boot sector
    > # You have the choice between: bmp, compat, menu and text
    > # Look in /boot/ and in lilo.conf(5) manpage for details
    > #
    > install=/boot/boot-menu.b
    >
    > # Specifies the location of the map file
    > #
    > map=/boot/map
    >
    > delay=20
    > # Specifies the VGA text mode at boot time. (normal, extended, ask,
    > # <mode>)
    > #
    > # vga=ask
    > # vga=9
    > #
    > vga=normal
    >
    > # Kernel command line options that apply to all installed images go
    > # here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
    > # the Linux kernel `Doentation' directory.
    > #
    > # append=""
    >
    > # Boot up Linux by default.
    > #
    > default=Linux
    >
    > image=/vmlinuz
    > label=Linux
    > read-only
    > # restricted
    > # alias=1
    >
    > image=/vmlinuz.old
    > label=LinuxOLD
    > read-only
    > optional
    > # restricted
    > # alias=2
    ================================================== ==========


    --
    Timothy Murphy
    e-mail: [email]timbirdsnest.maths.tcd.ie[/email]
    tel: +353-86-233 6090
    s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland
    Timothy Murphy Guest

  7. #7

    Default Re: dual boot problems: LILO stops at LI

    Timothy Murphy wrote:
    > Brian Myers wrote:
    >
    >
    >>>It's more or less a waste of time asking about LILO or Grub
    >>>if you don't give your lilo.conf or grub.conf .
    >>
    >>Sorry! the first note in this thread has an except from my lilo.conf. Here
    >>is the full file, in case that helps.
    >
    >
    > Well, I asked for it,
    > but I'm not really the person to advise you on it!
    > (I use grub, for one thing.)
    >
    > But what command do you use to install lilo?
    >
    > If I were in your position I would install LILO on the MBR of /dev/sda ,
    > by replacing "boot=/dev/hde2" by "boot=/dev/sda".
    This only works if the BIOS is configured to boot from SCSI before IDE
    drives. This is a very, very important thing to check when mixing IDE
    and SCSI on the same machine.

    Nico Kadel-Garcia Guest

  8. #8

    Default Re: dual boot problems: LILO stops at LI

    > If I were in your position I would install LILO on the MBR of /dev/sda ,
    > by replacing "boot=/dev/hde2" by "boot=/dev/sda".
    My machine isn't booting from the SCSI drive.
    I have three hard drives. Windows is on the first IDE hard drive. The second
    IDE drive has 12GB and is empty. The old SCSI drive still lingering on the
    machine is only 2GB and I use it for backups.

    (hda and hdb are my CDROM and DVD drives. That's what Linux decided to call
    them; I suppose their IDE controller comes first in some internal list
    somewhere.)
    > You are trying to install LILO on the partition /dev/hde2
    > of what I assume is the second hard disk.
    > Although this might be possible by including the command "bios=0x81"
    > (and making this partition active with fdisk)
    > it seems rather complicated to me.
    To me too. :)


    Brian Myers Guest

  9. #9

    Default Re: dual boot problems: LILO stops at LI

    <Removed all comments from your lilo.conf>
    > lba32
    >
    > disk=/dev/hdc
    > bios=0x80
    > disk=/dev/hde
    > bios=0x81
    >
    > boot=/dev/hde2
    > root=/dev/hde2
    > install=/boot/boot-menu.b
    > map=/boot/map
    > delay=20
    > vga=normal
    > default=Linux
    >
    > image=/vmlinuz
    > label=Linux
    > read-only
    >
    > image=/vmlinuz.old
    > label=LinuxOLD
    > read-only
    > optional
    run lilo -v with this lilo.conf

    copy the bootsector from /dev/hde2 to a file

    Add that file to the NT loader.

    reboot.

    (Or use the scheme John mentioned with lilo as the main bootloader)

    Eric
    Eric Moors Guest

  10. #10

    Default Re: dual boot problems: LILO stops at LI

    I strongly suggest that you get LILO 22.5.6, the latest release, as it is far
    more capable in getting to the second stage loader than the old version of
    LILO you are presently using. I haven't seen the version number in any of
    your posts.

    LILO is set up to act as a boot manager also. Your lilo.conf file has a "fill
    in the blanks" approach to setting it up.

    --John



    On Wed, 25 Jun 2003 07:28:44 -0700, "Brian Myers"
    <brian_myersNOSPAM> wrote:
    >I know this is a common problem in setting up dual-boot systems. I've
    >searched through the newsgroups; apparently the likely cause is some
    >mismatch in disk geometry. But I've tried messing with those settings in
    >lilo.conf without succeeding. So here's the relevant information; maybe one
    >of you can diagnose it better than I.
    >
    >Linux distribution
    > Debian (Woody)
    >
    >Excerpts from dmesg:
    > hda: Pioneer DVD-ROM ATAPIModel DVD-103S 011, ATAPI CD/DVD-ROM drive
    > hdb: CR-487ETE, ATAPI CD/DVD-ROM drive
    > hdc: Maxtor 6Y120P0, ATA DISK drive
    > hde: IBM-DJNA-371350, ATA DISK drive
    > hdc: 240121728 sectors (122942 MB) w/7936KiB Cache, CHS=238216/16/63
    > hde: 26520480 sectors (13578 MB) w/1966KiB Cache, CHS=26310/16/63,
    >UDMA(33)
    > Partition check:
    > hdc: [PTBL] [14946/255/63] hdc1
    > hde: hde1 < hde5 > hde2
    >
    >Boot details
    > hdc is my Windows drive.
    > hde is my Linux drive.
    > I'm trying to dual-boot using the NT loader on hdc. I'm using the dd
    >command to create a linimage.bin file, copying that to hdc, and editing
    >boot.ini.
    > Everything works fine if I boot from the Linux floppy.
    > hde is attached to a Highpoint Technology controller--Hpt366 Ultra DMA
    >66.
    >
    >By default, my lilo.conf came this way:
    >
    > # Support LBA for large hard disks.
    > #
    > lba32
    > #linear
    >
    > # Specifies the boot device. This is where Lilo installs its boot
    > # block. It can be either a partition, or the raw device, in which
    > # case it installs in the MBR, and will overwrite the current MBR.
    > #
    > boot=/dev/hde2
    >
    >On system boot after the bios messages appear my highpoint controller
    >displays three sets of disk geometry figures for the hde drive. One of the
    >options is marked with a "(Y)", so I assume that option is the one currently
    >in effect. Here are the values it displays:
    >
    > Options 2(Y)
    > Size 122
    > Cyls 14946
    > Head 255
    > Precomp 0
    > Sector 63
    > Mode LBA
    >
    >It looks to me as though lba32 ought to be the right option. I'm surprised
    >it doesn't work. But since it doesn't, of course I tried setting Linear
    >instead, but that wasn't any better. (Yes, I am remembering to sbin\lilo
    >after each change and create a new linimage.bin.)
    >
    >I note, however, the the head and cylinder counts listed here do not match
    >those given in the dmesg listing. Is that part of the problem?
    >
    >Why does it work when I boot from the floppy? What geometry settings are in
    >effect then?
    >
    >I also tried creating an hde specification in lilo.conf using the numbers
    >given by the highpoint controller, but that didn't work either.
    >
    >What do I need to do to make the dual-boot setup work?
    >
    >Brian
    >
    >
    >
    >
    >
    >
    >
    >
    >
    >
    >

    LILO version 22++ links at:
    [url]http://freshmeat.net/projects/lilo[/url]
    johninsd at san dot rr dot com Guest

  11. #11

    Default Re: dual boot problems: LILO stops at LI

    On Mon, 30 Jun 2003 16:54:11 +0200, Brian Myers wrote:
    > Thanks, Eric, for confirming that these steps ought to work. They seem
    > straightforward to me--but when I follow these steps and reboot I get the LI
    > error. Perhaps I'm not executing them correctly? Here's what I do.
    >
    >> run lilo -v with this lilo.conf
    >
    > Does it matter what directory you're in when you do this? I've tried running
    > /sbin/lilo -v from /etc and from /.
    >
    >> copy the bootsector from /dev/hde2 to a file
    >
    > dd if=/dev/hde2 of=/floppy/linimage.bin bs=512 count=1
    >
    >> Add that file to the NT loader.
    >
    > Reboot to that "W" operating system no one likes to mention and copy the
    > linimage.bin from the floppy to the root directiry where boot.ini is. Added
    > a line to boot.ini. This part's all very straightforward and I don't think
    > I've made a mistake here.
    >
    >> reboot.
    >
    > And I'm *sure* I did that part right.
    Oh, I did fix your lilo.conf.
    You did notice this and *used* the fixed lilo.conf, right?
    If you did, try changing boot=/dev/hde2 to boot=/dev/fd0
    Put in a floppy, and try rebooting from that floppy.
    (It is a faster test turn around cycle then changing
    stuff in the NT loader is)

    If it works copy the bootsector from the floppy to NT.

    Eric
    >> > lba32
    >> >
    >> > disk=/dev/hdc
    >> > bios=0x80
    >> > disk=/dev/hde
    >> > bios=0x81
    >> >
    >> > boot=/dev/hde2
    >> > root=/dev/hde2
    >> > install=/boot/boot-menu.b
    >> > map=/boot/map
    >> > delay=20
    >> > vga=normal
    >> > default=Linux
    >> >
    >> > image=/vmlinuz
    >> > label=Linux
    >> > read-only
    >> >
    >> > image=/vmlinuz.old
    >> > label=LinuxOLD
    >> > read-only
    >> > optional
    >>
    Eric Moors Guest

  12. #12

    Default Eureka! (was Re: dual boot problems: LILO stops at LI)

    > Oh, I did fix your lilo.conf.
    > You did notice this and *used* the fixed lilo.conf, right?
    Er, no. I did not notice you had fixed my lilo.conf. That makes me feel
    stupid--especially because when I tried your fixed file it worked just
    fine! But then the process of debugging Linux setup problems generally
    seems designed to instill humility in newcomers.

    Thanks very much for the help Eric!

    Brian
    Brian Guest

Similar Threads

  1. RH9 install problems (with dual-boot laptop)
    By Tom Crick in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: August 27th, 08:42 AM
  2. Floppy boot option in Lilo
    By Darsin in forum Linux Setup, Configuration & Administration
    Replies: 8
    Last Post: August 9th, 07:05 AM
  3. Change *first* bootloader from Lilo to Winxp with boot.ini
    By silly in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: July 3rd, 03:49 AM
  4. Debian lilo won't boot Redhat
    By Bijan Soleymani in forum Debian
    Replies: 9
    Last Post: July 2nd, 10:40 PM
  5. Using Lilo to boot more than one Linux distro.
    By Jon Haugsand in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: June 30th, 12:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139