Not sure which group this should go to, but I will post here because
it is related to development. I am a newbie with respect to working on
Mac. This is part of a Java based installer.

Basically I am doing a Runtime.exec("open Installer.app") The first
time something is exec'ed this way, it is okay. The second time I exec
I get the following error.

2003-09-29 17:29:08.916 open[10483] LSOpenFromURLSpec() returned -2110
for application (null) path
Volumes/TAEC/installer/scripts/macosx/run/Installer.app.
2003-09-29 17:29:08.919 open[10483] Couldn't open file:
/Volumes/TAEC/installer/scripts/macosx/run/Installer.app

I can also duplicate this from from the command line doing something
like

open /Volumes/TAEC/installer/scripts/macosx/run/Installer.app

The first time I run this from the command line it is okay, the second
I run the command (which is after the first command is completed) I
get the above error.

I searched through MacErrors.h and -2110 corresponds to
pathTooLongErr.

If I dismount and remount the cd, the I can run the open command
again, but then it fails on the second attempt.

The cd image I am running this from is created from mkisofs using the
command

mkisofs -V TAEC -r -J -o cd0.iso cd0dir

Am I possibly doing something wrong with the iso image creation.