Professional Web Applications Themes

Error: (Client found response content type...) - ASP.NET Web Services

I use webservice to connect to a server on Internet and sometimes(not always), I recieve this error on calling webserice member functions. Error: ********************************** Client found response content type of '', but expected 'text/xml'. The request failed with the error message: -- <HTML><HEAD><META HTTP-EQUIV="REFRESH" CONTENT="0" URL="http://iransaham.com/dataservice.asmx"></HEAD><BODY> </BODY></HTML> ********************************** Thanks in advance...

  1. #1

    Default Error: (Client found response content type...)

    I use webservice to connect to a server on Internet and sometimes(not
    always), I recieve this error on calling webserice member functions.

    Error:
    **********************************
    Client found response content type of '', but expected 'text/xml'.
    The request failed with the error message:
    --
    <HTML><HEAD><META HTTP-EQUIV="REFRESH" CONTENT="0"
    URL="http://iransaham.com/dataservice.asmx"></HEAD><BODY>
    </BODY></HTML>
    **********************************

    Thanks in advance


    Soheil Guest

  2. #2

    Default Re: Error: (Client found response content type...)

    This may be happening because the Web service call is failing after the
    proxy has invoked the service. The proxy expects XML back but is, for
    example, receiving an HTTP error. If the error were in the Web service
    itself, then you would more likely receive a SoapException.

    To troubleshoot this issue, set breakpoints in the Web service and in the
    proxy, and try to find out where the call is failing.

    Jeffrey Hasan, MCSD
    President, Bluestone Partners, Inc.
    -----------------------------------------------
    Author of: Expert SOA in C# Using WSE 2.0 (APress, 2004)
    [url]http://www.bluestonepartners.com/soa.aspx[/url]

    "Soheil" <soheilprox> wrote in message
    news:uenwklydEHA.2376tk2msftngp13.phx.gbl...
    > I use webservice to connect to a server on Internet and sometimes(not
    > always), I recieve this error on calling webserice member functions.
    >
    > Error:
    > **********************************
    > Client found response content type of '', but expected 'text/xml'.
    > The request failed with the error message:
    > --
    > <HTML><HEAD><META HTTP-EQUIV="REFRESH" CONTENT="0"
    > URL="http://iransaham.com/dataservice.asmx"></HEAD><BODY>
    > </BODY></HTML>
    > **********************************
    >
    > Thanks in advance
    >
    >

    Jeffrey Hasan Guest

  3. #3

    Default Re: Error: (Client found response content type...)

    Hi Jeffrey

    Adding the Soheil's question, here is the exact scenario where I get the
    error. But I do not know how to solve it.

    I use soap extension on my web service for encrypting and decrypting the
    message. I tried to debug the web service also, it is not even reaching
    there.

    As soon as I make a call to the web service, my calls goes to before
    deserialize and here I am getting the error, the Stream which I am
    getting is having blank string. With this I am getting the XmlException
    and inturns gives the error.

    Also, this error comes only when I leave the application idle for say 20
    min or so. I thought, it may be because of the session timeout, so
    changed the timeout from 20 min to 1 hour, but still having the problem.

    I am stuck here....

    Exepecting your help on this.

    Thanks in Advance
    Duva

    *** Sent via Developersdex [url]http://www.developersdex.com[/url] ***
    Don't just participate in USENET...get rewarded for it!
    Duvaraganath B R Guest

Similar Threads

  1. Client found response content type of '', but expected 'text/xml'
    By Vish Ramachandran in forum ASP.NET Web Services
    Replies: 7
    Last Post: November 2nd, 11:36 AM
  2. Replies: 4
    Last Post: February 15th, 11:00 PM
  3. Replies: 0
    Last Post: July 26th, 02:47 AM
  4. Client found response content type of 'application/soap'
    By nilok in forum ASP.NET Web Services
    Replies: 0
    Last Post: December 16th, 02:32 PM
  5. Replies: 0
    Last Post: November 14th, 08:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139