Professional Web Applications Themes

Error on device when calling a web service - ASP.NET Web Services

I get the following error when calling a web service that returns a dataset with about 4000 records (one table, nine fields): A managed SocketException occured at Application::Run+0xf Could not find resource assembly Application::Run+0xf frmUpdateScanner::Main+0xd Ok to terminate I only get this error when I call the webservice from the device (Symbol Barcode Scanner running PocketPC). The same code works fine when I run it on the emulator. Thanks for any advice, Sacha...

  1. #1

    Default Error on device when calling a web service

    I get the following error when calling a web service that returns a dataset
    with about 4000 records (one table, nine fields):

    A managed SocketException occured at Application::Run+0xf

    Could not find resource assembly

    Application::Run+0xf
    frmUpdateScanner::Main+0xd

    Ok to terminate


    I only get this error when I call the webservice from the device (Symbol
    Barcode Scanner running PocketPC). The same code works fine when I run it on
    the emulator.

    Thanks for any advice,

    Sacha


    Sacha Korell Guest

  2. #2

    Default Re: Error on device when calling a web service

    and by the way, transferring 4000 records will take to much time on pocket
    pc. And using dataset is not the best solution. I used another way and the
    speed was 8 times faster then dataset.

    "Sacha Korell" <korellhuntsville.sparta.com> wrote in message
    news:ue#ev5lRDHA.3796tk2msftngp13.phx.gbl...
    > I get the following error when calling a web service that returns a
    dataset
    > with about 4000 records (one table, nine fields):
    >
    > A managed SocketException occured at Application::Run+0xf
    >
    > Could not find resource assembly
    >
    > Application::Run+0xf
    > frmUpdateScanner::Main+0xd
    >
    > Ok to terminate
    >
    >
    > I only get this error when I call the webservice from the device (Symbol
    > Barcode Scanner running PocketPC). The same code works fine when I run it
    on
    > the emulator.
    >
    > Thanks for any advice,
    >
    > Sacha
    >
    >

    Mohammad Abu Sharkh Guest

  3. #3

    Default Re: Error on device when calling a web service

    Hi,

    Try to use the IDE for deployment. All what you need to do is to run the
    solution. If it worked fine, it means you have a missing assembly in the cab
    files.

    Regards,
    Mohammad

    "Sacha Korell" <korellhuntsville.sparta.com> wrote in message
    news:e3uP5EuRDHA.2144TK2MSFTNGP11.phx.gbl...
    > Thanks for your reply!
    >
    > No I am not using the IDE, but create a CAB file and move it to the
    scanner
    > and install it that way.
    >
    > What other way are you using?
    >
    > Thanks for your help,
    >
    > Sacha
    >
    >
    > "Mohammad Abu Sharkh" <mabusharkhccc.gr> wrote in message
    > news:OUJlYOsRDHA.3236TK2MSFTNGP10.phx.gbl...
    > > and by the way, transferring 4000 records will take to much time on
    pocket
    > > pc. And using dataset is not the best solution. I used another way and
    the
    > > speed was 8 times faster then dataset.
    > >
    > > "Sacha Korell" <korellhuntsville.sparta.com> wrote in message
    > > news:ue#ev5lRDHA.3796tk2msftngp13.phx.gbl...
    > > > I get the following error when calling a web service that returns a
    > > dataset
    > > > with about 4000 records (one table, nine fields):
    > > >
    > > > A managed SocketException occured at Application::Run+0xf
    > > >
    > > > Could not find resource assembly
    > > >
    > > > Application::Run+0xf
    > > > frmUpdateScanner::Main+0xd
    > > >
    > > > Ok to terminate
    > > >
    > > >
    > > > I only get this error when I call the webservice from the device
    (Symbol
    > > > Barcode Scanner running PocketPC). The same code works fine when I run
    > it
    > > on
    > > > the emulator.
    > > >
    > > > Thanks for any advice,
    > > >
    > > > Sacha
    > > >
    > > >
    > >
    > >
    >
    >

    Mohammad Abu Sharkh Guest

Similar Threads

  1. intermittent error calling .NET web service
    By Eddie J in forum ASP.NET Web Services
    Replies: 6
    Last Post: April 29th, 03:57 PM
  2. Intermittent Error When Calling Web Service from ASP.NET
    By Steve Piccolo in forum ASP.NET Web Services
    Replies: 4
    Last Post: February 4th, 07:37 PM
  3. Unauthorized Error Calling Web Service
    By Francois Guerin in forum ASP.NET Web Services
    Replies: 0
    Last Post: August 20th, 10:05 AM
  4. Error calling web service
    By John in forum ASP.NET Web Services
    Replies: 4
    Last Post: August 17th, 01:07 PM
  5. Replies: 0
    Last Post: November 12th, 03:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139