Professional Web Applications Themes

FAT32 partition mount problem - Linux Setup, Configuration & Administration

Greetings all: I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD I have a FAT32 shared partition, and I created the following entry in my fstab: /dev/hda6 /mnt/w2k vfat defaults 0 0 The problem I'm having is I can see the partition and it's content, but I can't write to it, not even as root, what I'm doing wrong? Any suggestion or comment is much appreciated (I'm newbie, so please bear with me). -- Thanks, ------------------------------------------------- Ko Fei Pu mailto:kfpu...

  1. #1

    Default FAT32 partition mount problem

    Greetings all:
    I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD
    I have a FAT32 shared partition, and I created the following entry in
    my fstab:
    /dev/hda6 /mnt/w2k vfat defaults 0 0

    The problem I'm having is I can see the partition and it's content, but
    I can't write to it, not even as root, what I'm doing wrong?

    Any suggestion or comment is much appreciated (I'm newbie, so please
    bear with me).
    --

    Thanks,
    -------------------------------------------------
    Ko Fei Pu
    mailto:kfpu

    Ko Fei Pu Guest

  2. #2

    Default Re: FAT32 partition mount problem

    On Wed, 03 Sep 2003 01:23:45 GMT, Ko Fei Pu wrote:
    > Greetings all:
    > I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD
    > I have a FAT32 shared partition, and I created the following entry in
    > my fstab:
    > /dev/hda6 /mnt/w2k vfat defaults 0 0
    >
    > The problem I'm having is I can see the partition and it's content, but
    > I can't write to it, not even as root, what I'm doing wrong?
    try adding a rw in the fs_mntops field
    man fstab for more info
    Bit Twister Guest

  3. #3

    Default Re: FAT32 partition mount problem

    I tried to add rw, it didn't work, so I changed to -w (according to the
    man, this should work), but none of them worked, any other idea?

    Thanks
    Ko Fei

    Bit Twister wrote:
    > On Wed, 03 Sep 2003 01:23:45 GMT, Ko Fei Pu wrote:
    >
    >>Greetings all:
    >>I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD
    >> I have a FAT32 shared partition, and I created the following entry in
    >>my fstab:
    >>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >>
    >>The problem I'm having is I can see the partition and it's content, but
    >>I can't write to it, not even as root, what I'm doing wrong?
    >
    >
    > try adding a rw in the fs_mntops field
    > man fstab for more info
    --

    Thanks,
    -------------------------------------------------
    Ko Fei Pu
    mailto:kfpu

    Ko Fei Pu Guest

  4. #4

    Default Re: FAT32 partition mount problem

    Yes, I did umount/mount, I even rebooted the computer, still it won't
    allow me to write to it.

    Bit Twister wrote:
    > On Wed, 03 Sep 2003 01:48:33 GMT, Ko Fei Pu wrote:
    >
    >>I tried to add rw, it didn't work, so I changed to -w (according to the
    >>man, this should work), but none of them worked, any other idea?
    >
    >
    > Hmmm, you would think read and write would work which is how I have
    > my mandrake fstab setup. Did you do a
    > umount /mnt/w2k
    > mount /mnt/w2k
    >
    > touch /mnt/w2k/junk.txt
    > rm /mnt/w2k/junk.txt
    --

    Thanks,
    -------------------------------------------------
    Ko Fei Pu
    mailto:kfpu

    Ko Fei Pu Guest

  5. #5

    Default Re: FAT32 partition mount problem

    Here's the /etc/fstab:
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda8 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660
    noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto
    noauto,owner,kudzu 0 0
    /dev/hda6 /mnt/w2k vfat defaults 0 0

    Here's fdisk -l /dev/hda:
    Disk /dev/hda: 30.0 GB, 30020272128 bytes
    255 heads, 63 sectors/track, 3649 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 701 5630751 7 HPFS/NTFS
    /dev/hda2 702 3648 23671777+ f Win95 Ext'd (LBA)
    /dev/hda5 702 707 48163+ 83 Linux
    /dev/hda6 708 1982 10241406 c Win95 FAT32 (LBA)
    /dev/hda7 1983 3002 8193118+ 83 Linux
    /dev/hda8 3003 3129 1020096 82 Linux swap

    TIA

    Bit Twister wrote:
    > On Wed, 03 Sep 2003 01:56:36 GMT, Ko Fei Pu wrote:
    >
    >>Yes, I did umount/mount, I even rebooted the computer, still it won't
    >>allow me to write to it.
    >
    >
    > Ok, post your /etc/fstab and fdisk -l /dev/hda
    >
    > Should have worked.
    >
    >
    >>Bit Twister wrote:
    >>
    >>>On Wed, 03 Sep 2003 01:48:33 GMT, Ko Fei Pu wrote:
    >>>
    >>>
    >>>>I tried to add rw, it didn't work, so I changed to -w (according to the
    >>>>man, this should work), but none of them worked, any other idea?
    >>>
    >>>
    >>>Hmmm, you would think read and write would work which is how I have
    >>>my mandrake fstab setup. Did you do a
    >>>umount /mnt/w2k
    >>>mount /mnt/w2k
    >>>
    >>>touch /mnt/w2k/junk.txt
    >>>rm /mnt/w2k/junk.txt
    >>
    >
    >
    --

    Thanks,
    -------------------------------------------------
    Ko Fei Pu
    mailto:kfpu

    Ko Fei Pu Guest

  6. #6

    Default Re: FAT32 partition mount problem

    In comp.os.linux.misc Ko Fei Pu <kfpu> wrote:
    >>>/dev/hda6 /mnt/w2k vfat defaults 0 0
    [...]
    > I tried to add rw, it didn't work, so I changed to -w (according to the
    Well, don't "try", "do". And yes, it does work. SHow your altered
    fstab line.
    > man, this should work), but none of them worked, any other idea?
    No, man fstab says NOTHING about "-w". That shoudl NOT have worked.

    No ideas are necessary. Only diagnosis.

    You are probably mistaking your condition.


    Peter
    Peter T. Breuer Guest

  7. #7

    Default Re: FAT32 partition mount problem

    On Wed, 03 Sep 2003 04:14:50 GMT, Ko Fei Pu wrote:
    > cannot write to /mnt/w2k even as root.
    > Here's fdisk -l /dev/hda:
    > /dev/hda6 708 1982 10241406 c Win95 FAT32 (LBA)
    > Here's the /etc/fstab:
    > /dev/hda6 /mnt/w2k vfat defaults 0 0
    Change
    /dev/hda6 /mnt/w2k vfat rw,umask=0 0 0

    To test change
    umount /mnt/w2k
    mount /mnt/w2k

    touch /mnt/w2k/junk.txt
    rm /mnt/w2k/junk.txt
    Bit Twister Guest

  8. #8

    Default Re: FAT32 partition mount problem

    I had different behavior for each one of the commands you mentioned,
    here are the output:

    [rootlocalhost mnt]# umount /mnt/w2k
    [rootlocalhost mnt]# ls -l
    total 12
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    [rootlocalhost mnt]# mount /mnt/w2k
    [rootlocalhost mnt]# mount | grep /mnt/w2k
    /dev/hda6 on /mnt/w2k type vfat (rw,umask=0)
    [rootlocalhost mnt]# ls -l
    total 16
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxrwxrwx 9 root root 8192 Dec 31 1969 w2k
    [rootlocalhost mnt]# umount /mnt/w2k
    [rootlocalhost mnt]# ls -l
    total 12
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    [rootlocalhost mnt]# mount /dev/hda6 /mnt/w2k -t vfat
    [rootlocalhost mnt]# mount|grep hda6
    /dev/hda6 on /mnt/w2k type vfat (rw)
    [rootlocalhost mnt]# ls -l
    total 16
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 9 root root 8192 Dec 31 1969 w2k

    why when I used mount /mnt/w2k it worked but not when I used the mount
    /dev/hda6 /mnt/w2k -t vfat?

    Thanks

    Hactar wrote:
    > In article <Bob5b.132669$K44.121422edtnps84>,
    > Ko Fei Pu <kfpu> wrote:
    >
    >>I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD
    >> I have a FAT32 shared partition, and I created the following entry in
    >>my fstab:
    >>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >
    >
    > What do these return (when it's not mounted):
    >
    > mount /mnt/w2k
    > mount | grep hda6
    >
    > mount /dev/hda6 /mnt/w2k -t vfat
    > mount | grep hda6
    >
    > ?
    >
    Ko Fei Pu Guest

  9. #9

    Default Re: FAT32 partition mount problem

    I had different behavior for each one of the commands you mentioned,
    here are the output:

    [rootlocalhost mnt]# umount /mnt/w2k
    [rootlocalhost mnt]# ls -l
    total 12
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    [rootlocalhost mnt]# mount /mnt/w2k
    [rootlocalhost mnt]# mount | grep /mnt/w2k
    /dev/hda6 on /mnt/w2k type vfat (rw,umask=0)
    [rootlocalhost mnt]# ls -l
    total 16
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxrwxrwx 9 root root 8192 Dec 31 1969 w2k
    [rootlocalhost mnt]# umount /mnt/w2k
    [rootlocalhost mnt]# ls -l
    total 12
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    [rootlocalhost mnt]# mount /dev/hda6 /mnt/w2k -t vfat
    [rootlocalhost mnt]# mount|grep hda6
    /dev/hda6 on /mnt/w2k type vfat (rw)
    [rootlocalhost mnt]# ls -l
    total 16
    drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    drwxr-xr-x 9 root root 8192 Dec 31 1969 w2k

    why when I used mount /mnt/w2k it worked but not when I used the mount
    /dev/hda6 /mnt/w2k -t vfat? Sorry for the dumb question (I'm newbie :-(
    ), what should I do to change the fstab entry? Right now I have the
    following statement, which seems not working:
    /dev/hda6 /mnt/w2k vfat defaults 0 0

    Thanks

    Hactar wrote:
    > In article <Bob5b.132669$K44.121422edtnps84>,
    > Ko Fei Pu <kfpu> wrote:
    >
    >>I have a dual boot machine with W2K Pro & RH 9 installed, in the same HD
    >> I have a FAT32 shared partition, and I created the following entry in
    >>my fstab:
    >>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >
    >
    > What do these return (when it's not mounted):
    >
    > mount /mnt/w2k
    > mount | grep hda6
    >
    > mount /dev/hda6 /mnt/w2k -t vfat
    > mount | grep hda6
    >
    > ?
    >
    Ko Fei Pu Guest

  10. #10

    Default Re: FAT32 partition mount problem

    This is what I have in my fstab entry for VFAT:
    /dev/hda6 /mnt/w2k vfat defaults 0 0

    Thanks

    Peter T. Breuer wrote:
    > In comp.os.linux.misc Ko Fei Pu <kfpu> wrote:
    >
    >>>>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >
    > [...]
    >
    >>I tried to add rw, it didn't work, so I changed to -w (according to the
    >
    >
    > Well, don't "try", "do". And yes, it does work. SHow your altered
    > fstab line.
    >
    >
    >>man, this should work), but none of them worked, any other idea?
    >
    >
    > No, man fstab says NOTHING about "-w". That shoudl NOT have worked.
    >
    > No ideas are necessary. Only diagnosis.
    >
    > You are probably mistaking your condition.
    >
    >
    > Peter
    Ko Fei Pu Guest

  11. #11

    Default Re: FAT32 partition mount problem

    In comp.os.linux.misc Ko Fei Pu <kfpu> wrote:
    > This is what I have in my fstab entry for VFAT:
    > /dev/hda6 /mnt/w2k vfat defaults 0 0
    Well, what do you WANT there?

    To me it looks just like what you have below! So it's not what you say
    is (i.e. "altered").
    > Peter T. Breuer wrote:
    >> In comp.os.linux.misc Ko Fei Pu <kfpu> wrote:
    >>>>>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >> Well, don't "try", "do". And yes, it does work. SHow your altered
    >> fstab line.
    What is the problem you are trying to solve? (and please don't top post
    again!).


    Peter
    Peter T. Breuer Guest

  12. #12

    Default Re: FAT32 partition mount problem - SOLVED

    On Wed, 03 Sep 2003 20:58:29 GMT, Ko Fei Pu wrote:
    > Thanks to all of you, the problem is solved but I still don't understand
    > what I did wrong, could someone tell me what was my mistake, please?
    You used defaults instead of settting what you wanted for vfat.
    > Then I changed to:
    > /dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    > and the /etc/mtab showed
    > /dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    > This time the /mnt/w2k showed rwx rights not just rx, what's the difference?
    Go back to the man pages and read what umask does.
    Bit Twister Guest

  13. #13

    Default Re: FAT32 partition mount problem - SOLVED

    In comp.os.linux.setup Ko Fei Pu <kfpu> wrote:
    > Thanks to all of you, the problem is solved but I still don't understand
    Please STOP TOP POSTING! I refuse to answer you until you post
    properly. And properly means "like everyone else is doing and you are
    NOT".
    > what I did wrong, could someone tell me what was my mistake, please?
    > I'm trying to mount my W2K FAT32 partition as rw in Linux.
    > This is my original entry in the fstab:
    > /dev/hda6 /mnt/w2k vfat defaults 0 0
    > with this command, there's no entry in /etc/mtab.
    It's not a COMMAND. It's an entry. It does nothing on its own. And mtab
    is irrelevant - it's just a record of the current state of the system.
    You change it using mount. You wouldn't expect any change in mtab from
    a change in fstab!
    > I tried to use the command below and it still has only rx rights but not w:
    It's not a COMMAND.
    > /dev/hda6 /mnt/w2k vfat auto,rw 0 0
    > and the /etc/mtab showed
    > /dev/hda6 /mnt/w2k vfat (rw) 0 0
    That only means that you rebooted the system. There is no other
    significance.
    > Then I changed to:
    > /dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    > and the /etc/mtab showed
    > /dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    No it didn't!!! That's merely a consequence of your reboot with the new
    fstab! Why are you fixated on mtab?
    > This time the /mnt/w2k showed rwx rights not just rx, what's the difference?
    w is "write", as you asked for with the umask. And you are reading the
    perms wrong anyway.

    Peter
    Peter T. Breuer Guest

  14. #14

    Default Re: FAT32 partition mount problem

    Ko Fei Pu wrote:
    > I had different behavior for each one of the commands you mentioned,
    > here are the output:
    >
    > [rootlocalhost mnt]# umount /mnt/w2k
    > [rootlocalhost mnt]# ls -l
    > total 12
    > drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    > drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    > drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    > [rootlocalhost mnt]# mount /mnt/w2k
    > [rootlocalhost mnt]# mount | grep /mnt/w2k
    > /dev/hda6 on /mnt/w2k type vfat (rw,umask=0)
    > [rootlocalhost mnt]# ls -l
    > total 16
    > drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    > drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    > drwxrwxrwx 9 root root 8192 Dec 31 1969 w2k
    > [rootlocalhost mnt]# umount /mnt/w2k
    > [rootlocalhost mnt]# ls -l
    > total 12
    > drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    > drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    > drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    > [rootlocalhost mnt]# mount /dev/hda6 /mnt/w2k -t vfat
    > [rootlocalhost mnt]# mount|grep hda6
    > /dev/hda6 on /mnt/w2k type vfat (rw)
    > [rootlocalhost mnt]# ls -l
    > total 16
    > drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    > drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    > drwxr-xr-x 9 root root 8192 Dec 31 1969 w2k
    >
    > why when I used mount /mnt/w2k it worked but not when I used the mount
    > /dev/hda6 /mnt/w2k -t vfat? Sorry for the dumb question (I'm newbie :-(
    > ), what should I do to change the fstab entry? Right now I have the
    > following statement, which seems not working:
    > /dev/hda6 /mnt/w2k vfat defaults 0 0
    >
    When you used 'mount /mnt/w2k', you used the setting in
    fstab which set the umask to 000. When you used 'mount
    /dev/hda6 /mnt/w2k -t vfat', you over rode the setting in
    fstab. You did not set the umask, therefor it defaulted to
    the default umask of 022. See man mount for the defaults
    and options for type vfat.

    Homer Welch Guest

  15. #15

    Default Re: FAT32 partition mount problem

    Homer Welch wrote:
    > Ko Fei Pu wrote:
    >
    >> I had different behavior for each one of the commands you mentioned,
    >> here are the output:
    >>
    >> [rootlocalhost mnt]# umount /mnt/w2k
    >> [rootlocalhost mnt]# ls -l
    >> total 12
    >> drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    >> drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    >> drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    >> [rootlocalhost mnt]# mount /mnt/w2k
    >> [rootlocalhost mnt]# mount | grep /mnt/w2k
    >> /dev/hda6 on /mnt/w2k type vfat (rw,umask=0)
    >> [rootlocalhost mnt]# ls -l
    >> total 16
    >> drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    >> drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    >> drwxrwxrwx 9 root root 8192 Dec 31 1969 w2k
    >> [rootlocalhost mnt]# umount /mnt/w2k
    >> [rootlocalhost mnt]# ls -l
    >> total 12
    >> drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    >> drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    >> drwxr-xr-x 2 root root 4096 Aug 31 22:49 w2k
    >> [rootlocalhost mnt]# mount /dev/hda6 /mnt/w2k -t vfat
    >> [rootlocalhost mnt]# mount|grep hda6
    >> /dev/hda6 on /mnt/w2k type vfat (rw)
    >> [rootlocalhost mnt]# ls -l
    >> total 16
    >> drwxr-xr-x 2 root root 4096 Aug 27 04:59 cdrom
    >> drwxr-xr-x 2 root root 4096 Aug 27 06:23 floppy
    >> drwxr-xr-x 9 root root 8192 Dec 31 1969 w2k
    >>
    >> why when I used mount /mnt/w2k it worked but not when I used the mount
    >> /dev/hda6 /mnt/w2k -t vfat? Sorry for the dumb question (I'm newbie
    >> :-( ), what should I do to change the fstab entry? Right now I have
    >> the following statement, which seems not working:
    >> /dev/hda6 /mnt/w2k vfat defaults 0 0
    >>
    >
    > When you used 'mount /mnt/w2k', you used the setting in fstab which set
    > the umask to 000. When you used 'mount /dev/hda6 /mnt/w2k -t vfat', you
    > over rode the setting in fstab. You did not set the umask, therefor it
    > defaulted to the default umask of 022. See man mount for the defaults
    > and options for type vfat.
    >
    I checked the man mount and the defaults option is:
    defaults Use default options: rw, suid, dev, exec,
    auto, nouser, and async.
    so I assumed when I entered defaults in fstab, it'll mount /mnt/w2k as
    rw, that was my confusion.

    TIA

    Ko Fei Pu Guest

  16. #16

    Default Re: FAT32 partition mount problem - SOLVED

    Peter T. Breuer wrote:
    > In comp.os.linux.setup Ko Fei Pu <kfpu> wrote:
    >
    >>Thanks to all of you, the problem is solved but I still don't understand
    >
    >
    > Please STOP TOP POSTING! I refuse to answer you until you post
    > properly. And properly means "like everyone else is doing and you are
    > NOT".
    >
    >
    >>what I did wrong, could someone tell me what was my mistake, please?
    >
    >
    >>I'm trying to mount my W2K FAT32 partition as rw in Linux.
    >>This is my original entry in the fstab:
    >>/dev/hda6 /mnt/w2k vfat defaults 0 0
    >>with this command, there's no entry in /etc/mtab.
    >
    >
    > It's not a COMMAND. It's an entry. It does nothing on its own. And mtab
    > is irrelevant - it's just a record of the current state of the system.
    > You change it using mount. You wouldn't expect any change in mtab from
    > a change in fstab!
    >
    >
    >>I tried to use the command below and it still has only rx rights but not w:
    >
    >
    > It's not a COMMAND.
    >
    >
    >>/dev/hda6 /mnt/w2k vfat auto,rw 0 0
    >>and the /etc/mtab showed
    >>/dev/hda6 /mnt/w2k vfat (rw) 0 0
    >
    >
    > That only means that you rebooted the system. There is no other
    > significance.
    >
    >
    >>Then I changed to:
    >>/dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    >>and the /etc/mtab showed
    >>/dev/hda6 /mnt/w2k vfat rw,umask=0 0 0
    >
    >
    > No it didn't!!! That's merely a consequence of your reboot with the new
    > fstab! Why are you fixated on mtab?
    >
    >
    >>This time the /mnt/w2k showed rwx rights not just rx, what's the difference?
    >
    >
    > w is "write", as you asked for with the umask. And you are reading the
    > perms wrong anyway.
    >
    > Peter
    Peter:
    Thanks for alerting me to the TOP POSTING, I didn't understand it in the
    begining, and I thank you for alerting me to the usenet's etiquette.

    Ko Fei Pu Guest

  17. #17

    Default Re: FAT32 partition mount problem - SOLVED

    Groan!!

    In comp.os.linux.misc Ko Fei Pu <kfpu> wrote:
    > Peter T. Breuer wrote:
    >> In comp.os.linux.setup Ko Fei Pu <kfpu> wrote:
    >>>Thanks to all of you, the problem is solved but I still don't understand
    >>
    >> Please STOP TOP POSTING! I refuse to answer you until you post
    >> properly. And properly means "like everyone else is doing and you are
    >> NOT".
    PLEASE STOP BOTTOM POSTING!!!!

    [huge snip of quoted material]

    Get it right, man! What is this? How do you expect anyone to
    communicate with you?
    > Thanks for alerting me to the TOP POSTING, I didn't understand it in the
    > begining, and I thank you for alerting me to the usenet's etiquette.
    You still don't understand!!!! Please just post NORMALLY! Sob.

    You should be commenting point by point, neither above the whole text
    nor below the whole text, cutting away material that you do not comment
    on! Then we know what you are talking about at any moment!

    Have you seen anyone reply to you any other way?

    Peter
    Peter T. Breuer Guest

  18. #18

    Default Re: FAT32 partition mount problem - SOLVED

    On Thu, 04 Sep 2003 19:45:07 +0200, Peter T. Breuer wrote:
    > You should be commenting point by point, neither above the whole text
    > nor below the whole text, cutting away material that you do not comment
    > on! Then we know what you are talking about at any moment!
    >
    > Have you seen anyone reply to you any other way?
    Unfortunately, he probably has.

    Correctness is not statistical, to paraphrase Orwell. I don't know the
    percentage of non-interleaved posts on Usenet (nor any subset thereof),
    but if it was 99.44% then it would still be wrong.


    Ed Murphy Guest

  19. #19

    Default Re: FAT32 partition mount problem - SOLVED

    Peter T. Breuer wrote:
    > In comp.os.linux.setup Ko Fei Pu <kfpu> wrote:
    >
    >>Thanks to all of you, the problem is solved but I still don't understand
    >
    >
    > Please STOP TOP POSTING! I refuse to answer you until you post
    > properly. And properly means "like everyone else is doing and you are
    > NOT".
    Having Peter Breuer not respond will probably help you get your problem
    fixed faster. While occasionally having a technical clue, he's so rude
    and gives such incomplete answers that they're worse than useless.

    Setting your "umask" to 0 in the mounting causes a bitmask *not* to be
    applied to the default settings of FAT files. Since FAT doesn't have the
    same kind of read/write/execute bits as UNIX file systems have, they
    have to be mapped from Windows to the UNIX/Linux world *somehow*.

    Definitely read the manual pages on the "mount" command for more details.

    Nico Kadel-Garcia Guest

Similar Threads

  1. USB key mount problem with 4.11
    By Louis LeBlanc in forum FreeBSD
    Replies: 2
    Last Post: February 22nd, 08:26 PM
  2. Newbie: Can't mount logical partition
    By Helge Moulding in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: August 10th, 11:48 PM
  3. Help! Resizing Windows XP FAT32 MBR partition.
    By Manolo in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 4th, 06:58 AM
  4. 2 drives- mount points and partition sizes ??
    By myself@elsewheres.not in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 2nd, 12:42 PM
  5. nfs mount problem from linux to aix
    By Lothar Krauss in forum AIX
    Replies: 4
    Last Post: July 1st, 06:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139