I normally run Mandrake 9.0. Last week I installed Win4Lin and Knoppix
Debian. After installing Win4Lin, I found that my winmodem driver was
deleted every time I booteed into it, so I removed it.

The following morning I could boot into Knoppix on the HD, but not
Mandrake. I am using Mandrake's LILO, running Knoppix from a directory
in Mandrake's /mnt.

Trying to boot into Mandrake, I got the "invalid superblock" error with
relation to my / directory, which is on a separate partition from /boot,
/usr, /home and /var. I tried running e2fsck from the original
superblock, which gave no errors. The suggested alternative was
incorrect as I have 4K blocks. Running e2fsck from a valid alternative
twice modified the file system each time, but did not cure the problem.

I tried reinstalling the bootloader with Mandrake Rescue, but got errors
there too. I have checked lilo.conf and /etc/fstab. Just a thought,
with those partitions, surely /mnt is on the / partition, so it is being
accessed? Knoppix is on a different (slave) HD and installed its own
bootloader on the MBR of that HD, but I assume that the bootloader there
is just ignored.

What should I try next?

Doug.