Professional Web Applications Themes

Film Loops and blinking - Macromedia Director Lingo

G'day all I doing some animation, and have successfully had cuePoints in a wav file that trigger the characters blinking. The blinking itself is a film loop that just sits over the character. All well and good. I'm now trying to do a random blink every now and then in the following fashion (this is in an exitFrame): if random(30) = 1 then put "Bruce blink!" sprite(52).member = member( "Bruce slider eyes blinking" ) end if In this case sprite 52 originally has a set of non-blinking eyes in it. The problem is... I'm only getting the first blink (ie ...

  1. #1

    Default Film Loops and blinking

    G'day all

    I doing some animation, and have successfully had cuePoints in a wav file
    that trigger the characters blinking. The blinking itself is a film loop
    that just sits over the character. All well and good.

    I'm now trying to do a random blink every now and then in the following
    fashion (this is in an exitFrame):

    if random(30) = 1 then
    put "Bruce blink!"
    sprite(52).member = member( "Bruce slider eyes blinking" )
    end if

    In this case sprite 52 originally has a set of non-blinking eyes in it. The
    problem is... I'm only getting the first blink (ie I get the put but there
    is no blink). Does anyone know how I can re-set the film loop to start
    again? And if film loops can't be re-triggered by a re-assignment of the
    member, then how come I can blink many times when triggered by cuePoints?
    The member assignment is the same (although different images etc as
    different part of animation).

    Any ideas anyone?

    David.
    ps - Still to get back on boomerang. Will do when get onto it.


    David Downie Guest

  2. #2

    Default Re: Film Loops and blinking

    Did some extra research (I did google before posting, but obviously didn't
    look hard enough).

    Once again, Chuck to the rescue

    "tell sprite 1 to go to frame 1"

    [url]http://groups.google.com.au/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=b4np84%24hv8%241%40forums.macromedia.com[/url]

    Now he's blinking like a champ. Still not sure why it works with the
    cuePoints though, but that isn't my problem.

    David.


    David Downie Guest

Similar Threads

  1. Controlling film loops
    By yoyoyoyoyoyoyoyok in forum Macromedia Director Basics
    Replies: 2
    Last Post: March 7th, 11:17 PM
  2. issue with film loops and memory?
    By AJJA17 webforumsuser@macromedia.com in forum Macromedia Director Lingo
    Replies: 0
    Last Post: December 10th, 02:39 PM
  3. Film Loops Speed Up With Volume Control Knob
    By ScottE in forum Macromedia Director Lingo
    Replies: 2
    Last Post: November 2nd, 12:55 PM
  4. controlling Film Loops with lingo?
    By Loren Schwarz in forum Macromedia Director Lingo
    Replies: 4
    Last Post: September 19th, 09:28 PM
  5. Digital Film / Silicon Film(tm) - for real ?
    By Ken Chandler in forum Photography
    Replies: 2
    Last Post: June 26th, 10:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139