Professional Web Applications Themes

Fit frame to content doesn't work with text... why??? - Adobe Indesign Windows

Does anyone know (Adobe, maybe??) why trying to fit the frame to content (CTRL+ALT+C) ALMOST NEVER WORKS with text? I know this isn't supposed to work when the frame is smaller than the content -- but I am talking about when the frame is larger than the text in it. Every time I do this, it cuts off the last few letters... and then I have to manually resize the text frame myself. I don't understand what the point of this is if it doesn't work properly with text. I realize it's for boxes with images/line-art also but it should ...

  1. #1

    Default Fit frame to content doesn't work with text... why???

    Does anyone know (Adobe, maybe??) why trying to fit the frame to content (CTRL+ALT+C) ALMOST NEVER WORKS with text? I know this isn't supposed to work when the frame is smaller than the content -- but I am talking about when the frame is larger than the text in it.

    Every time I do this, it cuts off the last few letters... and then I have to manually resize the text frame myself.

    I don't understand what the point of this is if it doesn't work properly with text. I realize it's for boxes with images/line-art also but it should really WORK with text. For me, it almost ALWAYS cuts off 3 or 4 letters.

    I am using InDesign CD 3.01 but I remember this happening with 2.02 also. Why has this not been fixed?
    Biz_Notch@adobeforums.com Guest

  2. #2

    Default Re: Fit frame to content doesn't work with text... why???

    There are lots of little pitfalls that can trap the unwary implementer of Fit Frame to Contents and I fear that the implementer of the feature on the menu has been trapped by at least two of them:

    In particular, if there's only one line of text and it tries to collapse in both dimensions it falls foul of:

    1. Corner effects. The space they consume is overlooked by the feature--this could also affect a a vertical-only adjustment if you have a full (or nearly full) last line of text.

    2. Negative tracking. If you have negative tracking applied to the text then the trap is that the last character extends beyond its following insertion point. Unfortunately, the feature uses the position of that insertion point to determine where to collapse to, thereby leaving not enough room for the last character.

    Dave
    Dave_Saunders@adobeforums.com Guest

  3. #3

    Default Re: Fit frame to content doesn't work with text... why???

    Fitting to Frame only seems to work when there are just one word or one line ranged left. More than one line doesn't get fitted.

    There does seem to be something that needs to be fixed here.
    Tony_Stuart@adobeforums.com Guest

  4. #4

    Default Re: Fit frame to content doesn't work with text... why???

    Tony,

    I agree that the feature could be more functional, but what you're describing is the intended functionality. It will only collapse horizontally if there is but one line of text.

    Dave
    Dave_Saunders@adobeforums.com Guest

  5. #5

    Default Re: Fit frame to content doesn't work with text... why???

    Quote Originally Posted by Dave_Saundersadobeforums.com View Post
    Tony,

    It will only collapse horizontally if there is but one line of text.

    Dave
    Presumably you mean 'If there is one line of text' - saying 'If there is but one line of text' means anything other than a single line of text, which is where this feature does not actually work.

    Why this is intended functionality, however, beats me!
    Unregistered Guest

Similar Threads

  1. "Deleted Hidden Page And Image Content" - Doesn't work?
    By Stuart_Brazington@adobeforums.com in forum Adobe Acrobat Macintosh
    Replies: 10
    Last Post: April 4th, 08:19 AM
  2. Submit Form doesn't work with Frame on IE
    By news@adobeforums.com in forum Adobe Acrobat Windows
    Replies: 9
    Last Post: April 14th, 08:57 AM
  3. Export frame for classes doesn't work
    By WiPeOuT in forum Macromedia Flash
    Replies: 0
    Last Post: November 14th, 08:22 AM
  4. Display text in text box - should be simple, doesn't work
    By Jim Owen in forum ASP.NET General
    Replies: 1
    Last Post: July 24th, 05:37 AM
  5. window.opener.location.href doesn't work in frame
    By Leon in forum ASP.NET General
    Replies: 1
    Last Post: June 24th, 01:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139