I have installed the latest version of Flash Player. Now it appears to me that
some flash-based websites ask me to install Flash Player. Is it possible that
the latest version is not compatible to older ones?
Is it possible to have installed both versions? If so, how do I install,
without overwriting the older version?

Jo