Professional Web Applications Themes

Floppy drive on RedHat 9 - Linux Setup, Configuration & Administration

Hi, On RedHat 9, PC INTEL 2GHz, 512MO RAM french guy ;o) Objective : transferring with a floppy some files from a PC/OS Linux to PC/OS Windows and vice-versa (2 different PC physically distants from 1,5m). so + as root I perform the following command lines : disk format under windows 2000 Pro (PC#2) on PC#1, modification of etc/fstab with the new line : /dev/fd0 /mnt/floppy auto noauto, user 0 0 'mount -a' 'mount /mnt/floppy' gives an icon 'floppy' on the desktop 'mount' gives "/dev/fd0 on /mnt/floppy vfat (rw,noexec,nosuid,nodev)" file transfer to /mnt/floppy (disk drive activity) 'umount /mnt/floppy' the icon ...

  1. #1

    Default Floppy drive on RedHat 9

    Hi,

    On RedHat 9, PC INTEL 2GHz, 512MO RAM
    french guy ;o)

    Objective : transferring with a floppy some files from a PC/OS Linux
    to PC/OS Windows and vice-versa (2 different PC physically distants
    from 1,5m).

    so

    + as root I perform the following command lines :

    disk format under windows 2000 Pro (PC#2)
    on PC#1, modification of etc/fstab with the new line :
    /dev/fd0 /mnt/floppy auto noauto, user 0 0
    'mount -a'
    'mount /mnt/floppy' gives an icon 'floppy' on the desktop
    'mount' gives "/dev/fd0 on /mnt/floppy vfat (rw,noexec,nosuid,nodev)"
    file transfer to /mnt/floppy (disk drive activity)
    'umount /mnt/floppy' the icon 'floppy' disappear
    back to windows on PC#2
    I can read the file, OK

    one thing to notice : every file transferred to /mnt/floppy don't keep
    the code permission, they're indicated as rwx for root even if they're
    originally r-x

    + as user the same commands :
    it doesn't work : no permission to put files in /mnt/floppy
    so I perform a su and try to modify ('chmod a+w /mnt/floppy') the file
    permissions, the OS linux answer is 'not allowed to perform this
    modification'.

    from the PC#2 (windows) I copy file on a floppy and I can read it on
    the PC#1 normally , expecting the rights set to rwxr-xr-x in
    /mnt/floppy

    Then I'm a little puzzled, so I'm here.

    1/ How can I change permanently the permission for all user in
    /mnt/floppy in order to keep the permission of the original files ?

    2/ How can I assure that all users cn copy files on floppy whenever
    they want ?

    Help appreciated
    Herv? Guest

  2. #2

    Default Re: Floppy drive on RedHat 9

    Herv? LEBAIL wrote: 

    The VFAT filesystem used on Windows-compatible floppies doesn't support
    Linux file permissions or ownership. You could format the floppy with a
    Linux filesystem like ext2 to keep the permissions, but then you
    couldn't use the floppy in Windows.
     

    The /etc/fstab line for the floppy should have the "owner" option (not
    "user"), so that the user currently logged on the console can mount the
    floppy.

    --
    Markku Kolkka
    fi
    Markku Guest

  3. #3

    Default Re: Floppy drive on RedHat 9

    In article <google.com>,
    Herv? LEBAIL <com> wrote:
    :
    :+ as root I perform the following command lines :
    :
    :disk format under windows 2000 Pro (PC#2)
    :on PC#1, modification of etc/fstab with the new line :
    :/dev/fd0 /mnt/floppy auto noauto, user 0 0
    :'mount -a'
    :'mount /mnt/floppy' gives an icon 'floppy' on the desktop
    :'mount' gives "/dev/fd0 on /mnt/floppy vfat (rw,noexec,nosuid,nodev)"
    :file transfer to /mnt/floppy (disk drive activity)
    :'umount /mnt/floppy' the icon 'floppy' disappear
    :back to windows on PC#2
    :I can read the file, OK
    :
    :one thing to notice : every file transferred to /mnt/floppy don't keep
    :the code permission, they're indicated as rwx for root even if they're
    :originally r-x
    :
    :+ as user the same commands :
    :it doesn't work : no permission to put files in /mnt/floppy
    :so I perform a su and try to modify ('chmod a+w /mnt/floppy') the file
    :permissions, the OS linux answer is 'not allowed to perform this
    :modification'.

    First, there should be no space between "noauto," and "user" in
    /etc/fstab. I suspect that was just a typo in your posting.

    The vfat file systems don't support Unix-style permissions and
    ownership. That has to be faked at mount time. If you perform the
    'mount' command as a regular user, you'll find that the user now
    owns all the files and directories on the floppy and will be able to
    write to them. If you want to override that, read the manpage for
    the 'mount' command and pay particular attention to the "uid",
    "gid", and "umask" options in the section, "Mount options for fat."

    --
    Bob Nichols AT interaccess.com I am "rnichols"
    Robert Guest

Similar Threads

  1. floppy drive a: failing to see disk. drive b: ok. help!
    By Mr Major Thorburn in forum Windows Server
    Replies: 0
    Last Post: June 9th, 06:16 PM
  2. MAC SE Floppy Drive 1.4 meg Floppy Drive (old)
    By Bill in forum Mac Applications & Software
    Replies: 3
    Last Post: October 11th, 04:24 PM
  3. Wallstreet Floppy drive
    By v1r0b1k@despammed.com in forum Mac Applications & Software
    Replies: 13
    Last Post: September 5th, 12:15 PM
  4. OS 10.2 and ext. floppy drive list ...
    By MZiesk in forum Mac Applications & Software
    Replies: 2
    Last Post: August 2nd, 01:35 PM
  5. Installing XP/2K without a floppy drive.
    By Cari \(MS-MVP\) in forum Windows XP/2000/ME
    Replies: 0
    Last Post: July 8th, 07:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139