Professional Web Applications Themes

flv playback works on local system, not on web server - Adobe Flash, Flex & Director

I am hoping someone has a quick answer to this question, many thanks in advance. I am using the new component flvplayer that comes with Flash 8 and am referencing a local .flv file. It is a REALLY simple flash doent with only that component and it references a .flv file that is in the same directory as the .fla file. When I do a test inside of Flash it works great. I can even publish it and when I use the html generated file outside of Flash 8 (using IE), it also works great. When I copy all the ...

  1. #1

    Default flv playback works on local system, not on web server

    I am hoping someone has a quick answer to this question, many thanks in
    advance. I am using the new component flvplayer that comes with Flash 8 and am
    referencing a local .flv file. It is a REALLY simple flash doent with only
    that component and it references a .flv file that is in the same directory as
    the .fla file. When I do a test inside of Flash it works great. I can even
    publish it and when I use the html generated file outside of Flash 8 (using
    IE), it also works great. When I copy all the files (including the skin and
    ..flv file, basically the same files that are on my local hard drive) up to my
    IIS web server however, when I reference the html that was generated all I get
    is a blank white screen. It obviously finds the html, but nothing comes
    up....any ideas, it has to be something simple. All the files on the web
    server are in the same directory.

    skeeze Guest

  2. #2

    Default Re: flv playback works on local system, not on webserver

    It would help if you can post a link. I'ts probably a path issue, but it's all just guessing until we can see the html
    JayCharles Guest

  3. #3

    Default Re: flv playback works on local system, not on webserver

    I'm having that same problem. I understand why it works locally. It's because
    I'm pulling the .flv from my local drive. On my website I have a directory
    called video. In this directory, I place the .swf and the .flv files. In the
    ..swf file under contentpath, I just have the name of the .flv file since it is
    in the same directory. The html file is placed in the root directory, but I
    change the path of the swf file. When I open my web browser and navigate to
    the site, it starts to open the swf, but it will not play the video. I know
    it's opening because it shows my heading text for the video that is part of the
    swf.

    Is there anything I need to do on the server? Any help will be greatly
    appreciated!!!

    jakel03 Guest

  4. #4

    Default Re: flv playback works on local system, not on webserver

    Found the issue. You have to add a mime type on the web server. Directly
    below is the Macromedia solution and below that is another one. THe Macromedia
    one adds the mime type to the server, which would seem the best choice, but the
    Macromedia post has a different description than the second article, I am not
    sure which one is correct. Anybody know? Does it matter? (I applied both
    procedures, so I am not sure which one takes precedence).

    [url]http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_19439[/url]


    [url]http://blogs.ittoolbox.com/c/engineering/archives/004198.asp[/url]
    Adding .FLV MIME Type in IIS
    Posted 5/16/2005 | by Ryan Moore | Comments (0) | TrackBacks (0)
    .FLV files are already the best method for publishing video on the web, and
    are sure to become even better with the new enhancements in Flash 8. When
    serving .flv files off of a Windows Server 2003 (or any other Windows server I
    would imagine) requires setting up the MIME type on the server first (it isn't
    one of the native MIME types on MS servers).
    You can figure out easily if your server is configured to support .flv files
    by posting a .flv file on a server and navigating to the URL of that .flv in a
    browser. If you see a LONG string of garbage on the screen, your server isn't
    set up for .FLVs and needs to have the MIME type set up.
    Adding .flv MIME type in IIS
    1) Select the site to configure in IIS, right click and select "Properties"
    2) Under HTTP Headers Tab, select "File Types" under the MIME Map section and
    select "New Type"
    3) Type ".flv" as the associated extension and "video/x-flv" as the content
    type.
    4) Select "OK" and you're ready to fly!

    skeeze Guest

Similar Threads

  1. flash media server only works local on server
    By sven1973 in forum Macromedia Flash Flashcom
    Replies: 0
    Last Post: December 7th, 05:01 PM
  2. Web Services Works Local But Not On Server
    By MDKelly in forum Macromedia Flash Data Integration
    Replies: 3
    Last Post: September 26th, 03:30 AM
  3. impersonation works on local xp not on web server
    By smyers@quilogy.com in forum ASP.NET Security
    Replies: 3
    Last Post: May 2nd, 03:41 PM
  4. Replies: 1
    Last Post: September 10th, 05:03 PM
  5. Replies: 1
    Last Post: June 26th, 09:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139