Professional Web Applications Themes

G4 has trouble displaying game - Mac Applications & Software

I recently bought a copy of soldier of forturn II for my G4. I put the CD and installed it with no problems. However, when I went to play the game my computer acted like the game was built for a system 4 times as fast. I have a 1.0 GHz G4 with 512 MB RAM and a 64 MB dual display 3D graphics card. the game system requirements are G4 400 MHz, OS X 10.1.5, 128 MB RAM, 16 MB 3D graphics card. Now it's clear my machine should have no trouble with this game. But when I went ...

  1. #1

    Default G4 has trouble displaying game

    I recently bought a copy of soldier of forturn II for my G4. I put
    the CD and installed it with no problems. However, when I went to
    play the game my computer acted like the game was built for a system 4
    times as fast. I have a 1.0 GHz G4 with 512 MB RAM and a 64 MB dual
    display 3D graphics card. the game system requirements are G4 400
    MHz, OS X 10.1.5, 128 MB RAM, 16 MB 3D graphics card. Now it's clear
    my machine should have no trouble with this game. But when I went to
    play it as soon as I started trying to do anything more than walk in a
    straight line the computer would take about 5 seconds to refresh the
    image and by that time I'm dead. I went and took all the game graphic
    and sounds settings down to the lowest level and tried again but with
    no luck. It is like my computer has another program running that it
    taking up 90% of the system resources but I'm not running anything but
    the game. if you got any ideas I'd be willing to try them.
    Daniel Guest

  2. #2

    Default Re: G4 has trouble displaying game

    On Sat, 9 Aug 2003 1:21:44 -0400, Daniel H wrote
    (in message <google.com>):
     

    If you're on OS X, then run 'top' in the terminal and check what's going
    on, maybe there is indeed another program eating up your cpu cycles.

    --
    J Brady

    Jonathan Guest

  3. #3

    Default Re: G4 has trouble displaying game

    Jonathan Brady <myfmail.com> wrote in message news:<on.sympatico.ca>... 
    >
    > If you're on OS X, then run 'top' in the terminal and check what's going
    > on, maybe there is indeed another program eating up your cpu cycles.[/ref]


    here is what 'top' has to say:

    Processes: 48 total, 3 running, 45 sleeping... 131 threads 22:48:07
    Load Avg: 2.44, 2.40, 2.33 CPU usage: 6.5% user, 93.5% sys, 0.0% idle
    SharedLibs: num = 7, resident = 2.20M code, 148K data, 564K LinkEdit
    MemRegions: num = 3201, resident = 53.1M + 7.91M private, 60.1M shared
    PhysMem: 50.7M wired, 171M active, 128M inactive, 350M used, 162M free
    VM: 2.06G + 3.62M 10001(0) pageins, 1752(0) pageouts

    PID COMMAND %CPU TIME #TH #PRTS #MREGS RPRVT RSHRD RSIZE VSIZE
    476 AppleSpell 0.0% 0:00.03 1 17 20 220K 820K 964K 14.7M
    459 top 3.7% 0:53.15 1 14 17 220K 372K 488K 13.6M
    452 tcsh 0.0% 0:00.04 1 10 15 344K 640K 812K 5.73M
    451 login 0.0% 0:00.32 1 12 33 232K 400K 572K 13.7M
    450 Terminal 0.9% 0:09.79 3 58 108 1.23M 6.62M 5.55M 103M
    448 Yahoo! Mes 1.8% 0:10.01 8 129 163 2.79M 10.2M 8.91M 158M
    422 Safari 0.0% 2:47.24 6 158 385 25.5M 16.9M 26.7M 144M
    421 Sherlock 0.0% 0:44.49 14 172 252 8.84M 8.34M 13.9M 123M
    420 iChatAgent 0.0% 0:00.12 2 48 22 304K 1.23M 1.22M 15.5M
    416 Finder 0.0% 0:01.23 1 72 124 2.29M 11.9M 8.46M 113M
    415 SystemUISe 0.0% 0:03.69 2 140 114 1.54M 4.62M 3.49M 99.7M
    414 Dock 0.0% 0:05.06 2 87 119 856K 10.0M 7.88M 101M
    408 pbs 0.0% 0:00.73 2 27 27 372K 984K 1.15M 14.4M
    406 slpd 0.0% 0:02.64 8 51 31 192K 556K 600K 17.8M
    403 httpd 0.0% 0:00.00 1 8 74 72K 1.48M 288K 15.6M
    Daniel Guest

  4. #4

    Default Re: G4 has trouble displaying game

    On Sat, 9 Aug 2003 23:49:20 -0400, Daniel H wrote
    (in message <google.com>):
     

    idle 0%!!!

    Something is definitely eating too many cpu cycles and it's something
    running root/sys.

    type 'top -u' without the quotes into the terminal and the processes
    will be sorted by cpu usage and the top cpu cycles consumer process will
    be on top, see what it is and what's going on with it.

    Restart and see what top gives you right away at startup. The numbers
    should be more reasonable. If you keep going to idle 0% then you need to
    investigate deeper into the system and find out what's taking over your
    system.

    --
    J Brady

    Jonathan Guest

  5. #5

    Default Re: G4 has trouble displaying game

    On Sun, 10 Aug 2003 4:07:04 -0400, Pique wrote
    (in message <100820030907045105%com>):
     

    Is the window manager consuming 50% of cpu cycles constantly? Maybe
    that's normal on a really, really slow machine, but otherwise no it's
    not normal. The only way that I could cause the window manager's cpu
    usage to spike is by grabbing a large safari window (nearly full screen
    on a 20" apple LCD with really complex contents) and moving it back and
    forth as quickly as possbile for a prolongued period and even then the
    usage never passed 40% (on a dual 1.0 GHz G4)

    --
    J Brady

    Jonathan Guest

  6. #6

    Default Re: G4 has trouble displaying game

    In article <newsguy.com>,
    Jonathan Brady <myfmail.com> wrote:

    [...]
     

    Some apps seem to make the Windowmanager more active. When I watch top
    while having for instance UnRarX or MT-NW doing work, I see the
    WindowManager's CPU-usage go up. Quite dramatically sometimes. Hiding
    those apps (while still keeping them doing what they're doing) brings
    down the Windowmnager's CPU-usage. Maybe something to do with the barber
    poles these apps show?

    --
    Free and shareware at <http://www.euronet.nl/~tekelenb/software/>
    Sander Guest

  7. #7

    Default Re: G4 has trouble displaying game

    On Mon, 11 Aug 2003, Pique wrote:
     
    > >
    > > Is the window manager consuming 50% of cpu cycles constantly? Maybe
    > > that's normal on a really, really slow machine, but otherwise no it's
    > > not normal. The only way that I could cause the window manager's cpu
    > > usage to spike is by grabbing a large safari window (nearly full screen
    > > on a 20" apple LCD with really complex contents) and moving it back and
    > > forth as quickly as possbile for a prolongued period and even then the
    > > usage never passed 40% (on a dual 1.0 GHz G4)[/ref]
    > Turns out today it's down at about 10%
    > Guess something was struggling. I'll know where to look when it all
    > gets slow again.
    > iMac G3 500 MHz, OS X10.2.6, 640 Mb ram
    > FWIW
    >
    > I've got 16Mb of video ram on this, and Quartz Extreme is supposed to
    > (by specs) be running, but a utilily I ran to test it said it wasn't.[/ref]
    Not with a Rage 128 it won't.

    Fred

    Frederick Guest

  8. #8

    Default Re: G4 has trouble displaying game

    Frederick Cheung <DUH.ucam.org> wrote in message news:<srcf.societies.cam.ac.uk>... 
    > > Turns out today it's down at about 10%
    > > Guess something was struggling. I'll know where to look when it all
    > > gets slow again.
    > > iMac G3 500 MHz, OS X10.2.6, 640 Mb ram
    > > FWIW
    > >
    > > I've got 16Mb of video ram on this, and Quartz Extreme is supposed to
    > > (by specs) be running, but a utilily I ran to test it said it wasn't.[/ref]
    > Not with a Rage 128 it won't.
    >
    > Fred[/ref]

    Ok, I just restarted my computer and ran top -u first thing. It is
    interesting to note that it took about twice as long as usual for my
    computer to boot back up. Hope this helps.

    245 syslogd 0.0% 0:01.11 1 7 13 80K 276K 160K
    1.28M
    424 Terminal 4.5% 0:00.59 3 59 99 1.16M- 5.01M+ 5.82M
    102M-
    245 syslogd 1.8% 0:01.15 1 7 13 80K 276K 160K
    1.28M
    183 Window Man 0.0% 0:03.03 2 138 365 3.61M 17.6M 19.3M
    172M
    Processes: 44 total, 3 running, 41 sleeping... 104 threads
    00:33:26
    Load Avg: 2.80, 2.60, 2.40 CPU usage: 4.5% user, 95.5% sys, 0.0%
    idle
    SharedLibs: num = 76, resident = 16.5M code, 2.27M data, 6.73M
    LinkEdit
    MemRegions: num = 2166, resident = 13.6M + 5.66M private, 38.2M shared
    PhysMem: 42.9M wired, 50.9M active, 71.2M inactive, 165M used, 347M
    free
    VM: 1.55G + 49.3M 5712(0) pageins, 0(0) pageouts

    PID COMMAND %CPU TIME #TH #PRTS #MREGS RPRVT RSHRD RSIZE
    VSIZE
    0 kernel_tas 93.3% 3:48.57 29 0 - - - 36.2M+
    499M
    424 Terminal 3.4% 0:01.50 3 58 106 1.33M+ 5.02M 6.01M+
    103M+
    434 top 2.9% 0:00.62 1 14 17 192K 292K 488K
    13.6M
    183 Window Man 0.0% 0:03.23 2 138 367 3.63M+ 17.6M 19.3M+
    172M+
    51 kextd 0.0% 0:01.17 2 18 21 792K 616K 828K
    14.9M
    245 syslogd 0.0% 0:01.18 1 7 13 80K 276K 164K
    1.28M
    354 loginwindo 0.0% 0:01.03 4 151 105 1.77M 8.53M 9.16M
    106M
    320 nfsiod 0.0% 0:00.00 1 8 12 12K 288K 84K
    1.27M
    1 init 0.0% 0:00.00 1 9 12 88K 272K 276K
    1.28M
    2 mach_init 0.0% 0:00.09 2 88 15 84K 288K 168K
    1.80M
    78 update 0.0% 0:00.05 1 7 13 52K 260K 104K
    1.26M
    82 dynamic_pa 0.0% 0:00.00 1 10 15 68K 264K 104K
    1.29M
    117 configd 0.0% 0:00.60 3 101 131 380K 1.39M 1.46M
    15.8M
    142 SecuritySe 0.0% 0:00.06 2 32 25 228K 892K 796K
    15.0M
    179 ATSServer 0.0% 0:00.38 2 33 155 424K 3.02M 2.26M
    31.5M
    Daniel Guest

  9. #9

    Default Re: G4 has trouble displaying game

    In article <google.com>,
    com (Daniel H) wrote:

    [...]

    [top -u]
     

    Assuming this is not a snaphsot but this process _stays_ at around 90%,
    I would guess you installed some software that installed a kernel
    extension that is misbehaving. (No idea which software that would be[*],
    but it would have had to ask you for your admin password on installation
    to be able to install a kernel extension.)

    I don't know how to find out which kernel extention that would be. It
    would live either in /Library/Extensions/ or in
    /System/Library/Extensions/

    Not sure either what would be the best way to uninstall it. I'd probably
    move it elsewhere using Terminal ("sudo mv [filepath]"), and immediately
    reboot the machine. But there may be friendlier or more reliable ways.

    [*] I think I recall having heard reports that some of Norton's software
    has bugs like this.

    --
    Free and shareware at <http://www.euronet.nl/~tekelenb/software/>
    Sander Guest

Similar Threads

  1. New 3D Game
    By Paul in forum Macromedia Director 3D
    Replies: 16
    Last Post: November 29th, 12:26 AM
  2. making this game multiuser game
    By hondo3000 in forum Macromedia Director 3D
    Replies: 3
    Last Post: August 9th, 01:29 PM
  3. Replies: 1
    Last Post: July 18th, 09:57 PM
  4. new 3D UFO game
    By Damon Pidhajecky in forum Macromedia Director 3D
    Replies: 1
    Last Post: July 10th, 10:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139