Professional Web Applications Themes

Geforce4 linux setup problem, help needed - Linux Setup, Configuration & Administration

Audience: Me, a Linux newby. 10yrs under M$ from dos to xp(ugh) Specs: AMD 2700XP 1 gig PC2700 RAM Epox EP-8RDA + w/ Nforce2 chipset Adaptec 29160n controller 17gig Maxtor SCSI hd. Sound blaster Live Platinum Nvidia Geforce 4 w/256meg on board. MAG Innovision 19" monitor I am attempting to install Redhat Linux 9 Shrike ISO's. After using the default setup options Anaconda will initialize and probe for Video, Monitor and mouse. It detects a VESA driver generic for the video card. Unkown monitor and Generic wheel mouse. Then: "Attempting to start Xserver 1...2...3... a log is supposed to be ...

  1. #1

    Default Geforce4 linux setup problem, help needed

    Audience: Me, a Linux newby. 10yrs under M$ from dos to xp(ugh)
    Specs:
    AMD 2700XP
    1 gig PC2700 RAM
    Epox EP-8RDA + w/ Nforce2 chipset
    Adaptec 29160n controller
    17gig Maxtor SCSI hd.
    Sound blaster Live Platinum
    Nvidia Geforce 4 w/256meg on board.
    MAG Innovision 19" monitor

    I am attempting to install Redhat Linux 9 Shrike ISO's. After using
    the default setup options Anaconda will initialize and probe for
    Video, Monitor and mouse.

    It detects a VESA driver generic for the video card.
    Unkown monitor
    and Generic wheel mouse.

    Then:
    "Attempting to start Xserver 1...2...3...
    a log is supposed to be generated but I can't find it anywhere.
    Screen goes blank and monitor shutsdown.

    I hope this was a coherent posting of what I am facing and that I have
    provided sufficient information, if more is needed I will be happy to
    provide it.

    Any and all help would be greatly appreciated.

    Thanks
    Todd Guest

  2. #2

    Default Re: Geforce4 linux setup problem, help needed

    Todd Robinette wrote:
     

    ..... jump to runlevel 3. make a note of all your h/w specs,
    to include your monitor's vert/horiz frequency ranges and
    execute the "xf86config" utility and answer appropriately.
    restart xfree and you should be fine
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    "I went into a general store, and they wouldn't sell me
    anything specific". - Steven Wright

    mjt Guest

  3. #3

    Default Re: Geforce4 linux setup problem, help needed

    mjt wrote:
     

    I don't think so. For Nvidia GeForce 4 you need the driver modules from
    nvidia. Download and install them. In your /etc/X11/XF86Config you
    should use the driver "nvidia" (not nv) then. Here's the device section
    of my XF86Config:

    Section "Device"
    Identifier "GeForce"
    Driver "nvidia"
    # Use Nvidias AGP support
    Option "NvAGP" "1"
    EndSection

    HTH,
    Tassilo

    --
    www.fscnrw.de
    Tassilo Guest

  4. #4

    Default Re: Geforce4 linux setup problem, help needed

    Tassilo Horn wrote:
     
    >
    > I don't think so. For Nvidia GeForce 4 you need the driver modules from
    > nvidia. Download and install them. In your /etc/X11/XF86Config you
    > should use the driver "nvidia" (not nv) then. Here's the device section
    > of my XF86Config:
    >
    > Section "Device"
    > Identifier"GeForce"
    > Driver"nvidia"
    > #UseNvidiasAGPsupport
    > Option"NvAGP""1"
    > EndSection[/ref]

    .... yea, but a START, to get xfree running, a default
    configuration is in order. after that, then we can fool
    with the custom nvidia stuff :)
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    Indifference will be the downfall of mankind, but who cares?

    mjt Guest

  5. #5

    Default Re: Geforce4 linux setup problem, help needed

    On Thu, 09 Oct 2003 22:04:28 GMT, mjt
    <com> wrote:
     
    >
    >.... jump to runlevel 3. make a note of all your h/w specs,
    >to include your monitor's vert/horiz frequency ranges and
    >execute the "xf86config" utility and answer appropriately.
    >restart xfree and you should be fine
    >.[/ref]

    Ok, first thank you for the quick response.
    New information:

    I have successfully installed Linux onto my system using text mode
    install.
    I selected the Nvidia 4 DDR generic driver as these most closely
    match my card.
    I entered the monitor specs
    Same problem.

    I will search for the way to logon through the prompt and try
    installing the most recent version of the drivers from nvidia.
    Todd Guest

  6. #6

    Default Re: Geforce4 linux setup problem, help needed

    Todd Robinette wrote:
     

    .... the log will be at: /var/log/XFree86.0.log

    scan that file for (WW) and (EE) entries and post those
    for now. are you SURE you manually entered the values
    for the horiz and vert frequency ranges?
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    Absurdity, n.: A statement or belief manifestly inconsistent
    with one's own opinion. "The Devil's Dictionary"

    mjt Guest

  7. #7

    Default Re: Geforce4 linux setup problem, help needed

    On Thu, 09 Oct 2003 16:45:03 -0400, Todd Robinette
    <rr.com> wrote: 
    Have you tried the ctrl+alt+ -/+ key combo....

    I had a similar problem, until I tried the key combo, turned out the X
    was in a too high a resolution. The key combo changes the current
    resolution....

    Just a thought. It worked for me!
    David. Guest

  8. #8

    Default Re: Geforce4 linux setup problem, help needed

    On Fri, 10 Oct 2003 19:13:05 +0930, David. E. Goble
    <computing> wrote:
     
    >Have you tried the ctrl+alt+ -/+ key combo....
    >
    >I had a similar problem, until I tried the key combo, turned out the X
    >was in a too high a resolution. The key combo changes the current
    >resolution....
    >
    >Just a thought. It worked for me![/ref]

    I just gave that a try to see what would happen, I got some flashes
    out of the monitor and nothing more.

    Thanks though : - )
    Todd Guest

  9. #9

    Default Re: Geforce4 linux setup problem, help needed

    On Thu, 09 Oct 2003 22:04:28 GMT, mjt
    <com> wrote:
     
    >
    >.... jump to runlevel 3.[/ref]

    How does one do this? From the initial title menu?
     


    thanks : - )
    Todd Guest

  10. #10

    Default Re: Geforce4 linux setup problem, help needed

    On Fri, 10 Oct 2003 11:24:48 +0000, Todd Robinette wrote:
     
    >>
    >>.... jump to runlevel 3.[/ref]
    >
    > How does one do this? From the initial title menu?

    >
    >
    > thanks : - )[/ref]

    you might try (as root): X -configure
    this usually results in a working XF86Config file
    as in:

    cd <a_path>
    X -configure
    X -xf86config <a_path>/<the generated xf86config file name>

    and see what happens.

    kirth

    Kirth Guest

  11. #11

    Default Re: Geforce4 linux setup problem, help needed

    Todd Robinette wrote:
     
    >
    > How does one do this? From the initial title menu?[/ref]

    .... boot INTO Linux, if the screen is goofy, do this:
    <ctrl><alt><f1>, log as root, and, "telinit 3"
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    Life would be so much easier if we could just look at the source code.

    mjt Guest

  12. #12

    Default Re: Geforce4 linux setup problem, help needed

    Todd Robinette wrote:
     
    >>
    >>.... jump to runlevel 3.[/ref]
    >
    >
    > How does one do this? From the initial title menu?[/ref]

    "/sbin/telinit 3".

    Read the man page on init and telinit.

    Nico Guest

  13. #13

    Default Re: Geforce4 linux setup problem, help needed

    On Sat, 11 Oct 2003 00:51:42 +0200, "Kirth Gersen"
    <nl> wrote:
     
    >>
    >> How does one do this? From the initial title menu?
    >> 
    >>
    >>
    >> thanks : - )[/ref]
    >
    >you might try (as root): X -configure
    >this usually results in a working XF86Config file
    >as in:
    >
    >cd <a_path>
    >X -configure
    >X -xf86config <a_path>/<the generated xf86config file name>
    >
    >and see what happens.
    >
    >kirth[/ref]

    Thanks to everyone!

    I had too create and modify the xf86config file.

    After a text install the config file didn't exist the last time I
    re-installed.
    I did a complete re-install again and modified the Video section using
    the NV driver.

    Now it works.
    Todd Guest

  14. #14

    Default Re: Geforce4 linux setup problem, help needed

    On Fri, 10 Oct 2003 23:35:48 GMT, mjt
    <com> wrote:
     
    >>
    >> How does one do this? From the initial title menu?[/ref]
    >
    >... boot INTO Linux, if the screen is goofy, do this:
    ><ctrl><alt><f1>, log as root, and, "telinit 3"
    >[/ref]

    BTY, in the Text mode install I set the correct video card driver but
    when I looked in the config file it was set to the one anaconda had
    "probed" VESA Generic. So it appears my selected driver was either not
    changed or was changed back for some reason.

    Thanks again.

    Now I need to find a good back-up utility so I can back up the whole
    thing.
    Todd Guest

Similar Threads

  1. Connectix VirtualPC 5.2 linux Xfree setup problem
    By Kenn White in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: September 29th, 08:42 PM
  2. RedHat Linux setup
    By Daniel in forum Linux Setup, Configuration & Administration
    Replies: 6
    Last Post: September 28th, 05:17 PM
  3. Linux setup problem.
    By Ilian in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: September 8th, 09:36 PM
  4. HELP:How shall I setup linux on this PC?
    By fusali in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: July 24th, 08:22 AM
  5. GeForce4 card
    By Jamin W. Collins in forum Debian
    Replies: 11
    Last Post: July 19th, 09:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139