I have installed the latest Solaris 8 Recommended Patch Cluster on my
SunBlade 100, checked that I have all the required and recommended patches
for Gnome 2.0 (on [url]www.sun.com[/url]) and followed all the troubleshooting steps
in the Gnome 2.0 installation guide on docs.sun.com.

But still, every time I try to launch Gnome as aan ordinary user, it comes
up with a load of errors which prevent it from starting. If I run it from
a failsafe session, the principle error is as follows:


Window manager warning: Failed to contact configuration server; some
possible ca
uses are that you need to enable TCP/IP networking for ORBit, or you have
stale
NFS locks due to a system crash. See [url]http://www.gnome.org/projects/gconf/[/url]
for in
formation. (Details - 1: IOR file '/export/home/rcross/.gconfd/lock/ior'
not op
ened successfully, no gconfd located: No such file or directory 2: IOR file
'/ex
port/home/rcross/.gconfd/lock/ior' not opened successfully, no gconfd
located: N
o such file or directory)

I can log in OK as root (although it does not find the xscreensaver program
and it complains about desktop settings). I don't know why it's
complaining about stale NFS locks when I log in as an ordinary user,
because I don't mount any NFS resources.

I ran truss on gnome-session from the failsafe session, but I could not
find any obvious problems, although, I must admit, I'm not even sure what
to look for.

Any ideas what's going wrong?