Professional Web Applications Themes

GRUB won't boot - Linux Setup, Configuration & Administration

I have a system that won't boot off the HD - I installed RedHat and chose GRUB as the boot loader, but the BIOS comes up and says no OS is found. If I boot off floppy it will boot fine. I have tried running > grub-install /dev/hda and  /dev/hda but neither allowed me to boot from the Harddrive. Is there a way to see what/where grub is installed and where the bios is looking for the os ?? My disk is as follows : Device boot start end type /dev/hda1 * 1 13 Linux /dev/hda2 14 2401 Linux /dev/hda3 ...

  1. #1

    Default GRUB won't boot

    I have a system that won't boot off the HD - I installed RedHat and chose
    GRUB as the boot loader, but the BIOS comes up and says no OS is found. If
    I boot off floppy it will boot fine.

    I have tried running > grub-install /dev/hda
    and 
    /dev/hda
    but neither allowed me to boot from the Harddrive.

    Is there a way to see what/where grub is installed and where the bios is
    looking for the os ??

    My disk is as follows :

    Device boot start end type
    /dev/hda1 * 1 13 Linux
    /dev/hda2 14 2401 Linux
    /dev/hda3 24902 2498 Linux swap

    /dev/hda2 /
    /dev/hda1 /boot
    none /dev/shm

    Geoff.


    Geoff Guest

  2. #2

    Default Re: GRUB won't boot


    "Geoff" <com> wrote in message news:... 
    If 
    > /dev/hda
    > but neither allowed me to boot from the Harddrive.
    >
    > Is there a way to see what/where grub is installed and where the bios is
    > looking for the os ??
    >
    > My disk is as follows :
    >
    > Device boot start end type
    > /dev/hda1 * 1 13 Linux
    > /dev/hda2 14 2401 Linux
    > /dev/hda3 24902 2498 Linux swap
    >
    > /dev/hda2 /
    > /dev/hda1 /boot
    > none /dev/shm
    >
    > Geoff.
    >
    >[/ref]


    Geoff Guest

  3. #3

    Default Re: GRUB won't boot

    On Fri, 09 Jan 2004 16:02:37 -0500, Geoff wrote:
     

    Is there some reason you didn't include your grub configuration file?

    --
    -Joseph-
    Newbies, don't let some of our people's nastiness put you off...
    http://users.netwit.net.au/~pursang/l-faq.pdf
    http://www.gentoo.org/doc/en/index.xml

    Joseph Guest

  4. #4

    Default Re: GRUB won't boot


    Try adding lba32 to grub.conf

    Kiran

    On Fri, 09 Jan 2004 21:24:22 -0500, Joseph wrote:
     
    >
    > Is there some reason you didn't include your grub configuration file?[/ref]

    Kiran Guest

  5. #5

    Default Re: GRUB won't boot

    "Geoff" <com> wrote in message news:<OFELb.109300$bellglobal.com>... 
    > /dev/hda
    > but neither allowed me to boot from the Harddrive.
    >
    > Is there a way to see what/where grub is installed and where the bios is
    > looking for the os ??
    >
    > My disk is as follows :
    >
    > Device boot start end type
    > /dev/hda1 * 1 13 Linux
    > /dev/hda2 14 2401 Linux
    > /dev/hda3 24902 2498 Linux swap
    >
    > /dev/hda2 /
    > /dev/hda1 /boot
    > none /dev/shm
    >
    > Geoff.[/ref]

    [#] grub-install /dev/hda
    (should place Stage 1 in MBR)
    [#] grub-install --root-directory=/boot /dev/hda
    (makes sure grub knows where Stage 1&2 are located)
    should have worked from a command prompt -- you did log in as root?

    Did you try:
    [#] grub-install '(hd0)'

    The info page deprecates this, but I've never heard of a failure. Why
    didn't you install grub to MBR when you installed RH? Any other OS on
    disk in past -- not that it should make a difference?

    Anyway, your BIOS is complaing that there is no boot loader in MBR (or
    grub can't find stage 2, but that usually leaves you with the blinking
    cursor) and the floppy boot confirms the rest of the install went ok.
    Is there a chance you told Anaconda to _not_ install grub to MBR?
    That's the default.

    As a weird check, try:
    [rootpbrain]# cat /boot/grub/device.map
    # this device map was generated by anaconda
    (fd0) /dev/fd0
    (hd0) /dev/hda


    Still, the commands you tried (as root) should place grub Stage 1 in
    MBR. If it doesn't work, read:
    [#] info grub

    See especially the Installation section
    and the
    Creating a GRUB boot floppy
    Installing GRUB natively
    sub-sections in case you need to do this "real manually".

    Maybe you have the misfortune to be the first person I've heard of who
    had problems installing grub from a Linux shell prompt.

    hth,
    prg
    email above disabled
    P Guest

  6. #6

    Default Re: GRUB won't boot

    ["Followup-To:" header set to alt.os.linux.]
    On Fri, 9 Jan 2004 16:02:37 -0500, Geoff
    <com> wrote: 
    Does your system have "virus protection" in the BIOS? If it does, turn
    it off.

    --
    Absurd Procrustean Egghead Cornstarch Variant Bill Mar
    Bill Guest

Similar Threads

  1. Grub boot problem
    By RaidenSix in forum Ubuntu
    Replies: 4
    Last Post: June 4th, 03:32 PM
  2. Where To Put GRUB Boot mbr???
    By Don in forum Ubuntu
    Replies: 4
    Last Post: June 4th, 06:39 AM
  3. GRUB and boot.b
    By Allen in forum Linux Setup, Configuration & Administration
    Replies: 6
    Last Post: January 1st, 04:06 AM
  4. new XP installation won't boot from grub
    By Jed in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: November 6th, 02:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139