Professional Web Applications Themes

Havok problem - Macromedia Director 3D

Hi All, I have a Havok related question thats really puzzling me. Ive : set up the Havok physics scene (inserted not imported) set the environment (a cubicVR) to a fixed rigid body, Set a sphere to a moveable rigid body, Applied 'move model' and Mouse move to the sphere. Everythings fine except the sphere doesnt drop straight down to stop on the floor, it moves horizontally straight through the wall! I though maybe id somehow accidentally got my whole environment rotated by 90 degrees, but this is not the case - so why do you think Havok is doing ...

  1. #1

    Default Havok problem

    Hi All,

    I have a Havok related question thats really puzzling me.

    Ive :

    set up the Havok physics scene (inserted not imported)

    set the environment (a cubicVR) to a fixed rigid body,

    Set a sphere to a moveable rigid body,

    Applied 'move model' and Mouse move to the sphere.

    Everythings fine except the sphere doesnt drop straight down to stop on the
    floor, it moves horizontally straight through the wall!
    I though maybe id somehow accidentally got my whole environment rotated by 90
    degrees, but this is not the case - so why do you think Havok is doing this??
    Im probably making some really simple error - Havok newbie!

    Thanks for reading this, any help is most appreciated.

    Dave

    DaveRaith Guest

  2. #2

    Default Re: Havok problem

    first of all, dont use the build in behaviors with havok, this will not work.
    to move a havok body you have to apply forces or velocity to it.

    your gravity vector seems to be the z-axis. it should be the negative y-axis.

    3dsmax uses the zaxis for up and down most other apps use the yaxis for up and
    down.

    what you have to do is:

    test havok with some lingo generated models,
    build a box for the ground, and try to move a second box or sphere with
    forces on it.

    throw out all havok behaviors! its not very hard to write some lingo for these
    things on your own.



    hondo3000 Guest

Similar Threads

  1. havok collision detection problem
    By JustStupid in forum Macromedia Director 3D
    Replies: 2
    Last Post: August 4th, 11:08 PM
  2. Problem with racing game using Havok
    By mk0505 in forum Macromedia Director 3D
    Replies: 1
    Last Post: April 24th, 06:21 PM
  3. Havok rigidbody problem
    By Mikael Hellqvist in forum Macromedia Director 3D
    Replies: 3
    Last Post: February 17th, 07:56 PM
  4. Havok xtra problem when previewing
    By Agustín María Rodríguez in forum Macromedia Director 3D
    Replies: 3
    Last Post: September 19th, 12:32 AM
  5. Problem setting dragParameters in Havok
    By John Simmons in forum Macromedia Director 3D
    Replies: 0
    Last Post: August 22nd, 11:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139