Professional Web Applications Themes

Help - Linux Setup, Configuration & Administration

I have installed RedHat 9.0 on my laptop. I use my laptop at work with a lan connection at home without. When I boot my system at work it is very fast, but when I boot it at home without the connection the boot is very slow, in particular for the "starting system logger" and "semdmail". Hovewer, the boot process does not fail, but the system is slow. Can you help me? Thank you in advance, NDM -- Posted via Mailgate.ORG Server - http://www.Mailgate.ORG...

  1. #1

    Default Help

    I have installed RedHat 9.0 on my laptop.
    I use my laptop at work with a lan connection at home without.
    When I boot my system at work it is very fast, but
    when I boot it at home without the connection the boot is very
    slow, in particular for the "starting system logger" and "semdmail".
    Hovewer, the boot process does not fail, but the system is slow.

    Can you help me?

    Thank you in advance,

    NDM


    --
    Posted via Mailgate.ORG Server - http://www.Mailgate.ORG
    NDM Guest

  2. #2

    Default Re: Help

    On Thu, 16 Oct 2003 15:20:02 +0000, NDM wrote:
     

    Check the network settings.
    Nobody Guest

  3. #3

    Default Re: Help

    NDM wrote:
     

    Most likely you edited your /etc/hosts file. Put the original back, line by
    line, until the problem goes away, in particular this line must be present
    as shown:

    127.0.0.1 localhost.localdomain localhost

    --
    Paul Lutus
    http://www.arachnoid.com

    Paul Guest

  4. #4

    Default Att Paul Litus

    Paul Lutus wrote:
     
    >
    > Most likely you edited your /etc/hosts file. Put the original back, line
    > by line, until the problem goes away, in particular this line must be
    > present as shown:
    >
    > 127.0.0.1 localhost.localdomain localhost
    >[/ref]

    Would there be any conflict "/etc/sysconfig/network" has a
    different entry for hostname?.

    If so how can the hostname be changed safely and legitimately?

    --
    faeychild.
    faeychild Guest

  5. #5

    Default Re: Att Paul Litus

    faeychild wrote:
     
    >>
    >> Most likely you edited your /etc/hosts file. Put the original back, line
    >> by line, until the problem goes away, in particular this line must be
    >> present as shown:
    >>
    >> 127.0.0.1 localhost.localdomain localhost
    >>[/ref]
    >
    > Would there be any conflict "/etc/sysconfig/network" has a
    > different entry for hostname?.[/ref]

    Please explain. What hostname? "localhost"? You cannot use this name for a
    hostname. It's reserved to the loopback interface.
     

    1. Change to runlevel 1 or whatever runlevel disables network services on
    your distribution.

    2. Edit /etc/sysconfig/network, change hostname. Also some other files in
    this tree may have the old hostname, check with:

    # grep (old host name) -R /etc/sysconfig/*

    Edit as required.

    3. Issue this:

    # hostname (new host name)

    4. Check that /etc/hosts has the correct hostname, if it has an entry at all
    for the local machine's hostname.

    5. Return to normal network-aware runlevels.

    --
    Paul Lutus
    http://www.arachnoid.com

    Paul Guest

  6. #6

    Default Re: Att Paul Litus

    Paul Lutus wrote:
     
    >>
    >>Would there be any conflict "/etc/sysconfig/network" has a
    >>different entry for hostname?.[/ref]
    >
    >
    > Please explain. What hostname? "localhost"? You cannot use this name for a
    > hostname. It's reserved to the loopback interface.[/ref]

    I use it all the time. It's a completely reasonable default hostname in
    /etc/sysconfig/network for systems that get their hostname reset through
    DHCP.
     
    >
    >
    > 1. Change to runlevel 1 or whatever runlevel disables network services on
    > your distribution.
    >
    > 2. Edit /etc/sysconfig/network, change hostname. Also some other files in
    > this tree may have the old hostname, check with:[/ref]

    No. If you have a static IP addreess, put it in /etc/hosts and when most
    Linux systems reboot these days, they will detect the
    "localhost.localdomain" hostname and reset it appropriately to match the
    /etc/hosts entry as you enable your network configuration.

    It's a bit obscure, but lets things work muc݀>%tter in stand-alone mode
    before your network is enabled.

    Nico Guest

  7. #7

    Default Re: Att Paul Litus

    Nico Kadel-Garcia wrote:

    < snip >
     
    >
    > I use it all the time. It's a completely reasonable default hostname in
    > /etc/sysconfig/network for systems that get their hostname reset through
    > DHCP.[/ref]

    We've already establishewd that DHCP is not present, in parts of the thread
    long since snipped out. Also, as general advice without specifics, it is a
    VBI to assume that "localhost" is a safe name to use for any address except
    127.0.0.1.
     
    >>
    >>
    >> 1. Change to runlevel 1 or whatever runlevel disables network services on
    >> your distribution.
    >>
    >> 2. Edit /etc/sysconfig/network, change hostname. Also some other files in
    >> this tree may have the old hostname, check with:[/ref]
    >
    > No. If you have a static IP addreess, put it in /etc/hosts and when most
    > Linux systems reboot these days, they will detect the
    > "localhost.localdomain" hostname and reset it appropriately to match the
    > /etc/hosts entry as you enable your network configuration.[/ref]

    No. The /etc/hosts entry will not change the system hostname. This must be
    done explicitly in the configuration files. It doesn't matter if there is
    static addressing and a NIC with an address matched in /etc/hosts. The
    system will still provide the defined hostname (if there is one) to the
    command "hostname" and all the ancillary uses of this information.

    --
    Paul Lutus
    http://www.arachnoid.com

    Paul Guest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139