Professional Web Applications Themes

Help!!!! - Macromedia Flash Sitedesign

I have created a flash menu. I do not know how I can include it on the webpage(HTML). Any help?...

Sponsored Links
  1. #1

    Default Help!!!!

    I have created a flash menu. I do not know how I can include it on the webpage(HTML). Any help?


    Sponsored Links
    enutty webforumsuser@macromedia.com Guest

  2. #2

    Default Re: Help!!!!

    There is an option in flash in the Publish menu that creates the correct
    HTML page for you, just goto Publish.

    Here is the HTML code anyway if your not sure:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.ca
    b#version=6,0,29,0" width="550" height="400" hspace="0" vspace="0">
    <param name="movie" value="NAMEOFYOURFILE.swf">
    <param name="quality" value="high">
    <param name="menu" value="false">
    <embed src="NAMEOFYOURFILE.swf" width="500" height="400"
    hspace="0" vspace="0" quality="high"
    pluginspage="http://www.macromedia.com/go/getflashplayer"
    type="application/x-shockwave-flash" menu="false"></embed></object>

    "enutty" <webforumsusermacromedia.com> wrote in message
    news:bn635j$2b8$1forums.macromedia.com...
    > I have created a flash menu. I do not know how I can include it on the
    webpage(HTML). Any help?
    >
    >

    Spiralmind Guest

  3. #3

    Default Re: Help!!!!

    That is what I used to do earlier for all the others. But the menu file has a movieclip. When I pulish -HTML It shows the menu for a sec and then disappers. I have the loop playback checked. Does movie clip need any other special kind of pulish or I really don't know as this is the first time I am working with movieclips.
    Thanks


    enutty webforumsuser@macromedia.com Guest

  4. #4

    Default Re: Help!!!!

    If you zip and upload the fla, i`ll have a look.

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  5. #5

    Default Re: Help!!!!



    [url]http://webforums.macromedia.com/attachments/menu1111111.zip[/url]



    enutty webforumsuser@macromedia.com Guest

  6. #6

    Default Re: Help!!!!

    on the first frame of the mc you have put "getURL("www.airportmarine.com");"
    Remove this and it publishes ok.

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  7. #7

    Default Re: Help!!!!

    But isn't that the way you call the different pages from the menu.
    I put that there so when some on clicks the home option on the menu they will be redirected to that webpage??
    Is there another way to call the pages in the movie clip submenu and also make it publish


    enutty webforumsuser@macromedia.com Guest

  8. #8

    Default Re: Help!!!!

    Just add param menu = false in the HTML

    "enutty" <webforumsusermacromedia.com> wrote in message
    news:bn635j$2b8$1forums.macromedia.com...
    > I have created a flash menu. I do not know how I can include it on the
    webpage(HTML). Any help?
    >
    >

    Spiralmind Guest

  9. #9

    Default Re: Help!!!!

    just insert a frame in all layers before "home",copy the mc and paste in place and put a stop() action in the first frame.

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  10. #10

    Default Re: Help!!!!

    what about the remaining links. How do I redirect each link to a different page


    enutty webforumsuser@macromedia.com Guest

  11. #11

    Default Re: Help!!!!

    You might also be better to remove the getURL action from "home" and put it just on the button.

    on (release) {
    getURL("http://www.whatever.com");
    }
    on (rollOver){
    gotoAndStop("home");
    }

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  12. #12

    Default Re: Help!!!!

    I did try and put the code geturl(...) on the button itself. It works. Thankyou so much. BUT...the mouse hand keeps blinking when I hover over the button. Do you have any idea why this is happening


    enutty webforumsuser@macromedia.com Guest

  13. #13

    Default Re: Help!!!!

    Yeh, I noticed that yesterday. I fixed it by doing something very simple but i can`t remember what it was now. Anyway here is the working file so hopefully you can work out what the problem was yourself.

    [url]http://webforums.macromedia.com/attachments/menu111111111.zip[/url]

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  14. #14

    Default Re: Help!!!!

    Thanks. I have one more question. Do you know how I can use the same code geturl(...) to call the other pages with the menu - sub menu items



    enutty webforumsuser@macromedia.com Guest

  15. #15

    Default Re: Help!!!!

    Just do exactly the same as the first button,putting the url you want in the on(release) event and the frame in the on(rollOver). In the sub-menu buttons just put the url.
    Another thing i noticed was that your submenu buttons require for the text to be clicked on. You should create a keyframe in the hitstate and draw a rectangle.

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  16. #16

    Default Re: Help!!!!

    Hi there,
    I am still working on the same menu. I get errors when I put the geturl() for the submenu. I am attaching it. Also I could not figure out why the mouse flickers from hand to arrow. Can you pleaseee look at it.
    Thanks

    [url]http://webforums.macromedia.com/attachments/Menu1111111.zip[/url]


    enutty webforumsuser@macromedia.com Guest

  17. #17

    Default Re: Help!!!!

    Did anyone get a chance to check my script


    enutty webforumsuser@macromedia.com Guest

  18. #18

    Default Re: Help!!!!

    You need to add on(release)

    eg/ on (release) {
    getURL("http://www.smithsoftware.net/airportmarine/boats.asp?t=s&id=1A");
    }

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  19. #19

    Default Re: Help!!!!

    ps/ you need to draw a square in the "hit" frames of the sub menu buttons

    Certified but not by Macromedia!
    myurl
    stwingy webforumsuser@macromedia.com Guest

  20. #20

    Default HELP!!!!

    hello

    i was just wondering if it is possible for me to complete an animation in
    director and copy it to dvd in a format that will play on a playstation 2

    is there a way around it. in desperate need to find out because iam doing a
    job for a client so i dont want to waste my time doing it if it isnt possible.

    thanks for your help

    cheers

    steve_cddesign Guest

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139